source: projects/specs/trunk/p/python-cups/python-cups-vl.spec @ 12056

Revision 12056, 4.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%{?filter_setup:
2%filter_provides_in %{python_sitearch}/.*\.so$
3%filter_setup
4}
5
6%define py3dir  %{_builddir}/python3-%{name}-%{version}-%{release}
7%define __python3 /usr/bin/python3
8%define python3_sitearch  %(%{__python3} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")
9%define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(0))")
10
11Summary:       Python bindings for CUPS
12Name:          python-cups
13Version:       1.9.74
14Release:       1%{?_dist_release}
15URL:           http://cyberelk.net/tim/software/pycups/
16Source:        http://cyberelk.net/tim/data/pycups/pycups-%{version}.tar.bz2
17License:       GPLv2+
18Group:         Development/Languages
19BuildRequires: cups-devel
20BuildRequires: python-devel
21BuildRequires: python3-devel
22BuildRequires: epydoc
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop
27
28%description
29This package provides Python bindings for CUPS API,
30known as pycups. It was written for use with
31system-config-printer, but can be put to other uses as well.
32
33%package -n python3-cups
34Summary:       Python3 bindings for CUPS API, known as pycups.
35Group:         Development/Languages
36
37%description -n python3-cups
38This package provides Python bindings for CUPS API,
39known as pycups. It was written for use with
40system-config-printer, but can be put to other uses as well.
41
42This is a ported release for python 3
43
44%package doc
45Summary:       Documentation for python-cups
46Group:         Documentation
47
48%description doc
49Documentation for python-cups.
50
51%prep
52%setup -q -n pycups-%{version}
53
54rm -rf %{py3dir}
55cp -a . %{py3dir}
56
57%build
58make CFLAGS="%{optflags} -fno-strict-aliasing"
59make doc
60
61pushd %{py3dir}
62CFLAGS="%{optflags}" %{__python3} setup.py build
63popd
64
65
66%install
67make install DESTDIR="%{buildroot}"
68
69pushd %{py3dir}
70%{__python3} setup.py install -O1 --skip-build --root %{buildroot}
71chmod 755 %{buildroot}%{python3_sitearch}/cups*.so
72popd
73
74%files
75%license COPYING
76%doc README NEWS TODO
77%{python_sitearch}/cups.so
78%{python_sitearch}/pycups*.egg-info
79%{_rpmconfigdir}/fileattrs/psdriver.attr
80%{_rpmconfigdir}/postscriptdriver.prov
81
82%files -n python3-cups
83%license COPYING
84%doc README NEWS
85%{python3_sitearch}/cups.cpython-3*.so
86%{python3_sitearch}/pycups*.egg-info
87%{_rpmconfigdir}/fileattrs/psdriver.attr
88%{_rpmconfigdir}/postscriptdriver.prov
89
90%files doc
91%doc examples html
92
93%changelog
94* Wed Apr 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.74-1
95- new upstream release.
96
97* Sat Nov 17 2018 Toshiaki Ara <ara_t@384.jp> 1.9.72-1
98- new upstream release.
99
100* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.66-1
101- new upstream release.
102
103* Sat Sep 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.58-1
104- new upstream release.
105- built for Vine Linux.
106
107* Thu Jun  9 2011 Tim Waugh <twaugh@redhat.com> - 1.9.57-1
108- 1.9.57.  Fixes rpm provides script (bug #712027).
109
110* Sun Mar 20 2011 Tim Waugh <twaugh@redhat.com> - 1.9.55-1
111- 1.9.55.  Support for IPP "resolution" type.
112
113* Wed Feb 23 2011 Tim Waugh <twaugh@redhat.com> - 1.9.54-1
114- 1.9.54.  The rpm hook is now upstream.
115
116* Wed Feb 23 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-5
117- Use rpmconfigdir macro throughout.
118
119* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.53-4
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
121
122* Tue Jan 25 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-3
123- Fixed typo in psdriver.attr that prevented PPD files from being
124  scanned when generating postscriptdriver tags.
125
126* Thu Jan 20 2011 Tim Waugh <twaugh@redhat.com> - 1.9.53-2
127- Moved postscriptdriver RPM tagging machinery here.  Fixed
128  leading/trailing whitespace in tags as well.
129
130* Wed Dec 15 2010 Tim Waugh <twaugh@redhat.com> - 1.9.53-1
131- 1.9.53 fixing a thread-local storage issue (bug #662805).
132
133* Wed Nov 17 2010 Jiri Popelka <jpopelka@redhat.com> - 1.9.52-2
134- Fixed rpmlint errors/warnings (#648986)
135- doc subpackage
136
137* Mon Nov 01 2010 Jiri Popelka <jpopelka@redhat.com> - 1.9.52-1
138- Initial RPM spec file
Note: See TracBrowser for help on using the repository browser.