source: projects/specs/trunk/p/python-cssutils/python-cssutils-vl.spec @ 8158

Revision 8158, 4.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3%define betaversion b3
4
5Summary: CSS Cascading Style Sheets library for Python
6Summary(ja): Python 用 CSS カスケーディング・スタイル・シート ライブラリ
7Name: python-cssutils
8Version: 0.9.7
9Release: 3%{?betaversion:.%betaversion}%{?_dist_release}
10License: LGPLv3+
11Group: Development/Libraries
12URL: http://cthedot.de/cssutils/
13Source: http://cssutils.googlecode.com/files/cssutils-%{version}%{?betaversion:%betaversion}.zip
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15# Required at runtime for the css* executables
16Requires: python-setuptools
17BuildRequires: python-devel
18BuildRequires: python-setuptools
19BuildArch: noarch
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25A Python package to parse and build CSS Cascading Style Sheets. DOM only, not
26any rendering facilities.
27
28%description -l ja
29CSS カスケーディング・スタイル・シートの作成と構文解析用の Pythonパッケージ
30です。ただし DOM にのみ対応しており、レンダリングには対応していません。
31
32
33%package doc
34Summary: Documentation for the CSS Cascading Style Sheets library for Python
35Summary(ja): Python 用 CSS カスケーディング・スタイル・シート ライブラリのドキュメント
36Group: Applications/Documentation
37
38%description doc
39This is the documentation for python-cssutils, a Python package to parse and
40build CSS Cascading Style Sheets.
41
42%description doc -l ja
43CSS カスケーディング・スタイル・シートの作成と構文解析用の Pythonパッケージ
44である、python-cssutils のドキュメントです。
45
46
47%prep
48%setup -q -n cssutils-%{version}%{?betaversion:%betaversion}
49# Convert all CRLF files, keeping original timestamps
50for FILE in `find . -type f -exec grep -Gl '\r\n' {} \;`; do
51    tr -d '\r' < ${FILE} > ${FILE}.tmp
52    touch -r ${FILE} ${FILE}.timestamp
53    cat ${FILE}.tmp > ${FILE}
54    touch -r ${FILE}.timestamp ${FILE}
55    %__rm -f ${FILE}.timestamp ${FILE}.tmp
56done
57
58
59%build
60%{__python} setup.py build
61
62
63%install
64%{__rm} -rf ${RPM_BUILD_ROOT}
65%{__python} setup.py install \
66    --single-version-externally-managed \
67    -O1 \
68    --skip-build \
69    --root ${RPM_BUILD_ROOT}
70
71
72%clean
73%{__rm} -rf ${RPM_BUILD_ROOT}
74
75
76%files
77# The sources have some 2755 mode directories (as of 0.9.5.1), fix here
78%defattr(-,root,root,0755)
79%doc CHANGELOG.txt COPYING* docs/ README.txt
80%{_bindir}/csscapture
81%{_bindir}/csscombine
82%{_bindir}/cssparse
83%{python_sitelib}/cssutils-*.egg-info/
84%{python_sitelib}/cssutils/
85%{python_sitelib}/encutils/
86# # This is a way too generic name!
87# %exclude %{python_sitelib}/tests/
88
89%files doc
90%defattr(-,root,root,-)
91%doc docs/* examples/
92
93
94%changelog
95* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.7-3.b3
96- rebuild with VineSeed environment
97
98* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.7-2.b3
99- rebuild with python-2.7.2
100
101* Thu Aug 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.b3
102- new upstream release
103
104* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.6-1
105- new upstream release
106
107* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.5.1-2
108- rebuild with python-2.6
109
110* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.9.5.1-1
111- initial build for Vine Linux based on fedora package
112
113* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.9.5.1-4
114- Rebuild for Python 2.6
115
116* Fri Oct 10 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-3
117- Add missing python-setuptools BR, split off doc sub-package (mschwendt).
118
119* Thu Oct  9 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-2
120- Update license, group, add python-setuptools requirement (mschwendt).
121
122* Tue Aug 19 2008 Matthias Saou <http://freshrpms.net/> 0.9.5.1-1
123- Update to 0.9.5.1.
124
125* Fri Aug  8 2008 Matthias Saou <http://freshrpms.net/> 0.9.5-1
126- Update to 0.9.5 final.
127
128* Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.9.5b2-0.2.rc2
129- Convert CRLF end of lines.
130- Patch out #!/... magic from python files meant to be included and not run.
131
132* Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.9.5b2-0.1.rc2
133- Initial RPM release.
134
Note: See TracBrowser for help on using the repository browser.