source: projects/specs/trunk/p/python-crypto/python-crypto-vl.spec @ 8155

Revision 8155, 5.6 KB checked in by kenta, 10 years ago (diff)
  • python-crypto
    • new upstream release
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary:        Cryptography library for Python
5Summary(ja):    Python 用 Cryptography ライブラリ
6Name:           python-crypto
7Version:        2.6.1
8Release:        1%{?_dist_release}
9License:        Python License (CNRI Python License)
10Group:          Development/Libraries
11URL:            http://www.dlitz.net/software/pycrypto/
12Source:         http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
13
14Patch0:         dont-drop-g.patch
15Patch1:         fix-epydoc-ignore.patch
16Patch2:         fix-unresolved-reference-size.patch
17
18BuildRequires:  python >= 2.2
19BuildRequires:  python-devel >= 2.2
20BuildRequires:  gmp-devel >= 5
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23%description
24Python-crypto is a collection of both secure hash functions
25(such as MD5 and SHA), and various encryption algorithms
26(AES, DES, IDEA, RSA, ElGamal, etc.).
27
28%prep
29%setup -n pycrypto-%{version} -q
30%patch0 -p1
31%patch1 -p1
32%patch2 -p1
33
34# Remove spurious shellbangs
35%{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
39
40%install
41%{__rm} -rf %{buildroot}
42%{__python} setup.py install -O1 --skip-build --root %{buildroot}
43
44# Remove group write permissions on shared objects
45/usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
46        -exec %{__chmod} g-w {} \;
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52%files
53%defattr(-,root,root,-)
54%doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
55#%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
56%{python_sitearch}/
57
58%changelog
59* Sun Dec 15 2013 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-1
60- new upstream release
61- drop Patch3: doc.patch
62
63* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6-1
64- new upstream release
65
66* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
67- rebuild with python-2.7.2
68
69* Mon Jan 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5-1
70- new upstream release
71- added patches(1,2,3) from Debian
72
73* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.1-1
74- new upstream release
75- dropt patch1
76
77* Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-2
78- rebuilt with rpm-4.8.1 for pkg-config
79
80* Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
81- new upstream release
82- changed %%files
83
84* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
85- fix %files (change directory from %{python_sitelib} to %{python_sitearch})
86
87* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
88- new upstream release
89
90* Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
91- new upstream release
92- changed URL and SOURCE to new upstream
93- dropt patch0,2
94- replaced patch1 from Debian newer
95- added pacth3 from Debian
96- changed document files dir in %%files
97
98* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
99- rebuild with python-2.6
100
101* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
102- added Patch0,1,2 from Debian to fix some problem
103
104* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
105- initial build for VineSeed
106
107* Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
108- Fix libdir handling so it works on more arches than x86_64
109
110* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
111- Fix typo
112
113* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
114- Remove dist
115- rebuild, because the older version was much bigger, as it was build when
116  distutils was doing static links of libpython
117
118* Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
119- Rebuild for python 2.5
120
121* Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
122- Don't ghost pyo files (#205408)
123
124* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
125- Rebuild for Fedora Extras 6
126
127* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
128- Rebuild for Fedora Extras 5
129
130* Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
131- Update to 2.0.1
132- Use Dist
133- Drop python-crypto-64bit-unclean.patch, similar patch was applied
134  upstream
135
136* Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
137- add python-crypto-64bit-unclean.patch (#156173)
138
139* Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
140- iterate release for build on python 2.4 based systems
141
142* Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
143- Fix build on x86_64: use python_sitearch for files and patch source
144  to find gmp
145
146* Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
147- Update to 2.00
148
149* Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
150- Don't use get_python_version(), it's available in Python >= 2.3 only.
151
152* Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
153- Own dir python_sitearch/Crypto/
154
155* Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
156- Match python spec template more
157
158* Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
159- Own _libdir/python/site-packages/Crypto/
160
161* Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
162- generate .pyo files during install
163- require exact version of python used to build the package
164- include more docs + demos
165- fix dependency on /usr/local/bin/python
166- use fedora.us style buildroot
167- buildrequires gmp-devel
168- use description from README
169
170* Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org>  0.3.2-0.fdr.1.a6
171- Initial build.
172
Note: See TracBrowser for help on using the repository browser.