source: projects/specs/trunk/p/python-crypto/python-crypto-vl.spec @ 5701

Revision 5701, 5.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary:        Cryptography library for Python
5Summary(ja):    Python 用 Cryptography ライブラリ
6Name:           python-crypto
7Version:        2.5
8Release:        2%{?_dist_release}
9License:        Python License (CNRI Python License)
10Group:          Development/Libraries
11URL:            http://www.dlitz.net/software/pycrypto/
12Source:         http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
13
14Patch0:         dont-drop-g.patch
15Patch1:         fix-epydoc-ignore.patch
16Patch2:         fix-unresolved-reference-size.patch
17Patch3:         doc.patch
18
19BuildRequires:  python >= 2.2
20BuildRequires:  python-devel >= 2.2
21BuildRequires:  gmp-devel >= 4.1
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24%description
25Python-crypto is a collection of both secure hash functions
26(such as MD5 and SHA), and various encryption algorithms
27(AES, DES, IDEA, RSA, ElGamal, etc.).
28
29%prep
30%setup -n pycrypto-%{version} -q
31%patch0 -p1
32%patch1 -p1
33%patch2 -p1
34%patch3 -p1
35
36# Remove spurious shellbangs
37%{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
41
42%install
43%{__rm} -rf %{buildroot}
44%{__python} setup.py install -O1 --skip-build --root %{buildroot}
45
46# Remove group write permissions on shared objects
47/usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
48        -exec %{__chmod} g-w {} \;
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53
54%files
55%defattr(-,root,root,-)
56%doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
57#%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
58%{python_sitearch}/
59
60%changelog
61* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
62- rebuild with python-2.7.2
63
64* Mon Jan 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.5-1
65- new upstream release
66- added patches(1,2,3) from Debian
67
68* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.4.1-1
69- new upstream release
70- dropt patch1
71
72* Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-2
73- rebuilt with rpm-4.8.1 for pkg-config
74
75* Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
76- new upstream release
77- changed %%files
78
79* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
80- fix %files (change directory from %{python_sitelib} to %{python_sitearch})
81
82* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
83- new upstream release
84
85* Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
86- new upstream release
87- changed URL and SOURCE to new upstream
88- dropt patch0,2
89- replaced patch1 from Debian newer
90- added pacth3 from Debian
91- changed document files dir in %%files
92
93* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
94- rebuild with python-2.6
95
96* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
97- added Patch0,1,2 from Debian to fix some problem
98
99* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
100- initial build for VineSeed
101
102* Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
103- Fix libdir handling so it works on more arches than x86_64
104
105* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
106- Fix typo
107
108* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
109- Remove dist
110- rebuild, because the older version was much bigger, as it was build when
111  distutils was doing static links of libpython
112
113* Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
114- Rebuild for python 2.5
115
116* Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
117- Don't ghost pyo files (#205408)
118
119* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
120- Rebuild for Fedora Extras 6
121
122* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
123- Rebuild for Fedora Extras 5
124
125* Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
126- Update to 2.0.1
127- Use Dist
128- Drop python-crypto-64bit-unclean.patch, similar patch was applied
129  upstream
130
131* Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
132- add python-crypto-64bit-unclean.patch (#156173)
133
134* Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
135- iterate release for build on python 2.4 based systems
136
137* Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
138- Fix build on x86_64: use python_sitearch for files and patch source
139  to find gmp
140
141* Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
142- Update to 2.00
143
144* Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
145- Don't use get_python_version(), it's available in Python >= 2.3 only.
146
147* Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
148- Own dir python_sitearch/Crypto/
149
150* Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
151- Match python spec template more
152
153* Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
154- Own _libdir/python/site-packages/Crypto/
155
156* Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
157- generate .pyo files during install
158- require exact version of python used to build the package
159- include more docs + demos
160- fix dependency on /usr/local/bin/python
161- use fedora.us style buildroot
162- buildrequires gmp-devel
163- use description from README
164
165* Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org>  0.3.2-0.fdr.1.a6
166- Initial build.
167
Note: See TracBrowser for help on using the repository browser.