source: projects/specs/trunk/p/python-crypto/python-crypto-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary:        Cryptography library for Python
5Summary(ja):    Python 用 Cryptography ライブラリ
6Name:           python-crypto
7Version:        2.0.1
8Release:        3%{?_dist_release}
9License:        Python License (CNRI Python License)
10Group:          Development/Libraries
11URL:            http://www.amk.ca/python/code/crypto.html
12Source:         http://www.amk.ca/files/python/crypto/pycrypto-2.0.1.tar.gz
13
14Patch0:         arc2-buffer-overflow.patch
15Patch1:         no-usr-local.patch
16Patch2:         run-tests.patch
17
18BuildRequires:  python >= 2.2
19BuildRequires:  python-devel >= 2.2
20BuildRequires:  gmp-devel >= 4.1
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23%description
24Python-crypto is a collection of both secure hash functions
25(such as MD5 and SHA), and various encryption algorithms
26(AES, DES, IDEA, RSA, ElGamal, etc.).
27
28%prep
29%setup -n pycrypto-%{version} -q
30%patch0 -p1
31%patch1 -p1
32%patch2 -p1
33
34
35sed -i s:/lib:/%_lib:g setup.py
36
37
38%build
39CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
40
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
45find -name "*.py"|xargs %{__perl} -pi -e "s:/usr/local/bin/python:%{__python}:"
46
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52%files
53%defattr(-,root,root,-)
54%doc README TODO ACKS ChangeLog LICENSE Doc
55
56%{python_sitearch}/Crypto/*.py*
57%{python_sitearch}/Crypto/Cipher/*.so
58%{python_sitearch}/Crypto/Cipher/*.py*
59%{python_sitearch}/Crypto/Hash/*.so
60%{python_sitearch}/Crypto/Hash/*.py*
61%{python_sitearch}/Crypto/Protocol/*.py*
62%{python_sitearch}/Crypto/PublicKey/*.so
63%{python_sitearch}/Crypto/PublicKey/*.py*
64%{python_sitearch}/Crypto/Util/*.py*
65%{python_sitearch}/*.egg-info
66
67%dir %{python_sitearch}/Crypto/Cipher/
68%dir %{python_sitearch}/Crypto/Hash/
69%dir %{python_sitearch}/Crypto/Protocol/
70%dir %{python_sitearch}/Crypto/PublicKey/
71%dir %{python_sitearch}/Crypto/Util/
72
73%changelog
74* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
75- rebuild with python-2.6
76
77* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
78- added Patch0,1,2 from Debian to fix some problem
79
80* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
81- initial build for VineSeed
82
83* Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
84- Fix libdir handling so it works on more arches than x86_64
85
86* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
87- Fix typo
88
89* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
90- Remove dist
91- rebuild, because the older version was much bigger, as it was build when
92  distutils was doing static links of libpython
93
94* Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
95- Rebuild for python 2.5
96
97* Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
98- Don't ghost pyo files (#205408)
99
100* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
101- Rebuild for Fedora Extras 6
102
103* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
104- Rebuild for Fedora Extras 5
105
106* Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
107- Update to 2.0.1
108- Use Dist
109- Drop python-crypto-64bit-unclean.patch, similar patch was applied
110  upstream
111
112* Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
113- add python-crypto-64bit-unclean.patch (#156173)
114
115* Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
116- iterate release for build on python 2.4 based systems
117
118* Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
119- Fix build on x86_64: use python_sitearch for files and patch source
120  to find gmp
121
122* Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
123- Update to 2.00
124
125* Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
126- Don't use get_python_version(), it's available in Python >= 2.3 only.
127
128* Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
129- Own dir python_sitearch/Crypto/
130
131* Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
132- Match python spec template more
133
134* Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
135- Own _libdir/python/site-packages/Crypto/
136
137* Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
138- generate .pyo files during install
139- require exact version of python used to build the package
140- include more docs + demos
141- fix dependency on /usr/local/bin/python
142- use fedora.us style buildroot
143- buildrequires gmp-devel
144- use description from README
145
146* Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org>  0.3.2-0.fdr.1.a6
147- Initial build.
148
Note: See TracBrowser for help on using the repository browser.