source: projects/specs/trunk/p/python-crypto/python-crypto-vl.spec @ 1691

Revision 1691, 5.0 KB checked in by kudoh, 14 years ago (diff)
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary:        Cryptography library for Python
5Summary(ja):    Python 用 Cryptography ライブラリ
6Name:           python-crypto
7Version:        2.3
8Release:        1%{?_dist_release}
9License:        Python License (CNRI Python License)
10Group:          Development/Libraries
11URL:            http://www.dlitz.net/software/pycrypto/
12Source:         http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
13
14#Patch0:         arc2-buffer-overflow.patch
15Patch1:         no-usr-local.patch
16#Patch2:         run-tests.patch
17Patch3:         doc.patch
18
19BuildRequires:  python >= 2.2
20BuildRequires:  python-devel >= 2.2
21BuildRequires:  gmp-devel >= 4.1
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24%description
25Python-crypto is a collection of both secure hash functions
26(such as MD5 and SHA), and various encryption algorithms
27(AES, DES, IDEA, RSA, ElGamal, etc.).
28
29%prep
30%setup -n pycrypto-%{version} -q
31#%patch0 -p1
32%patch1 -p1
33#%patch2 -p1
34%patch3 -p1
35
36# Remove spurious shellbangs
37%{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
41
42%install
43%{__rm} -rf %{buildroot}
44%{__python} setup.py install -O1 --skip-build --root %{buildroot}
45
46# Remove group write permissions on shared objects
47/usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
48        -exec %{__chmod} g-w {} \;
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53
54%files
55%defattr(-,root,root,-)
56%doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
57#%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
58%{python_sitearch}/
59
60%changelog
61* Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
62- new upstream release
63- changed %%files
64
65* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
66- fix %files (change directory from %{python_sitelib} to %{python_sitearch})
67
68* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
69- new upstream release
70
71* Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
72- new upstream release
73- changed URL and SOURCE to new upstream
74- dropt patch0,2
75- replaced patch1 from Debian newer
76- added pacth3 from Debian
77- changed document files dir in %%files
78
79* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
80- rebuild with python-2.6
81
82* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
83- added Patch0,1,2 from Debian to fix some problem
84
85* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
86- initial build for VineSeed
87
88* Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
89- Fix libdir handling so it works on more arches than x86_64
90
91* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
92- Fix typo
93
94* Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
95- Remove dist
96- rebuild, because the older version was much bigger, as it was build when
97  distutils was doing static links of libpython
98
99* Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
100- Rebuild for python 2.5
101
102* Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
103- Don't ghost pyo files (#205408)
104
105* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
106- Rebuild for Fedora Extras 6
107
108* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
109- Rebuild for Fedora Extras 5
110
111* Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
112- Update to 2.0.1
113- Use Dist
114- Drop python-crypto-64bit-unclean.patch, similar patch was applied
115  upstream
116
117* Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
118- add python-crypto-64bit-unclean.patch (#156173)
119
120* Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
121- iterate release for build on python 2.4 based systems
122
123* Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
124- Fix build on x86_64: use python_sitearch for files and patch source
125  to find gmp
126
127* Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
128- Update to 2.00
129
130* Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
131- Don't use get_python_version(), it's available in Python >= 2.3 only.
132
133* Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
134- Own dir python_sitearch/Crypto/
135
136* Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
137- Match python spec template more
138
139* Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
140- Own _libdir/python/site-packages/Crypto/
141
142* Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
143- generate .pyo files during install
144- require exact version of python used to build the package
145- include more docs + demos
146- fix dependency on /usr/local/bin/python
147- use fedora.us style buildroot
148- buildrequires gmp-devel
149- use description from README
150
151* Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org>  0.3.2-0.fdr.1.a6
152- Initial build.
153
Note: See TracBrowser for help on using the repository browser.