source: projects/specs/trunk/p/python-coverage/python-coverage-vl.spec @ 8158

Revision 8158, 1.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define pkgname coverage
2
3# Basic Information
4Name:           python-%{pkgname}
5Version:        3.7.1
6Release:        1%{?_dist_release}
7License:        BSD
8Group:          Development/Tools
9URL:            http://nedbatchelder.com/code/coverage
10Source0:        http://pypi.python.org/packages/source/c/%{pkgname}/%{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Code coverage measurement for Python
18Summary(ja):    Python 向けのコードカバレッジ測定
19
20# Dependency
21# 以下に依存関係を記述してください 。
22Requires:       python
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25
26%description
27the code analysis tools and tracing hooks provided in the Python standard
28library to determine which lines are executable, and which have been executed.
29
30Coverage.py runs on Pythons 2.3 through 3.3, and PyPy 1.8.
31
32Documentation is at `nedbatchelder.com <http://nedbatchelder.com/code/coverage>`_.  Code repository and issue
33tracker are at `bitbucket.org <http://bitbucket.org/ned/coveragepy>`_.
34
35New in 3.5: Branch coverage exclusions, keyboard shortcuts in HTML report.
36
37New in 3.4: Better control over source to measure, and unexecuted files
38can be reported.
39
40New in 3.3: .coveragerc files.
41
42New in 3.2: Branch coverage!
43
44
45
46#%%description -l ja
47#ここに日本語で詳細を記述してください。
48
49%prep
50%setup -q -n coverage-%{version}
51
52%build
53%{__python} setup.py build
54
55%install
56%{__rm} -rf ${RPM_BUILD_ROOT}
57%{__python} setup.py install --root=${RPM_BUILD_ROOT}
58
59
60%clean
61%{__rm} -rf ${RPM_BUILD_ROOT}
62
63
64%files
65%defattr(-,root,root)
66%{_bindir}/coverage
67%{_bindir}/coverage-2.7
68%{_bindir}/coverage2
69%{python_sitearch}/%{pkgname}-%{version}-py%{pyver}.egg-info
70%{python_sitearch}/%{pkgname}
71
72
73%changelog
74* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.7.1-1
75- new upstream release
76
77* Tue Aug 14 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.5.2-1
78- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.