source: projects/specs/trunk/p/python-configobj/python-configobj-vl.spec @ 8158

Revision 8158, 3.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-configobj
4Version:        4.5.3
5Release:        4%{?_dist_release}
6Summary:        Config file reading, writing, and validation
7Summary(ja):    設定ファイルの読み込み、書き込み、及び評価用のPython ツール
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://www.voidspace.org.uk/python/configobj.html
11Source0:        http://dl.sf.net/configobj/configobj-%{version}.zip
12
13BuildRequires:  python-devel, python-setuptools
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21ConfigObj is a simple but powerful config file reader and writer: an ini file
22round tripper. Its main feature is that it is very easy to use, with a
23straightforward programmer's interface and a simple syntax for config files.
24It has lots of other features though:
25    * Nested sections (subsections), to any level
26    * List values
27    * Multiple line values
28    * String interpolation (substitution)
29    * Integrated with a powerful validation system
30          o including automatic type checking/conversion
31          o repeated sections
32          o and allowing default values
33    * All comments in the file are preserved
34    * The order of keys/sections is preserved
35    * No external dependencies
36    * Full Unicode support
37    * A powerful unrepr mode for storing basic datatypes
38
39
40%prep
41%setup -q -n configobj-%{version}
42
43
44%build
45%{__python} setup.py build
46
47
48%install
49rm -rf $RPM_BUILD_ROOT
50%{__python} setup.py install -O1 --skip-build --root=$RPM_BUILD_ROOT
51
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root,-)
59%doc docs
60%{python_sitelib}/*.py
61%{python_sitelib}/*.pyc
62%{python_sitelib}/*.pyo
63%{python_sitelib}/configobj-*.egg-info
64
65%changelog
66* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.5.3-4
67- rebuild with VineSeed environment
68
69* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.5.3-3
70- rebuild with python-2.7.2
71
72* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.5.3-2
73- rebuilt with python-2.6.4
74
75* Wed Dec 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.5.3-1
76- initial build for Vine Linux based on fedora package
77
78* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 4.5.3-3
79- Upload Source file so this actually builds.
80
81* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.5.3-2
82- Rebuild for Python 2.6
83
84* Sat Jun 28 2008 Luke Macken <lmacken@redhat.com> - 4.5.3-1
85- Update to 4.5.3
86
87* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 4.5.2-1
88- Update to 4.5.2
89
90* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 4.4.0-2
91- Update for python-setuptools changes in rawhide
92
93* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 4.4.0-1
94- 4.4.0
95
96* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-6
97- Rebuild for python 2.5
98
99* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-5
100- Fix dist tag
101
102* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-4
103- Rebuild for FC6
104
105* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-3
106- Include pyo files
107
108* Tue Jul 18 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-2
109- Fix typo in the url
110
111* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 4.3.2-1
112- Initial package
Note: See TracBrowser for help on using the repository browser.