source: projects/specs/trunk/p/python-clientform/python-clientform-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4Name:           python-clientform
5Version:        0.2.7
6Release:        2%{?_dist_release}
7Summary:        Python module for client-side HTML forms
8Summary(ja):    クライアントサイドの HTML フォーム用 Python モジュール
9
10Group:          Development/Languages
11License:        BSD
12URL:            http://wwwsearch.sourceforge.net/ClientForm/
13Source0:        http://wwwsearch.sourceforge.net/ClientForm/src/ClientForm-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildArch:      noarch
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19
20
21%description
22ClientForm is a Python module for handling HTML forms on the client side,
23useful for parsing HTML forms, filling them in and returning the completed
24forms to the server.  It developed from a port of Gisle Aas' Perl module
25HTML::Form, from the libwww-perl library, but the interface is not the same.
26
27%prep
28%setup -q -n ClientForm-%{version}
29
30
31%build
32%{__python} setup.py build
33
34
35%install
36rm -rf $RPM_BUILD_ROOT
37%{__python} setup.py install --single-version-externally-managed -O1 \
38                             --skip-build --root $RPM_BUILD_ROOT
39
40 
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44
45%files
46%defattr(-,root,root,-)
47%doc COPYING.txt GeneralFAQ.html README.txt README.html examples
48%{python_sitelib}/ClientForm.py
49%{python_sitelib}/ClientForm.pyc
50%{python_sitelib}/ClientForm.pyo
51%{python_sitelib}/ClientForm-%{version}-py%{pyver}.egg-info
52
53%changelog
54* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.7-2
55- rebuilt with python-2.6.4
56
57* Sat Dec 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.2.7-1
58- initial build for Vine Linux based on fedora package
59
60* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.7-3
61- Rebuild for Python 2.6
62
63* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.2.7-2
64- Update for python-setuptools changes in rawhide
65
66* Sat Aug 18 2007 Luke Macken <lmacken@redhat.com> 0.2.7-1
67- 0.2.7
68
69* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.2.6-1
70- 0.2.6
71
72* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.2.5-2
73- Rebuild for python 2.5
74- 0.2.5
75
76* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> 0.2.2-6
77- Rebuild for FC6
78
79* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> 0.2.2-5
80- Include .pyo files instead of ghosting them
81
82* Thu May 11 2006 Luke Macken <lmacken@redhat.com> 0.2.2-4
83- Install with --single-version-externally-managed flag
84- Add a few more docs
85
86* Thu May 11 2006 Luke Macken <lmacken@redhat.com> 0.2.2-3
87- Add python-setuptools to BuildRequires
88
89* Thu May 11 2006 Luke Macken <lmacken@redhat.com> 0.2.2-2
90- Fix version in Source0
91
92* Thu May 11 2006 Luke Macken <lmacken@redhat.com> 0.2.2-1
93- Bump to 0.2.2
94
95* Tue Feb 14 2006 Josh Boyer <jwboyer@jdub.homelinux.org> 0.1.17-4
96- Bump for FE5 rebuild
97
98* Sun Oct 30 2005 Josh Boyer <jwboyer@jdub.homelinux.org> 0.1.17-3
99- Fix up review comments
100
101* Thu Oct 6 2005 Josh Boyer <jwboyer@jdub.homelinux.org> 0.1.17-2
102- Rename package to add python- prefix
103
104* Wed Oct 5 2005 Josh Boyer <jwboyer@jdub.homelinux.org> 0.1.17-1
105- Initial spec file
Note: See TracBrowser for help on using the repository browser.