source: projects/specs/trunk/p/python-cffi/python-cffi-vl.spec @ 12469

Revision 12469, 7.5 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Name:           python-cffi
2Version:        1.14.1
3Release:        1%{?_dist_release}
4Summary:        Foreign Function Interface for Python to call C code
5Group:          programming
6Vendor:         Project Vine
7Distribution:   Vine Linux
8
9License:        MIT
10URL:            https://pypi.org/project/cffi/
11Source0:        cffi-%{version}.tar.gz
12
13BuildRequires:  libffi-devel
14BuildRequires:  gcc
15
16# For tests:
17BuildRequires:  gcc-c++
18
19BuildRequires:  python-rpm-macros
20BuildRequires:  python2-rpm-macros
21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-pycparser
24
25BuildRequires:  python3-rpm-macros
26BuildRequires:  python3-devel
27BuildRequires:  python3-setuptools
28BuildRequires:  python3-pycparser
29
30%{?python_provide:%python_provide python2-cffi}
31
32%?python_enable_dependency_generator
33
34
35%description
36Foreign Function Interface for Python, providing a convenient and
37reliable way of calling existing C code from Python. The interface is
38based on LuaJIT’s FFI.
39
40
41%package -n python3-cffi
42Summary:        Foreign Function Interface for Python 3 to call C code
43Group:          programming
44%{?python_provide:%python_provide python3-cffi}
45
46%description -n python3-cffi
47Foreign Function Interface for Python, providing a convenient and
48reliable way of calling existing C code from Python. The interface is
49based on LuaJIT’s FFI.
50
51
52%prep
53%autosetup -n cffi-%{version}
54
55
56%build
57%py2_build
58%py3_build
59
60
61%install
62%py2_install
63%py3_install
64
65
66%files
67%doc PKG-INFO
68%license LICENSE
69%{python2_sitearch}/cffi/
70%{python2_sitearch}/_cffi_backend.so
71%{python2_sitearch}/cffi-%{version}-py%{python_version}.egg-info/
72
73%files -n python3-cffi
74%doc PKG-INFO
75%license LICENSE
76%{python3_sitearch}/cffi/
77%{python3_sitearch}/_cffi_backend.*.so
78%{python3_sitearch}/cffi-%{version}-py%{python3_version}.egg-info/
79
80%changelog
81* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.1-1
82- new upstream release.
83
84* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.0-1
85- new upstream release.
86
87* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.11.5-7
88- initial build for Vine Linux.
89
90* Wed Aug 22 2018 Miro Hrončok <mhroncok@redhat.com> - 1.11.5-6
91- Fix FTBFS (#1605627)
92
93* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.5-5
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
95
96* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 1.11.5-4
97- Rebuilt for Python 3.7
98
99* Fri May 25 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.11.5-3
100- Disable tests to fix mock-only FTBFS.
101
102* Fri Mar 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.11.5-2
103- Update Python 2 dependency declarations to new packaging standards
104  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
105
106* Fri Mar 02 2018 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.2-1
107- New release 1.11.5
108
109* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.11.2-3
110- Escape macros in %%changelog
111
112* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.2-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
114
115* Thu Oct 19 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.2-1
116- New release 1.11.0
117- Fix %%check
118
119* Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 1.11.0-2
120- Cleanup spec file conditionals
121
122* Sat Sep 23 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.0-1
123- New release 1.11.0
124
125* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.0-3
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
127
128* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.0-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
130
131* Tue Apr 04 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.10.0-1
132- New release 1.10.0
133
134* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.1-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
136
137* Sat Jan 07 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.9.1-1
138- Update to latest upstream 1.9.1
139
140* Fri Jan 6 2017 Orion Poplawski <orion@cora.nwra.com> - 1.8.3-4
141- Modernize spec
142
143* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.8.3-3
144- Rebuild for Python 3.6
145- Disable test dependencies
146
147* Thu Nov 03 2016 John Dulaney <jdulaney@Fedoraproject.org> - 1.8.3-2
148- Re-disable check
149
150* Sun Sep 18 2016 John Dulaney <jdulaney@Fedoraproject.org> - 1.8.3-1
151- Update to 1.8.3
152- Reenable check
153
154* Wed Sep 07 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.8.2-1
155- Update to 1.8.2
156
157* Tue Aug 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.7.0-3
158- Record installed files
159
160* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
161- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
162
163* Thu Jun 23 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.7.0-1
164- Update to 1.7.0
165
166* Thu Apr 28 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-3
167- Switch Source0 to using pypi.io
168
169* Thu Apr 28 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-2
170- Update Source0 URL to account for pypi change
171
172* Thu Apr 21 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-1
173- Update to 1.6.0 (#1329203)
174
175* Mon Feb 15 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.5.2-1
176- Update to 1.5.2 (#1299272)
177
178* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
180
181* Mon Jan 18 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.0-1
182- Update to 1.5.0 (#1299272)
183
184* Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.4.2-2
185- Move python-cffi => python2-cffi
186
187* Tue Dec 22 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.4.2-1
188- Update to 1.4.2 (#1293504)
189
190* Thu Dec 17 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.4.1-1
191- Update to latest upstream release
192
193* Fri Dec 11 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.3.1-1
194- Update to latest upstream release
195
196* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 1.1.2-4
197- Rebuilt for Python3.5 rebuild
198
199* Wed Jul 15 2015 Parag Nemade <pnemade AT redhat DOT com> - 1.1.2-3
200- Modernize spec file
201- add missing source
202
203* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
205
206* Tue Jun 16 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.1.2-2
207- Update to 1.1.2
208- Fix license
209
210* Tue Aug 19 2014 Eric Smith <spacewar@gmail.com> 0.8.6-1
211- Update to latest upstream.
212- No python3 in el7.
213
214* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-4
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
216
217* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-3
218- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
219
220* Mon May 12 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.8.1-2
221- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
222
223* Wed Feb 26 2014 Eric Smith <spacewar@gmail.com> 0.8.1-1
224- Update to latest upstream.
225
226* Tue Aug 13 2013 Eric Smith <spacewar@gmail.com> 0.6-5
227- Add Requires of python{,3}-pycparser.
228
229* Thu Jul 25 2013 Eric Smith <spacewar@gmail.com> 0.6-4
230- Fix broken conditionals in spec (missing question marks), needed for el6.
231
232* Tue Jul 23 2013 Eric Smith <spacewar@gmail.com> 0.6-3
233- Add Python3 support.
234
235* Mon Jul 22 2013 Eric Smith <spacewar@gmail.com> 0.6-2
236- Better URL, and use version macro in Source0.
237
238* Sun Jul 21 2013 Eric Smith <spacewar@gmail.com> 0.6-1
239- initial version
Note: See TracBrowser for help on using the repository browser.