source: projects/specs/trunk/p/python-cffi/python-cffi-vl.spec @ 11921

Revision 11921, 7.2 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1Name:           python-cffi
2Version:        1.11.5
3Release:        7%{?_dist_release}
4Summary:        Foreign Function Interface for Python to call C code
5Group:          Development/Libraries
6License:        MIT
7URL:            http://cffi.readthedocs.org/
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Source0:        cffi-%{version}.tar.gz
11
12BuildRequires:  libffi-devel
13BuildRequires:  gcc
14
15# For tests:
16BuildRequires:  gcc-c++
17
18BuildRequires:  python-rpm-macros
19BuildRequires:  python-devel
20BuildRequires:  python-setuptools
21BuildRequires:  python-pycparser
22
23BuildRequires:  python3-rpm-macros
24BuildRequires:  python3-devel
25BuildRequires:  python3-setuptools
26BuildRequires:  python3-pycparser
27
28%{?python_provide:%python_provide python2-cffi}
29
30%?python_enable_dependency_generator
31
32%description
33Foreign Function Interface for Python, providing a convenient and
34reliable way of calling existing C code from Python. The interface is
35based on LuaJIT’s FFI.
36
37%package -n python3-cffi
38Summary:        Foreign Function Interface for Python 3 to call C code
39%{?python_provide:%python_provide python3-cffi}
40
41%description -n python3-cffi
42Foreign Function Interface for Python, providing a convenient and
43reliable way of calling existing C code from Python. The interface is
44based on LuaJIT’s FFI.
45
46%prep
47%autosetup -n cffi-%{version}
48
49%build
50%py_build
51%py3_build
52
53%install
54%py_install
55%py3_install
56
57%files
58%doc PKG-INFO
59%license LICENSE
60%{python_sitearch}/cffi/
61%{python_sitearch}/_cffi_backend.so
62%{python_sitearch}/cffi-%{version}-py%{python_version}.egg-info/
63
64%files -n python3-cffi
65%doc PKG-INFO
66%license LICENSE
67%{python3_sitearch}/cffi/
68%{python3_sitearch}/_cffi_backend.*.so
69%{python3_sitearch}/cffi-%{version}-py%{python3_version}.egg-info/
70
71%changelog
72* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.11.5-7
73- initial build for Vine Linux.
74
75* Wed Aug 22 2018 Miro Hrončok <mhroncok@redhat.com> - 1.11.5-6
76- Fix FTBFS (#1605627)
77
78* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.5-5
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
80
81* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 1.11.5-4
82- Rebuilt for Python 3.7
83
84* Fri May 25 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.11.5-3
85- Disable tests to fix mock-only FTBFS.
86
87* Fri Mar 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.11.5-2
88- Update Python 2 dependency declarations to new packaging standards
89  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
90
91* Fri Mar 02 2018 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.2-1
92- New release 1.11.5
93
94* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.11.2-3
95- Escape macros in %%changelog
96
97* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.2-2
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
99
100* Thu Oct 19 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.2-1
101- New release 1.11.0
102- Fix %%check
103
104* Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 1.11.0-2
105- Cleanup spec file conditionals
106
107* Sat Sep 23 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.11.0-1
108- New release 1.11.0
109
110* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.0-3
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
112
113* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.0-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
115
116* Tue Apr 04 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.10.0-1
117- New release 1.10.0
118
119* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.1-2
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
121
122* Sat Jan 07 2017 John Dulaney <jdulaney@Fedoraproject.org> - 1.9.1-1
123- Update to latest upstream 1.9.1
124
125* Fri Jan 6 2017 Orion Poplawski <orion@cora.nwra.com> - 1.8.3-4
126- Modernize spec
127
128* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.8.3-3
129- Rebuild for Python 3.6
130- Disable test dependencies
131
132* Thu Nov 03 2016 John Dulaney <jdulaney@Fedoraproject.org> - 1.8.3-2
133- Re-disable check
134
135* Sun Sep 18 2016 John Dulaney <jdulaney@Fedoraproject.org> - 1.8.3-1
136- Update to 1.8.3
137- Reenable check
138
139* Wed Sep 07 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.8.2-1
140- Update to 1.8.2
141
142* Tue Aug 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.7.0-3
143- Record installed files
144
145* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.0-2
146- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
147
148* Thu Jun 23 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.7.0-1
149- Update to 1.7.0
150
151* Thu Apr 28 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-3
152- Switch Source0 to using pypi.io
153
154* Thu Apr 28 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-2
155- Update Source0 URL to account for pypi change
156
157* Thu Apr 21 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.6.0-1
158- Update to 1.6.0 (#1329203)
159
160* Mon Feb 15 2016 John Dulaney <jdulaney@fedoraproject.org> - 1.5.2-1
161- Update to 1.5.2 (#1299272)
162
163* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
165
166* Mon Jan 18 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.0-1
167- Update to 1.5.0 (#1299272)
168
169* Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.4.2-2
170- Move python-cffi => python2-cffi
171
172* Tue Dec 22 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.4.2-1
173- Update to 1.4.2 (#1293504)
174
175* Thu Dec 17 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.4.1-1
176- Update to latest upstream release
177
178* Fri Dec 11 2015 John Dulaney <jdulaney@fedoraproject.org> - 1.3.1-1
179- Update to latest upstream release
180
181* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 1.1.2-4
182- Rebuilt for Python3.5 rebuild
183
184* Wed Jul 15 2015 Parag Nemade <pnemade AT redhat DOT com> - 1.1.2-3
185- Modernize spec file
186- add missing source
187
188* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
190
191* Tue Jun 16 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.1.2-2
192- Update to 1.1.2
193- Fix license
194
195* Tue Aug 19 2014 Eric Smith <spacewar@gmail.com> 0.8.6-1
196- Update to latest upstream.
197- No python3 in el7.
198
199* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-4
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
201
202* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-3
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
204
205* Mon May 12 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.8.1-2
206- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
207
208* Wed Feb 26 2014 Eric Smith <spacewar@gmail.com> 0.8.1-1
209- Update to latest upstream.
210
211* Tue Aug 13 2013 Eric Smith <spacewar@gmail.com> 0.6-5
212- Add Requires of python{,3}-pycparser.
213
214* Thu Jul 25 2013 Eric Smith <spacewar@gmail.com> 0.6-4
215- Fix broken conditionals in spec (missing question marks), needed for el6.
216
217* Tue Jul 23 2013 Eric Smith <spacewar@gmail.com> 0.6-3
218- Add Python3 support.
219
220* Mon Jul 22 2013 Eric Smith <spacewar@gmail.com> 0.6-2
221- Better URL, and use version macro in Source0.
222
223* Sun Jul 21 2013 Eric Smith <spacewar@gmail.com> 0.6-1
224- initial version
Note: See TracBrowser for help on using the repository browser.