source: projects/specs/trunk/p/python-bsddb3/python-bsddb3-vl.spec @ 7027

Revision 7027, 1.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python-bsddb3: new package
task-gnome: add package
others: new upstream release

Line 
1%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
2Summary:        Python bindings for Berkeley DB
3Summary(ja):    Berkeley DB 用 python バインディング
4Name:           python-bsddb3
5Version:        5.3.0
6Release:        1%{?_dist_release}
7Source0:        http://pypi.python.org/packages/source/b/bsddb3/bsddb3-%{version}.tar.gz
8License:        MIT
9Group:          Development/Languages
10URL:            http://www.jcea.es/programacion/pybsddb.htm
11
12Requires:       python
13
14BuildRequires:  python-devel
15BuildRequires:  db4-devel
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19
20%description
21python-bsddb3 are the Python "bindings" for the excellent Oracle Berkeley DB.
22
23%description -l ja
24python-bsddb3 は Oracle Berkeley DB 用の python バインディングです。
25
26
27%package devel
28Summary: Development files for %{name}
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33%{summary}
34
35
36%prep
37
38%setup -q -n bsddb3-%{version}
39
40
41%build
42%{__python} setup.py build
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__python} setup.py install --root ${RPM_BUILD_ROOT}
47
48
49%clean
50%{__rm} -rf ${RPM_BUILD_ROOT}
51
52
53%files
54%defattr(-,root,root,-)
55%doc ChangeLog README.txt
56%{python_sitearch}/bsddb3/
57%{python_sitearch}/bsddb3-%{version}-py%{pyver}.egg-info
58
59%files devel
60%defattr(-,root,root,-)
61%{_includedir}/python%{pyver}/bsddb3/bsddb.h
62
63
64%changelog
65* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.3.0-1
66- initial build
67
Note: See TracBrowser for help on using the repository browser.