source: projects/specs/trunk/p/python-boto/python-boto-vl.spec @ 5125

Revision 5125, 2.8 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitelib: %define python_sitelib %(%{python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%define pkgname boto

Summary: A simple lightweight interface to Amazon Web Services
Summary(ja): シンプル・軽量な Amazon Web サービスへのインターフェイス
Name: python-boto
Version: 2.1.1
Release: 1%{?_dist_release}
License: MIT
Group: Development/Languages?
URL:  http://code.google.com/p/%{pkgname}/
Source:  http://boto.googlecode.com/files/%{pkgname}-%{version}.tar.gz
BuildRequires?: python-devel, python-setuptools
BuildArch?: noarch
BuildRoot?: %{_tmppath}/%{name}-%{version}-root

%description
Boto is a Python package that provides interfaces to Amazon Web Services.
It supports S3 (Simple Storage Service), SQS (Simple Queue Service) via
the REST API's provided by those services and EC2 (Elastic Compute Cloud)
via the Query API. The goal of boto is to provide a very simple, easy to
use, lightweight wrapper around the Amazon services.

%prep
%setup -q -n %{pkgname}-%{version}

%build
%{python} setup.py build

%install
rm -rf $RPM_BUILD_ROOT
%{python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT

# Remove all test scripts
rm -rf $RPM_BUILD_ROOT{%{_bindir},%{python_sitelib}/tests}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
#%doc README
%{python_sitelib}/*

%changelog

  • Mon Nov 07 2011 Toshiharu Kudoh <toshi.kd2@…> 2.1.1-1
  • new upstream release
  • Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@…> 2.0b4-1
  • new upstream release
  • Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@…> 2.0b3-1
  • new upstream release
  • Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@…> 2.0b2-2
  • rebuilt with rpm-4.8.1 for pkg-config
  • Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@…> 2.0b2-1
  • new upstream release
  • fixed Release macro
  • Sat May 22 2010 Toshiharu Kudoh <toshi.kd2@…> 1.9b-1
  • initial build for VineSeed
  • Fri Jul 24 2009 Robert Scheck <robert@…> 1.8d-1
  • Upgrade to 1.8d (#513560)
  • Wed Jun 03 2009 Luke Macken <lmacken@…> 1.7a-2
  • Add python-setuptools-devel to our build requirements, for egg-info
  • Thu Apr 16 2009 Robert Scheck <robert@…> 1.7a-1
  • Upgrade to 1.7a
  • Mon Feb 23 2009 Robert Scheck <robert@…> 1.5c-2
  • Rebuild against rpm 4.6
  • Sun Dec 07 2008 Robert Scheck <robert@…> 1.5c-1
  • Upgrade to 1.5c
  • Fri Dec 05 2008 Jeremy Katz <katzj@…> 1.2a-2
  • Rebuild for python 2.6
  • Wed May 07 2008 Robert Scheck <robert@…> 1.2a-1
  • Upgrade to 1.2a
  • Sat Feb 09 2008 Robert Scheck <robert@…> 1.0a-1
  • Upgrade to 1.0a
  • Sat Dec 08 2007 Robert Scheck <robert@…> 0.9d-1
  • Upgrade to 0.9d
  • Thu Aug 30 2007 Robert Scheck <robert@…> 0.9b-1
  • Upgrade to 0.9b
  • Initial spec file for Fedora and Red Hat Enterprise Linux
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define pkgname boto
3
4Summary:        A simple lightweight interface to Amazon Web Services
5Summary(ja):    シンプル・軽量な Amazon Web サービスへのインターフェイス
6Name:           python-boto
7Version:        2.1.1
8Release:        1%{?_dist_release}
9License:        MIT
10Group:          Development/Languages
11URL:            http://code.google.com/p/%{pkgname}/
12Source:         http://boto.googlecode.com/files/%{pkgname}-%{version}.tar.gz
13BuildRequires:  python-devel, python-setuptools
14BuildArch:      noarch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17%description
18Boto is a Python package that provides interfaces to Amazon Web Services.
19It supports S3 (Simple Storage Service), SQS (Simple Queue Service) via
20the REST API's provided by those services and EC2 (Elastic Compute Cloud)
21via the Query API. The goal of boto is to provide a very simple, easy to
22use, lightweight wrapper around the Amazon services.
23
24%prep
25%setup -q -n %{pkgname}-%{version}
26
27%build
28%{__python} setup.py build
29
30%install
31rm -rf $RPM_BUILD_ROOT
32%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
33
34# Remove all test scripts
35rm -rf $RPM_BUILD_ROOT{%{_bindir},%{python_sitelib}/tests}
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%files
41%defattr(-,root,root)
42#%doc README
43%{python_sitelib}/*
44
45%changelog
46* Mon Nov 07 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.1-1
47- new upstream release
48
49* Sun May 22 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0b4-1
50- new upstream release
51
52* Mon Oct 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0b3-1
53- new upstream release
54
55* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0b2-2
56- rebuilt with rpm-4.8.1 for pkg-config
57
58* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0b2-1
59- new upstream release
60- fixed Release macro
61
62* Sat May 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.9b-1
63- initial build for VineSeed
64
65* Fri Jul 24 2009 Robert Scheck <robert@fedoraproject.org> 1.8d-1
66- Upgrade to 1.8d (#513560)
67
68* Wed Jun 03 2009 Luke Macken <lmacken@redhat.com> 1.7a-2
69- Add python-setuptools-devel to our build requirements, for egg-info
70
71* Thu Apr 16 2009 Robert Scheck <robert@fedoraproject.org> 1.7a-1
72- Upgrade to 1.7a
73
74* Mon Feb 23 2009 Robert Scheck <robert@fedoraproject.org> 1.5c-2
75- Rebuild against rpm 4.6
76
77* Sun Dec 07 2008 Robert Scheck <robert@fedoraproject.org> 1.5c-1
78- Upgrade to 1.5c
79
80* Fri Dec 05 2008 Jeremy Katz <katzj@redhat.com> 1.2a-2
81- Rebuild for python 2.6
82
83* Wed May 07 2008 Robert Scheck <robert@fedoraproject.org> 1.2a-1
84- Upgrade to 1.2a
85
86* Sat Feb 09 2008 Robert Scheck <robert@fedoraproject.org> 1.0a-1
87- Upgrade to 1.0a
88
89* Sat Dec 08 2007 Robert Scheck <robert@fedoraproject.org> 0.9d-1
90- Upgrade to 0.9d
91
92* Thu Aug 30 2007 Robert Scheck <robert@fedoraproject.org> 0.9b-1
93- Upgrade to 0.9b
94- Initial spec file for Fedora and Red Hat Enterprise Linux
Note: See TracBrowser for help on using the repository browser.