source: projects/specs/trunk/p/python-beaker/python-beaker-vl.spec @ 5141

Revision 5141, 3.9 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitelib: %define python_sitelib %(%{python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

Name: python-beaker
Version: 1.6.1
Release: 1%{?_dist_release}
Summary: WSGI middleware layer to provide sessions
Summary(ja): セッションを提供するための WSGI ミドルウェアレイヤ

Group: Development/Languages?
License: BSD
URL:  http://beaker.groovie.org/
Source0:  http://pypi.python.org/packages/source/B/Beaker/Beaker-%{version}.tar.gz
BuildRoot?: %{_tmppath}/%{name}-%{version}-root
BuildArch?: noarch
BuildRequires?: python-setuptools
#Patch1: %{name}-absimport.patch

%description
Beaker is a caching library that includes Session and Cache objects built on
Myghty's Container API used in MyghtyUtils?. WSGI middleware is also included to
manage Session objects and signed cookies.

%prep
%setup -q -n Beaker-%{version}
#%patch1 -p0 -b .absimport

%build
%{python} setup.py build

%install
rm -rf $RPM_BUILD_ROOT
%{python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc LICENSE CHANGELOG
%{python_sitelib}/beaker/
%{python_sitelib}/Beaker*

%changelog

  • Sat Nov 12 2010 Toshiharu Kudoh <toshi.kd2@…> - 1.6.1-1
  • new upstream release
  • Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@…> - 1.5.4-2
  • rebuilt with rpm-4.8.1 for pkg-config
  • Sun Jun 20 2010 Toshiharu Kudoh <toshi.kd2@…> - 1.5.4-1
  • new upstream release
  • Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@…> - 1.5.3-1
  • initail build for VineSeed
  • Fri Jan 22 2010 Luke Macken <lmacken@…> - 1.5.1-1
  • Update to 1.5.1
  • Remove beaker-hmac2.4.patch, which made it into 1.4 upstream
  • Remove middleware-config.patch which is also upstream
  • Tue Jul 21 2009 Kyle VanderBeek? <kylev@…> - 1.3.1-5
  • Add patch based on upstream hg 403ef7c82d32 for config overwriting that breaks Pylons unit tests
  • Sat Jun 27 2009 Luke Macken <lmacken@…> - 1.3.1-4
  • Add a patch to remove the use of future.absolute_import in the google backend
  • Sat Jun 20 2009 Toshio Kuratomi <toshio@…> - 1.3.1-3
  • Different hmac patch suitable for upstream inclusion.
  • Tue Jun 02 2009 Luke Macken <lmacken@…> - 1.3.1-2
  • Add a patch to remove Beaker's use of hashlib on Python2.4, due to incompatiblities with Python's hmac module (#503772)
  • Sun May 31 2009 Luke Macken <lmacken@…> - 1.3.1-1
  • Update to 1.3.1
  • Tue Apr 07 2009 Felix Schwarz <felix.schwarz@…> - 1.3-1
  • Update to 1.3


  • Sun Apr 05 2009 Felix Schwarz <felix.schwarz@…> - 1.2.3-1
  • Update to 1.2.3


  • Tue Jan 06 2009 Luke Macken <lmacken@…> - 1.1.3-1
  • Update to 1.1.3
  • Sat Dec 20 2008 Felix Schwarz <felix.schwarz@…> - 1.1.2-1
  • Update to 1.1.2


  • Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@…> - 1.0.3-2
  • Rebuild for Python 2.6
  • Tue Jun 24 2008 Felix Schwarz <felix.schwarz@…> - 1.0.3-1
  • Update to 1.0.3.
  • Tue Jun 24 2008 Kyle VanderBeek? <kylev@…> - 0.9.5-1
  • Update to 0.9.5.
  • Remove license patch which is now corrected upstream.
  • Mon May 12 2008 Kyle VanderBeek? <kylev@…> - 0.9.4-4
  • Fix files to not use wildcard, fixing dir ownership
  • Mon May 12 2008 Kyle VanderBeek? <kylev@…> - 0.9.4-3
  • Corrected license
  • Mon May 12 2008 Kyle VanderBeek? <kylev@…> - 0.9.4-2
  • More restrictive file includes for safety
  • Sun May 11 2008 Kyle VanderBeek? <kylev@…> - 0.9.4-1
  • Update to 0.9.4 (security fix)
  • Fix rpmlint complaints, add CHANGELOG and LICENSE
  • Wed Apr 9 2008 Kyle VanderBeek? <kylev@…> - 0.9.3-1
  • Initial version.
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name: python-beaker
4Version: 1.6.1
5Release: 1%{?_dist_release}
6Summary: WSGI middleware layer to provide sessions
7Summary(ja): セッションを提供するための WSGI ミドルウェアレイヤ
8
9Group: Development/Languages
10License: BSD
11URL: http://beaker.groovie.org/
12Source0: http://pypi.python.org/packages/source/B/Beaker/Beaker-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15BuildRequires: python-setuptools
16#Patch1: %{name}-absimport.patch
17
18%description
19Beaker is a caching library that includes Session and Cache objects built on
20Myghty's Container API used in MyghtyUtils. WSGI middleware is also included to
21manage Session objects and signed cookies.
22
23
24%prep
25%setup -q -n Beaker-%{version}
26#%patch1 -p0 -b .absimport
27
28
29%build
30%{__python} setup.py build
31
32
33%install
34rm -rf $RPM_BUILD_ROOT
35%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
36
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41
42%files
43%defattr(-,root,root,-)
44%doc LICENSE CHANGELOG
45%{python_sitelib}/beaker/
46%{python_sitelib}/Beaker*
47
48
49%changelog
50* Sat Nov 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.1-1
51- new upstream release
52
53* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.4-2
54- rebuilt with rpm-4.8.1 for pkg-config
55
56* Sun Jun 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.4-1
57- new upstream release
58
59* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.3-1
60- initail build for VineSeed
61
62* Fri Jan 22 2010 Luke Macken <lmacken@redhat.com> - 1.5.1-1
63- Update to 1.5.1
64- Remove beaker-hmac2.4.patch, which made it into 1.4 upstream
65- Remove middleware-config.patch which is also upstream
66
67* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
68- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
69
70* Tue Jul 21 2009 Kyle VanderBeek <kylev@kylev.com> - 1.3.1-5
71- Add patch based on upstream hg 403ef7c82d32 for config overwriting that
72  breaks Pylons unit tests
73
74* Sat Jun 27 2009 Luke Macken <lmacken@redhat.com> - 1.3.1-4
75- Add a patch to remove the use of __future__.absolute_import in the google
76  backend
77
78* Sat Jun 20 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-3
79- Different hmac patch suitable for upstream inclusion.
80
81* Tue Jun 02 2009 Luke Macken <lmacken@redhat.com> - 1.3.1-2
82- Add a patch to remove Beaker's use of hashlib on Python2.4,
83  due to incompatiblities with Python's hmac module (#503772)
84
85* Sun May 31 2009 Luke Macken <lmacken@redhat.com> - 1.3.1-1
86- Update to 1.3.1
87
88* Tue Apr 07 2009 Felix Schwarz <felix.schwarz@oss.schwarz.eu> - 1.3-1
89- Update to 1.3
90 
91* Sun Apr 05 2009 Felix Schwarz <felix.schwarz@oss.schwarz.eu> - 1.2.3-1
92- Update to 1.2.3
93 
94* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
96
97* Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> - 1.1.3-1
98- Update to 1.1.3
99
100* Sat Dec 20 2008 Felix Schwarz <felix.schwarz@oss.schwarz.eu> - 1.1.2-1
101- Update to 1.1.2
102 
103* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.3-2
104- Rebuild for Python 2.6
105
106* Tue Jun 24 2008 Felix Schwarz <felix.schwarz@oss.schwarz.eu> - 1.0.3-1
107- Update to 1.0.3.
108
109* Tue Jun 24 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.5-1
110- Update to 0.9.5.
111- Remove license patch which is now corrected upstream.
112
113* Mon May 12 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.4-4
114- Fix files to not use wildcard, fixing dir ownership
115
116* Mon May 12 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.4-3
117- Corrected license
118
119* Mon May 12 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.4-2
120- More restrictive file includes for safety
121
122* Sun May 11 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.4-1
123- Update to 0.9.4 (security fix)
124- Fix rpmlint complaints, add CHANGELOG and LICENSE
125
126* Wed Apr  9 2008 Kyle VanderBeek <kylev@kylev.com> - 0.9.3-1
127- Initial version.
Note: See TracBrowser for help on using the repository browser.