source: projects/specs/trunk/p/python-asn1crypto/python-asn1crypto-vl.spec @ 12469

Revision 12469, 3.8 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1# Created by pyp2rpm-3.2.2
2%global pypi_name asn1crypto
3
4%bcond_without python2
5%bcond_without python3
6
7%{!?python3_pkgversion:%global python3_pkgversion 3}
8
9Summary:        Fast Python ASN.1 parser and serializer
10Name:           python-%{pypi_name}
11Version:        1.4.0
12Release:        1%{?_dist_release}
13Group:          programming
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17License:        MIT
18URL:            https://github.com/wbond/asn1crypto
19Source0:        https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
20BuildArch:      noarch
21
22%if 0%{?with_python2}
23BuildRequires:  python-rpm-macros
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26%{?python_provide:%python_provide python2-%{pypi_name}}
27%endif
28%if 0%{?with_python3}
29BuildRequires:  python%{python3_pkgversion}-rpm-macros
30BuildRequires:  python%{python3_pkgversion}-devel
31BuildRequires:  python%{python3_pkgversion}-setuptools
32%endif
33
34%description
35Fast ASN.1 parser and serializer with definitions for private keys,
36public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
37PKCS#12, PKCS#5, X.509 and TSP.
38
39%if 0%{?with_python3}
40%package -n     python%{python3_pkgversion}-%{pypi_name}
41Summary:        %{summary}
42%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
43
44%description -n python%{python3_pkgversion}-%{pypi_name}
45Fast ASN.1 parser and serializer with definitions for private keys,
46public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
47PKCS#12, PKCS#5, X.509 and TSP.
48%endif
49
50%prep
51%autosetup -n %{pypi_name}-%{version}
52# Remove bundled egg-info
53rm -rf %{pypi_name}.egg-info
54
55%build
56%if 0%{?with_python2}
57%py2_build
58%endif
59%if 0%{?with_python3}
60%py3_build
61%endif
62
63%install
64%if 0%{?with_python2}
65%py2_install
66%endif
67%if 0%{?with_python3}
68%py3_install
69%endif
70
71
72%check
73# asn1crypto source distribution doesn't come with tests
74# {__python2} setup.py test
75%if 0%{?with_python3}
76# {__python3} setup.py test
77%endif
78
79%if 0%{?with_python2}
80%files
81%license LICENSE
82%doc readme* changelog*
83%{python2_sitelib}/%{pypi_name}
84%{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
85%endif
86
87%if 0%{?with_python3}
88%files -n python%{python3_pkgversion}-%{pypi_name}
89%license LICENSE
90%doc readme* changelog*
91%{python3_sitelib}/%{pypi_name}
92%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
93%endif
94
95
96%changelog
97* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.0-1
98- new upstream release.
99
100* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-6
101- initial build for Vine Linux.
102
103* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-5
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
105
106* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-4
107- Rebuilt for Python 3.7
108
109* Tue Jun 19 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-3
110- Build Python 2 package conditionally
111
112* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-2
113- Rebuilt for Python 3.7
114
115* Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-1
116- New upstream release 0.24.0
117
118* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.0-2
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
120
121* Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 0.23-1
122- New upstream release 0.23.0
123
124* Fri Aug 04 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-5
125- Use python2-setuptools, add with_python3
126
127* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-4
128- Modernize spec
129
130* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
132
133* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-2
134- Address rpmlint issues
135
136* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-1
137- Initial package.
Note: See TracBrowser for help on using the repository browser.