source: projects/specs/trunk/p/python-asn1crypto/python-asn1crypto-vl.spec @ 11921

Revision 11921, 3.6 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1# Created by pyp2rpm-3.2.2
2%global pypi_name asn1crypto
3
4%bcond_without python2
5%bcond_without python3
6
7%{!?python3_pkgversion:%global python3_pkgversion 3}
8
9Name:           python-%{pypi_name}
10Version:        0.24.0
11Release:        6%{?_dist_release}
12Summary:        Fast Python ASN.1 parser and serializer
13
14License:        MIT
15URL:            https://github.com/wbond/asn1crypto
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20Source0:        https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
21BuildArch:      noarch
22
23%if 0%{?with_python2}
24BuildRequires:  python-rpm-macros
25BuildRequires:  python-devel
26BuildRequires:  python-setuptools
27%{?python_provide:%python_provide python2-%{pypi_name}}
28%endif
29%if 0%{?with_python3}
30BuildRequires:  python%{python3_pkgversion}-rpm-macros
31BuildRequires:  python%{python3_pkgversion}-devel
32BuildRequires:  python%{python3_pkgversion}-setuptools
33%endif
34
35%description
36Fast ASN.1 parser and serializer with definitions for private keys,
37public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
38PKCS#12, PKCS#5, X.509 and TSP.
39
40%if 0%{?with_python3}
41%package -n     python%{python3_pkgversion}-%{pypi_name}
42Summary:        %{summary}
43%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
44
45%description -n python%{python3_pkgversion}-%{pypi_name}
46Fast ASN.1 parser and serializer with definitions for private keys,
47public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
48PKCS#12, PKCS#5, X.509 and TSP.
49%endif
50
51%prep
52%autosetup -n %{pypi_name}-%{version}
53# Remove bundled egg-info
54rm -rf %{pypi_name}.egg-info
55
56%build
57%if 0%{?with_python2}
58%py_build
59%endif
60%if 0%{?with_python3}
61%py3_build
62%endif
63
64%install
65%if 0%{?with_python2}
66%py_install
67%endif
68%if 0%{?with_python3}
69%py3_install
70%endif
71
72
73%check
74# asn1crypto source distribution doesn't come with tests
75# {__python2} setup.py test
76%if 0%{?with_python3}
77# {__python3} setup.py test
78%endif
79
80%if 0%{?with_python2}
81%files
82%doc
83%{python_sitelib}/%{pypi_name}
84%{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
85%endif
86
87%if 0%{?with_python3}
88%files -n python%{python3_pkgversion}-%{pypi_name}
89%doc
90%{python3_sitelib}/%{pypi_name}
91%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
92%endif
93
94%changelog
95* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-6
96- initial build for Vine Linux.
97
98* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-5
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
100
101* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-4
102- Rebuilt for Python 3.7
103
104* Tue Jun 19 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-3
105- Build Python 2 package conditionally
106
107* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-2
108- Rebuilt for Python 3.7
109
110* Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-1
111- New upstream release 0.24.0
112
113* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.0-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
115
116* Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 0.23-1
117- New upstream release 0.23.0
118
119* Fri Aug 04 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-5
120- Use python2-setuptools, add with_python3
121
122* Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-4
123- Modernize spec
124
125* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
127
128* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-2
129- Address rpmlint issues
130
131* Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-1
132- Initial package.
Note: See TracBrowser for help on using the repository browser.