source: projects/specs/trunk/p/python-Coherence/python-Coherence-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Python framework to participate in digital living networks
4Name:           python-Coherence
5Version:        0.5.8
6Release:        2%{?_dist_release}
7License:        MIT
8Group:          Development/Languages
9URL:            https://coherence.beebits.net/
10Source:         https://coherence.beebits.net/download/Coherence-%{version}.tar.gz
11
12Requires:       python-setuptools
13Requires:       python-configobj
14BuildRequires:  python-devel
15BuildRequires:  python-setuptools
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17Buildarch:      noarch
18
19%description
20Coherence is a framework written in Python enabling applications to participate
21in digital living networks, such as the UPnP universe.
22
23%description -l ja
24Coherence はアプリケーションをDLNA(Digital Living Network Alliance)やUPnPに
25参加できるようにする Python で書かれたフレームワークです。
26
27
28%prep
29%setup -q -n Coherence-%{version}
30
31
32%build
33%{__python} setup.py build
34
35
36%install
37%{__rm} -rf ${RPM_BUILD_ROOT}
38%{__python} setup.py install \
39    --single-version-externally-managed \
40    -O1 --skip-build --root ${RPM_BUILD_ROOT}
41
42
43%clean
44%{__rm} -rf ${RPM_BUILD_ROOT}
45
46
47%files
48%defattr(-,root,root,-)
49%doc LICENCE README docs/*
50%exclude %{_bindir}/applet-coherence
51%{_bindir}/coherence
52%{python_sitelib}/Coherence-*.egg-info/
53%{python_sitelib}/coherence/
54# We don't want this in the package
55%exclude %{python_sitelib}/misc/
56
57
58%changelog
59* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.8-2
60- rebuild with python-2.6
61
62* Wed Dec 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.8-1
63- initial build for Vine Linux based on fedora package
64
65* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5.8-2
66- Rebuild for Python 2.6
67
68* Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.5.8-1
69- Update to 0.5.8.
70- Don't include new "misc" directory, as its location is ugly!
71- Don't include applet-coherence as it probably requires the "misc" directory.
72- Remove all reqs but python-configobj, as it seems to be the only one left.
73
74* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 0.5.0-1
75- Update to 0.5.0.
76
77* Wed Aug 29 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-2
78- Update python-setuptools build requirement to new python-setuptools-devel.
79
80* Fri Aug  3 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-1
81- Update to 0.4.0.
82- No need to update License field, MIT is already correct.
83
84* Tue Jul 24 2007 Matthias Saou <http://freshrpms.net/> 0.3.0-1
85- Update to 0.3.0.
86
87* Tue May  8 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-3
88- Rename Coherence -> python-Coherence to match our python naming guidelines.
89
90* Mon May  7 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-2
91- Rename coherence -> Coherence to match upstream and our naming guidelines.
92- Obsolete coherence < 0.2.1-2 but don't provide it since elisa's requirement
93  has been updated to match the name change and nothing else requires it.
94
95* Fri Apr 20 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-1
96- Update to 0.2.1.
97
98* Fri Mar 23 2007 Matthias Saou <http://freshrpms.net/> 0.1.0-1
99- Update to 0.1.0 release.
100
101* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 0.0-1.r303
102- Switch to using the go-4-python-2.5 svn branch.
103
104* Fri Feb  9 2007 Matthias Saou <http://freshrpms.net/> 0-0.1.r294
105- Initial RPM release.
106
Note: See TracBrowser for help on using the repository browser.