source: projects/specs/trunk/p/python-Coherence/python-Coherence-vl.spec @ 5701

Revision 5701, 4.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary:        Python framework to participate in DLNA/UPnP network.
4Summary(ja):    DLNA や UPnP に参加するための python フレームワーク
5Name:           python-Coherence
6Version:        0.6.6.2
7Release:        2%{?_dist_release}
8License:        MIT
9Group:          Development/Languages
10URL:            https://coherence.beebits.net/
11Source:         https://coherence.beebits.net/download/Coherence-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Buildarch:      noarch
15BuildRequires:  python-devel
16BuildRequires:  python-setuptools
17BuildRequires:  python-twisted
18
19Requires:       python-setuptools
20Requires:       python-configobj
21Requires:       python-twisted
22Requires:       dbus
23
24%description
25Coherence is a framework written in Python enabling applications to participate
26in digital living networks, such as the UPnP universe.
27
28%description -l ja
29Coherence はアプリケーションをDLNA(Digital Living Network Alliance)やUPnPに
30参加できるようにする Python で書かれたフレームワークです。
31
32
33%prep
34%setup -q -n Coherence-%{version}
35
36
37%build
38%{__python} setup.py build
39
40
41%install
42%{__rm} -rf ${RPM_BUILD_ROOT}
43%{__python} setup.py install \
44    --single-version-externally-managed \
45    -O1 --skip-build --root %{buildroot}
46# Install the D-Bus service file
47%{__install} -D -m 0644 -p misc/org.Coherence.service \
48    %{buildroot}/%{_datadir}/dbus-1/services/org.Coherence.service
49# Install the man page
50%{__install} -D -m 0644 -p docs/man/coherence.1 \
51    %{buildroot}/%{_mandir}/man1/coherence.1
52
53
54%clean
55%{__rm} -rf ${RPM_BUILD_ROOT}
56
57
58%files
59%defattr(-,root,root,-)
60%doc LICENCE README docs/*
61%exclude %{_bindir}/applet-coherence
62%{_bindir}/coherence
63%{_datadir}/dbus-1/services/org.Coherence.service
64%{python_sitelib}/Coherence-*.egg-info/
65%{python_sitelib}/coherence/
66# We don't want this in the package
67%exclude %{python_sitelib}/misc/
68%{_mandir}/man1/coherence.1*
69
70
71%changelog
72* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6.2-2
73- rebuild with python-2.7.2
74- add BuildRequires: python-twisted
75
76* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.6.2-1
77- new upstream release
78- add Summary(ja):
79- install D-Bus service file
80- install man pages
81
82* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.8-2
83- rebuild with python-2.6
84
85* Wed Dec 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.8-1
86- initial build for Vine Linux based on fedora package
87
88* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5.8-2
89- Rebuild for Python 2.6
90
91* Tue Jul 15 2008 Matthias Saou <http://freshrpms.net/> 0.5.8-1
92- Update to 0.5.8.
93- Don't include new "misc" directory, as its location is ugly!
94- Don't include applet-coherence as it probably requires the "misc" directory.
95- Remove all reqs but python-configobj, as it seems to be the only one left.
96
97* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 0.5.0-1
98- Update to 0.5.0.
99
100* Wed Aug 29 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-2
101- Update python-setuptools build requirement to new python-setuptools-devel.
102
103* Fri Aug  3 2007 Matthias Saou <http://freshrpms.net/> 0.4.0-1
104- Update to 0.4.0.
105- No need to update License field, MIT is already correct.
106
107* Tue Jul 24 2007 Matthias Saou <http://freshrpms.net/> 0.3.0-1
108- Update to 0.3.0.
109
110* Tue May  8 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-3
111- Rename Coherence -> python-Coherence to match our python naming guidelines.
112
113* Mon May  7 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-2
114- Rename coherence -> Coherence to match upstream and our naming guidelines.
115- Obsolete coherence < 0.2.1-2 but don't provide it since elisa's requirement
116  has been updated to match the name change and nothing else requires it.
117
118* Fri Apr 20 2007 Matthias Saou <http://freshrpms.net/> 0.2.1-1
119- Update to 0.2.1.
120
121* Fri Mar 23 2007 Matthias Saou <http://freshrpms.net/> 0.1.0-1
122- Update to 0.1.0 release.
123
124* Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 0.0-1.r303
125- Switch to using the go-4-python-2.5 svn branch.
126
127* Fri Feb  9 2007 Matthias Saou <http://freshrpms.net/> 0-0.1.r294
128- Initial RPM release.
129
Note: See TracBrowser for help on using the repository browser.