source: projects/specs/trunk/p/python-BeautifulSoup/python-BeautifulSoup-vl.spec @ 8154

Revision 8154, 4.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %global pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define oname   BeautifulSoup
5
6Name:           python-BeautifulSoup
7Version:        3.2.1
8Release:        1%{?_dist_release}
9Summary:        HTML/XML parser for quick-turnaround applications like screen-scraping
10
11Group:          Development/Languages
12License:        BSD
13URL:            http://www.crummy.com/software/BeautifulSoup/
14Source0:        http://www.crummy.com/software/BeautifulSoup/download/3.x/BeautifulSoup-%{version}.tar.gz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildArch:      noarch
18BuildRequires:  python-devel
19
20%description
21Beautiful Soup is a Python HTML/XML parser designed for quick
22turnaround projects like screen-scraping. Three features make it
23powerful:
24
25Beautiful Soup won't choke if you give it bad markup.
26
27Beautiful Soup provides a few simple methods and Pythonic idioms for
28navigating, searching, and modifying a parse tree.
29
30Beautiful Soup automatically converts incoming documents to Unicode
31and outgoing documents to UTF-8.
32
33Beautiful Soup parses anything you give it.
34
35Valuable data that was once locked up in poorly-designed websites is
36now within your reach. Projects that would have taken hours take only
37minutes with Beautiful Soup.
38#'
39
40%prep
41%setup -q -n %{oname}-%{version}
42
43
44%build
45%{__python} setup.py build
46%{__python} -c 'import %{oname} as bs; print bs.__doc__' > COPYING
47touch -r %{oname}.py COPYING
48
49
50%install
51%__rm -rf $RPM_BUILD_ROOT
52%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
53
54#Files installed by error
55%__rm -rf $RPM_BUILD_ROOT%{_bindir}
56
57 
58%clean
59%__rm -rf $RPM_BUILD_ROOT
60
61
62%check
63%{__python} BeautifulSoupTests.py
64
65
66%files
67%defattr(-,root,root,-)
68%doc COPYING
69%{python_sitelib}/%{oname}.py*
70%exclude %{python_sitelib}/%{oname}Tests.py*
71%{python_sitelib}/%{oname}-%{version}-py%{pyver}.egg-info
72
73%changelog
74* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
75- update to 3.2.1
76
77* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.8.1-2
78- rebuild with python-2.7.2
79
80* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.0.8.1-1
81- initial build based on Fedora development
82
83* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:3.0.8.1-2
84- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
85
86* Sun Jun 20 2010 Terje Rosten <terje.rosten@ntnu.no> - 1:3.0.8.1-1
87- 3.0.8.1
88
89* Sun Dec  6 2009 Terje Rosten <terje.rosten@ntnu.no> - 1:3.0.8-1
90- 3.0.8
91- Fix source url
92
93* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.0.7a-2
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Wed Jun 10 2009 kwizart < kwizart at gmail.com > - 1:3.0.7a-1
97- Revert to 3.0.7a and bump Epoch - Fix #505043
98  http://www.crummy.com/software/BeautifulSoup/3.1-problems.html
99
100* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.0.1-3
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
102
103* Mon Jan 12 2009 kwizart < kwizart at gmail.com > - 3.1.0.1-2
104- Fix installed files.
105
106* Mon Jan 12 2009 kwizart < kwizart at gmail.com > - 3.1.0.1-1
107- Update to 3.1.0.1
108
109* Thu Dec  4 2008 kwizart < kwizart at gmail.com > - 3.0.7a-3
110- ReTag
111
112* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.0.7a-2
113- Rebuild for Python 2.6
114
115* Wed Oct 15 2008 kwizart < kwizart at gmail.com > - 3.0.7a-1
116- Update to 3.0.7a
117
118* Mon Jun 30 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.7-2
119- Rebuild
120
121* Mon Jun 23 2008 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.0.7-1
122- Update to 3.0.7
123
124* Tue Feb  5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-3
125- Fix typo
126
127* Tue Feb  5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-2
128- Handle egg info
129- Bump release
130
131* Tue Feb  5 2008 Terje Rosten <terje.rosten@ntnu.no> - 3.0.5-1
132- Update to 3.0.5
133- Minor tweaks to spec file
134
135* Wed Apr 18 2007 kwizart < kwizart at gmail.com > - 3.0.4-1
136- Update to 3.0.4
137
138* Wed Nov 29 2006 TC Wan <tcwan@cs.usm.my>
139- Initial SPEC file for Fedora Core 5
Note: See TracBrowser for help on using the repository browser.