source: projects/specs/trunk/p/pysvn/pysvn-vl.spec @ 8420

Revision 8420, 4.8 KB checked in by kudoh, 10 years ago (diff)
Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pysvn
4Version:        1.7.8
5Release:        1%{?_dist_release}
6Summary:        Pythonic style bindings for Subversion
7Summary(ja):    Subversion 用の python バインディング
8Group:          Development/Languages
9License:        ASL 1.1
10URL:            http://pysvn.tigris.org/
11Source0:        http://pysvn.barrys-emacs.org/source_kits/%{name}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  python-devel
14BuildRequires:  PyXML
15BuildRequires:  subversion-devel
16BuildRequires:  krb5-devel
17BuildRequires:  neon-devel
18BuildRequires:  apr-devel
19BuildRequires:  openssl-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager:       kazutaka
24
25%description
26Pythonic style bindings for Subversion
27
28%description -l ja
29Subversion 用の python バインディングです。
30
31%prep
32%setup -q -n %{name}-%{version}
33
34%build
35pushd Source
36%{__python} setup.py backport
37CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py configure --enable-debug --verbose --norpath --fixed-module-name
38# Set correct build flags
39%{__sed} -i -e 's/-Wall -fPIC -fexceptions -frtti/%{optflags} -fPIC -frtti/' Makefile
40%{__make} %{?_smp_mflags}
41
42%install
43%{__rm} -rf %{buildroot}
44%{__install} -d -m 755 %{buildroot}%{python_sitearch}/%{name}
45%{__install} -p -m 644 Source/pysvn/__init__.py %{buildroot}%{python_sitearch}/%{name}
46%{__install} -p -m 755 Source/pysvn/_pysvn.so %{buildroot}%{python_sitearch}/%{name}
47
48%clean
49%{__rm} -rf %{buildroot}
50
51%files
52%defattr(-, root, root, -)
53%doc Docs/pysvn.html Docs/pysvn_prog_guide.html Docs/pysvn_prog_ref.html
54%doc Docs/pysvn_prog_ref.js
55%doc Examples
56%doc LICENSE.txt
57%{python_sitearch}/%{name}
58
59%changelog
60* Tue Apr 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.8-1
61- new upstream release
62
63* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.7.6-3
64- rebuild with VineSeed environment
65
66* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.6-2
67- rebuilt with subversion-1.7.6
68
69* Tue Jul 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.6-1
70- new upstream release
71
72* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-4
73- rebuild with python-2.7.2
74
75* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-3
76- rebuild with openssl-1.0.0c
77
78* Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.0-2
79- rebuild with python-2.6 (Seed only)
80
81* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.7.0-1
82- initial build for Vine Linux based of fedora development
83- add japanese description and summary
84- run backport command to skip reserved keyword check for python 2.6
85
86* Wed Mar 04 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-2
87- Remove the benchmark patch.  Changes included in this release.
88
89* Tue Mar 03 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-1
90- Update to 1.6.3
91
92* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-4
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
94
95* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.2-3
96- rebuild with new openssl
97
98* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.6.2-2
99- Rebuild for Python 2.6
100
101* Tue Oct 28 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.2-1
102- Upstream to 1.6.2, upstream provided some build fixes to remove patches
103-   (Thanks Barry!).  Re-enabled testing with provided patch to fix whitespace
104
105* Sat Oct 11 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-2
106- Fixed lingering module versioning in __init__
107
108* Mon Oct 06 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-1
109- Update to 1.6.1, fix F10 FBFS
110- Disabled tests, might be because of subversion 1.5
111
112* Wed Feb 27 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.3-1
113- Update to 1.5.3
114
115* Thu Feb 14 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-6
116- Clean up. Name change (back to upstream)
117
118* Tue Feb 12 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-5
119- Temporary fix for tests.  Need to work with upstream for permanent fix.
120
121* Fri Feb 08 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-4
122- Fixed build requires, libgssapi-devel was still in there (for EL5 support)
123
124* Fri Jan 11 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-3
125- Merged patches and spec changes by Terje Røsten <terje.rosten@ntnu.no>
126- Fixed the test failures
127
128* Fri Jan 04 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-2
129- Attempting to make the spec work with different versions of Python
130
131* Mon Sep 03 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-1
132- Update to 1.5.2
133- Some spec clean up
134
135* Fri Jan 12 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.0-1
136- Initial spec creation
137
Note: See TracBrowser for help on using the repository browser.