source: projects/specs/trunk/p/pysvn/pysvn-vl.spec @ 8154

Revision 8154, 4.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pysvn
4Version:        1.7.6
5Release:        3%{?_dist_release}
6Summary:        Pythonic style bindings for Subversion
7Summary(ja):    Subversion 用の python バインディング
8Group:          Development/Languages
9License:        ASL 1.1
10URL:            http://pysvn.tigris.org/
11Source0:        http://pysvn.barrys-emacs.org/source_kits/%{name}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  python-devel
14BuildRequires:  PyXML
15BuildRequires:  subversion-devel
16BuildRequires:  krb5-devel
17BuildRequires:  neon-devel
18BuildRequires:  apr-devel
19BuildRequires:  openssl-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager:       kazutaka
24
25%description
26Pythonic style bindings for Subversion
27
28%description -l ja
29Subversion 用の python バインディングです。
30
31%prep
32%setup -q -n %{name}-%{version}
33
34%build
35pushd Source
36%{__python} setup.py backport
37CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py configure --enable-debug --verbose --norpath --fixed-module-name
38# Set correct build flags
39%{__sed} -i -e 's/-Wall -fPIC -fexceptions -frtti/%{optflags} -fPIC -frtti/' Makefile
40%{__make} %{?_smp_mflags}
41
42%install
43%{__rm} -rf %{buildroot}
44%{__install} -d -m 755 %{buildroot}%{python_sitearch}/%{name}
45%{__install} -p -m 644 Source/pysvn/__init__.py %{buildroot}%{python_sitearch}/%{name}
46%{__install} -p -m 755 Source/pysvn/_pysvn.so %{buildroot}%{python_sitearch}/%{name}
47
48%clean
49%{__rm} -rf %{buildroot}
50
51%files
52%defattr(-, root, root, -)
53%doc Docs/pysvn.html Docs/pysvn_prog_guide.html Docs/pysvn_prog_ref.html
54%doc Docs/pysvn_prog_ref.js
55%doc Examples
56%doc LICENSE.txt
57%{python_sitearch}/%{name}
58
59%changelog
60* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.7.6-3
61- rebuild with VineSeed environment
62
63* Sun Sep 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.6-2
64- rebuilt with subversion-1.7.6
65
66* Tue Jul 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.6-1
67- new upstream release
68
69* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-4
70- rebuild with python-2.7.2
71
72* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-3
73- rebuild with openssl-1.0.0c
74
75* Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.0-2
76- rebuild with python-2.6 (Seed only)
77
78* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.7.0-1
79- initial build for Vine Linux based of fedora development
80- add japanese description and summary
81- run backport command to skip reserved keyword check for python 2.6
82
83* Wed Mar 04 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-2
84- Remove the benchmark patch.  Changes included in this release.
85
86* Tue Mar 03 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-1
87- Update to 1.6.3
88
89* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-4
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
91
92* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.2-3
93- rebuild with new openssl
94
95* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.6.2-2
96- Rebuild for Python 2.6
97
98* Tue Oct 28 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.2-1
99- Upstream to 1.6.2, upstream provided some build fixes to remove patches
100-   (Thanks Barry!).  Re-enabled testing with provided patch to fix whitespace
101
102* Sat Oct 11 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-2
103- Fixed lingering module versioning in __init__
104
105* Mon Oct 06 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-1
106- Update to 1.6.1, fix F10 FBFS
107- Disabled tests, might be because of subversion 1.5
108
109* Wed Feb 27 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.3-1
110- Update to 1.5.3
111
112* Thu Feb 14 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-6
113- Clean up. Name change (back to upstream)
114
115* Tue Feb 12 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-5
116- Temporary fix for tests.  Need to work with upstream for permanent fix.
117
118* Fri Feb 08 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-4
119- Fixed build requires, libgssapi-devel was still in there (for EL5 support)
120
121* Fri Jan 11 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-3
122- Merged patches and spec changes by Terje Røsten <terje.rosten@ntnu.no>
123- Fixed the test failures
124
125* Fri Jan 04 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-2
126- Attempting to make the spec work with different versions of Python
127
128* Mon Sep 03 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-1
129- Update to 1.5.2
130- Some spec clean up
131
132* Fri Jan 12 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.0-1
133- Initial spec creation
134
Note: See TracBrowser for help on using the repository browser.