source: projects/specs/trunk/p/pysvn/pysvn-vl.spec @ 5701

Revision 5701, 4.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pysvn
4Version:        1.7.0
5Release:        4%{?_dist_release}
6Summary:        Pythonic style bindings for Subversion
7Summary(ja):    Subversion 用の python バインディング
8Group:          Development/Languages
9License:        ASL 1.1
10URL:            http://pysvn.tigris.org/
11Source0:        http://pysvn.barrys-emacs.org/source_kits/%{name}-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13BuildRequires:  python-devel
14BuildRequires:  PyXML
15BuildRequires:  subversion-devel
16BuildRequires:  krb5-devel
17BuildRequires:  neon-devel
18BuildRequires:  apr-devel
19BuildRequires:  openssl-devel
20
21Packager:       kazutaka
22
23%description
24Pythonic style bindings for Subversion
25
26%description -l ja
27Subversion 用の python バインディングです。
28
29%prep
30%setup -q -n %{name}-%{version}
31
32%build
33pushd Source
34%{__python} setup.py backport
35CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py configure --enable-debug --verbose --norpath --fixed-module-name
36# Set correct build flags
37%{__sed} -i -e 's/-Wall -fPIC -fexceptions -frtti/%{optflags} -fPIC -frtti/' Makefile
38%{__make} %{?_smp_mflags}
39
40%install
41%{__rm} -rf %{buildroot}
42%{__install} -d -m 755 %{buildroot}%{python_sitearch}/%{name}
43%{__install} -p -m 644 Source/pysvn/__init__.py %{buildroot}%{python_sitearch}/%{name}
44%{__install} -p -m 755 Source/pysvn/_pysvn.so %{buildroot}%{python_sitearch}/%{name}
45
46%check
47#pushd Tests
48#%{__make} %{?_smp_mflags}
49
50%clean
51%{__rm} -rf %{buildroot}
52
53%files
54%defattr(-, root, root, -)
55%doc Docs/pysvn.html Docs/pysvn_prog_guide.html Docs/pysvn_prog_ref.html
56%doc Docs/pysvn_prog_ref.js
57%doc Examples
58%doc LICENSE.txt
59%{python_sitearch}/%{name}
60
61%changelog
62* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-4
63- rebuild with python-2.7.2
64
65* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.0-3
66- rebuild with openssl-1.0.0c
67
68* Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.0-2
69- rebuild with python-2.6 (Seed only)
70
71* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.7.0-1
72- initial build for Vine Linux based of fedora development
73- add japanese description and summary
74- run backport command to skip reserved keyword check for python 2.6
75
76* Wed Mar 04 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-2
77- Remove the benchmark patch.  Changes included in this release.
78
79* Tue Mar 03 2009 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.3-1
80- Update to 1.6.3
81
82* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-4
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
84
85* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.2-3
86- rebuild with new openssl
87
88* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.6.2-2
89- Rebuild for Python 2.6
90
91* Tue Oct 28 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.2-1
92- Upstream to 1.6.2, upstream provided some build fixes to remove patches
93-   (Thanks Barry!).  Re-enabled testing with provided patch to fix whitespace
94
95* Sat Oct 11 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-2
96- Fixed lingering module versioning in __init__
97
98* Mon Oct 06 2008 Caitlyn O'Hanna <ravenoak@virtualxistenz.com> - 1.6.1-1
99- Update to 1.6.1, fix F10 FBFS
100- Disabled tests, might be because of subversion 1.5
101
102* Wed Feb 27 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.3-1
103- Update to 1.5.3
104
105* Thu Feb 14 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-6
106- Clean up. Name change (back to upstream)
107
108* Tue Feb 12 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-5
109- Temporary fix for tests.  Need to work with upstream for permanent fix.
110
111* Fri Feb 08 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-4
112- Fixed build requires, libgssapi-devel was still in there (for EL5 support)
113
114* Fri Jan 11 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-3
115- Merged patches and spec changes by Terje Røsten <terje.rosten@ntnu.no>
116- Fixed the test failures
117
118* Fri Jan 04 2008 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-2
119- Attempting to make the spec work with different versions of Python
120
121* Mon Sep 03 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.2-1
122- Update to 1.5.2
123- Some spec clean up
124
125* Fri Jan 12 2007 Timothy Selivanow <timothy.selivanow@virtualxistenz.com> - 1.5.0-1
126- Initial spec creation
127
Note: See TracBrowser for help on using the repository browser.