source: projects/specs/trunk/p/pysqlite/pysqlite-vl.spec @ 521

Revision 521, 1.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pyexeclib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2%define name pysqlite
3%define major 2.4
4%define version 2.4.1
5%define release 1%{?_dist_release}
6
7Summary: Python DB-API 2.0 interface for SQLite
8Summary(ja): SQLite の Python バインディング
9Name: %{name}
10Version: %{version}
11Release: %{release}
12Source0: http://initd.org/pub/software/pysqlite/releases/%{major}/%{version}/%{name}-%{version}.tar.gz
13License: redistributable
14Group: Development/Libraries
15URL: http://initd.org/tracker/pysqlite
16
17Requires: python, sqlite3
18BuildRequires: python-devel, sqlite3-devel
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25pysqlite is a DB-API 2.0-compliant database interface for SQLite.
26
27%description -l ja
28pysqlite は DB-API 2.0 に準拠した SQLite 用の Python バインディングです。
29
30%prep
31%setup -q
32
33
34%build
35%{__python} setup.py build
36
37%install
38rm -rf $RPM_BUILD_ROOT
39%{__python} setup.py install --prefix=${RPM_BUILD_ROOT}%{_prefix} --install-data=${RPM_BUILD_ROOT}%{_docdir}
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(-,root,root)
46%doc LICENSE doc
47%{pyexeclib}/pysqlite2/
48%{_docdir}/pysqlite2-doc/
49
50%changelog
51* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.1-1vl5
52- rebuilt with python-2.5.2
53- added pyexeclib macro
54- applied new versioning policy and spec in utf-8
55
56* Wed Feb 6 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.4.1-0vl2
57- upstream release
58
59* Mon Aug 27 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.3.5-0vl2
60- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.