source: projects/specs/trunk/p/pyrenamer/pyrenamer-vl.spec @ 8154

Revision 8154, 2.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1# -*- encoding: utf-8 -*-
2%define ver 0.6.0
3%define rel 3
4
5Summary: an application for mass renaming files
6Summary: 大量のファイルの名前を変更するためのアプリケーション
7Name: pyrenamer
8Version: %{ver}
9Release: %{rel}%{?_dist_release}
10License: GPLv2
11Group: Applications/Accessories
12URL: http://www.infinicode.org/code/pyrenamer/
13Source0: http://www.infinicode.org/code/pyrenamer/files/%{name}-%{version}.tar.gz
14Source1: pyrenamer_trunk-ja.po
15Source2: pyrenamer-0.6.0-LINGUAS
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
17BuildRequires: pygtk2-devel GConf2-devel
18BuildRequires: desktop-file-utils
19Requires: pygtk2 GConf2
20Requires(post,postun): desktop-file-utils
21BuildArch: noarch
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: iwaim
26
27%description
28pyRenamer is an application for mass renaming files.
29
30You can rename files using patterns, substitutions,
31insert or delete text, or even rename files manually.
32You can also rename images using their EXIF tags
33and music using their internal tags.
34
35%prep
36%setup -q
37%__cp -a %{SOURCE1} po/ja.po
38%__rm -f po/LINGUAS
39%__cp -a %{SOURCE2} po/LINGUAS
40%configure
41
42%build
43make
44
45%install
46%__rm -rf %{buildroot}
47%makeinstall
48
49%__rm -rf %{buildroot}%{_docdir}/%{name}
50
51%find_lang %{name}
52
53%check
54make check
55%{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
56
57%clean
58%__rm -rf %{buildroot}
59
60
61%post
62if [ -x %{_bindir}/update-desktop-database ] ; then
63%{_bindir}/update-desktop-database %{_datadir}/applications
64fi
65
66%postun
67if [ -x %{_bindir}/update-desktop-database ] ; then
68%{_bindir}/update-desktop-database %{_datadir}/applications
69fi
70
71
72%files -f %{name}.lang
73%defattr(-,root,root,-)
74%doc AUTHORS COPYING ChangeLog NEWS README TODO
75%{_bindir}/pyrenamer
76%{_sysconfdir}/gconf/schemas/%{name}.schemas
77%{python_sitelib}/%{name}
78%{_datadir}/applications/%{name}.desktop
79%{_mandir}/man1/%{name}.1*
80%{_datadir}/pixmaps/*.png
81%{_datadir}/%{name}
82
83
84%changelog
85* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-3
86- rebuild with VineSeed environment
87
88* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
89- rebuild with python-2.7.2
90
91* Mon Jun  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.0-1
92- Initial build.
Note: See TracBrowser for help on using the repository browser.