source: projects/specs/trunk/p/pypoppler/pypoppler-vl.spec @ 6133

Revision 6133, 3.0 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pypoppler
4Version:        0.12.1
5Release:        5%{?_dist_release}
6Summary:        Python bindings for the Poppler PDF rendering library
7Summary(ja):    Poppler PDF レンダリングライブラリの Python バインディング
8
9Group:          Applications/Publishing
10License:        GPLv2+
11URL:            https://launchpad.net/poppler-python
12
13Source0:        http://launchpad.net/poppler-python/trunk/development/+download/%{name}-%{version}.tar.gz
14
15# Release the GIL on blocking functions like rendering pages and getting
16# thumbnails, see bug #504240 reported by BenjaminBerg.
17# bzr rev 75
18Patch0:         75_74.diff
19
20# Manually wrap poppler_page_render_to_pixbuf and
21# poppler_page_render_to_pixbuf_for_printing returning the Pixbuf
22# bzr rev 76
23#Patch1:                76_75.diff
24
25# Fix a few leaks by using the right functions while freeing the returned lists
26# bzr 79
27Patch2:         79_78.diff
28
29# Changes for poppler 1.5
30Patch3:         pypoppler-0.12.1-poppler0.15.0-changes.patch
31
32# Minimal fix for changes in poppler 0.18
33Patch4:         pypoppler-0.12.1-poppler-0.18.0-minimal-fix.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37BuildRequires:  pygtk2-devel
38BuildRequires:  atk-devel
39BuildRequires:  poppler-devel
40BuildRequires:  pycairo-devel
41#BuildRequires:  poppler-glib-devel >= 0.10.5
42
43
44%description
45Python bindings for the Poppler PDF rendering library. It is needed to
46run programs written in Python and using Poppler set.
47
48
49%prep
50%setup -q
51%patch0 -p0 -b .bzr75
52#%patch1 -p0 -b .bzr76
53%patch2 -p0 -b .bzr79
54%patch3 -p1 -b .poppler15
55%patch4 -p1 -b .poppler-18-minimal
56
57
58%build
59%configure --disable-static
60make %{?_smp_mflags}
61
62
63%install
64rm -rf %{buildroot}
65make install DESTDIR=%{buildroot} INSTALL="install -p"
66find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
67
68
69%clean
70rm -rf %{buildroot}
71
72
73%files
74%defattr(-,root,root,-)
75%doc AUTHORS ChangeLog COPYING NEWS
76%{python_sitearch}/poppler*
77
78
79%changelog
80* Thu May 03 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.1-5
81- rebuilt with poppler-0.18.4
82- dropt Pacth1
83- added Patch4 from Fedora rawhide
84
85* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.1-4
86- rebuild with python-2.7.2
87
88* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.12.1-3
89- rebuilt with poppler-0.16.3
90- added Patch0-3 from Fedora
91
92* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.1-2
93- rebuild with poppler-0.14.2
94
95* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.1-1
96- initail build for VineSeed
97
98* Thu Nov 19 2009 Fabian Affolter <fabian@bernewireless.net> - 0.12.1-1
99- Updated to new upstream version 0.12.1
100
101* Thu Sep 17 2009 Fabian Affolter <fabian@bernewireless.net> - 0.10.1-1
102- Updated to new upstream version 0.10.1
103
104* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
106
107* Sat Apr 25 2009 Fabian Affolter <fabian@bernewireless.net> - 0.10.0-1
108- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.