source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 521

Revision 521, 4.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define python_sitearch %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary: Python module for GNU parted
3Summary(ja): parted の python モジュール
4Name:    pyparted
5Version: 1.8.9
6Release: 2%{?_dist_release}
7License: GPLv2+
8Group:   System Environment/Libraries
9
10Source0: %{name}/%{name}-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires: python-devel, parted-devel >= 1.8.8
14Requires: parted >= 1.8.8
15
16%description
17Python modules for the parted library.  It is used for manipulation
18partition tables.
19
20%prep
21%setup -q
22
23%build
24export CFLAGS="%{optflags}"
25%__make %{?_smp_mflags}
26
27%install
28rm -rf $RPM_BUILD_ROOT
29%__make install DESTDIR=$RPM_BUILD_ROOT
30
31%clean
32rm -rf $RPM_BUILD_ROOT
33
34%files
35%defattr(-,root,root,-)
36%doc README COPYING AUTHORS ChangeLog
37%{python_sitearch}/*.so
38
39%changelog
40* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
41- rebuilt with python-2.6.4
42
43* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
44- new upstream release
45- build with parted-1.8.8
46
47* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
48- rebuilt with python-2.5.2
49- added pyexeclib macro
50- applied new versioning policy and spec in utf-8
51
52* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
53- rebuilt for VineSeed with parted-1.8.1 and python-2.4
54
55* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
56- rebuild for python 2.5
57
58* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
59- Rebuild for GNU parted-1.8.1
60
61* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
62- Determine Python version to use in %%build so the source RPM is more
63  easily moved between distribution releases.
64
65* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
66- Bump version to 1.8.0 and require parted >= 1.8.0
67- Remove python-abi Requires line since rpm handles that automatically
68
69* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
70- Include parted/constraint.h in required header files
71
72* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
73- Require parted-1.7.1 or higher
74
75* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
76- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
77
78* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
79- rebuild
80
81* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
82- Bump version to 1.7.1 and require parted >= 1.7.1
83
84* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
85- Bump version to 1.7.0 and require parted >= 1.7.0
86
87* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
88- rebuilt
89
90* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
91- rebuild for new parted.
92- add debugging options for make so debuginfo isn't useless
93
94* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
95- rebuild for new parted
96
97* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
98- Rebuilt for new parted library.
99
100* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
101- Updated for gcc4 and python2.4.  Fixed build warnings.
102
103* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
104- add support for sx8 devices
105
106* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
107- rebuild for python 2.4
108
109* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
110- #135100 req python-abi (Robert Scheck)
111
112* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
113- update for new parted ABI
114  - device -> heads, sectors, cylinders now refer to the bios geometry
115- require parted >= 1.6.12
116
117* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
118- build on ppc64 again
119
120* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
121- fix build for newer versions of gcc (fix from Jeff Law)
122
123* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
124- fix PARTITION_PROTECTED definition (#118451)
125
126* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
127- Initial build split out into separate source from the parted package.
128- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.