source: projects/specs/trunk/p/pyparted/pyparted-vl.spec @ 8154

Revision 8154, 4.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define python_sitearch %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
2Summary: Python module for GNU parted
3Summary(ja): parted の python モジュール
4Name:    pyparted
5Version: 3.8
6Release: 4%{?_dist_release}
7License: GPLv2+
8Group:   System Environment/Libraries
9
10Source0: https://fedorahosted.org/releases/p/y/%{name}/%{name}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildRequires: python-devel, parted-devel >= 3.0
14Requires: parted >= 3.0
15
16%description
17Python modules for the parted library.  It is used for manipulation
18partition tables.
19
20%prep
21%setup -q
22
23%build
24export CFLAGS="%{optflags}"
25%__make %{?_smp_mflags}
26
27%install
28rm -rf $RPM_BUILD_ROOT
29%__make install DESTDIR=$RPM_BUILD_ROOT
30
31%clean
32rm -rf $RPM_BUILD_ROOT
33
34%files
35%defattr(-,root,root,-)
36%doc README COPYING AUTHORS ChangeLog
37%{python_sitearch}/parted
38%{python_sitearch}/*.egg-info
39%{python_sitearch}/*.so
40
41%changelog
42* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-4
43- rebuild with VineSeed environment
44
45* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
46- rebuild with parted-3.1
47
48* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
49- rebuild with python-2.7.2
50
51* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
52- new upstream release
53
54* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
55- rebuild with parted-2.3
56
57* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
58- rebuilt with python-2.6.4
59
60* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
61- new upstream release
62- build with parted-1.8.8
63
64* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
65- rebuilt with python-2.5.2
66- added pyexeclib macro
67- applied new versioning policy and spec in utf-8
68
69* Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
70- rebuilt for VineSeed with parted-1.8.1 and python-2.4
71
72* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
73- rebuild for python 2.5
74
75* Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
76- Rebuild for GNU parted-1.8.1
77
78* Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
79- Determine Python version to use in %%build so the source RPM is more
80  easily moved between distribution releases.
81
82* Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
83- Bump version to 1.8.0 and require parted >= 1.8.0
84- Remove python-abi Requires line since rpm handles that automatically
85
86* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
87- Include parted/constraint.h in required header files
88
89* Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
90- Require parted-1.7.1 or higher
91
92* Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
93- Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
94
95* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
96- rebuild
97
98* Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
99- Bump version to 1.7.1 and require parted >= 1.7.1
100
101* Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
102- Bump version to 1.7.0 and require parted >= 1.7.0
103
104* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
105- rebuilt
106
107* Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
108- rebuild for new parted.
109- add debugging options for make so debuginfo isn't useless
110
111* Wed Nov  9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
112- rebuild for new parted
113
114* Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
115- Rebuilt for new parted library.
116
117* Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
118- Updated for gcc4 and python2.4.  Fixed build warnings.
119
120* Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
121- add support for sx8 devices
122
123* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
124- rebuild for python 2.4
125
126* Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
127- #135100 req python-abi (Robert Scheck)
128
129* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
130- update for new parted ABI
131  - device -> heads, sectors, cylinders now refer to the bios geometry
132- require parted >= 1.6.12
133
134* Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
135- build on ppc64 again
136
137* Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
138- fix build for newer versions of gcc (fix from Jeff Law)
139
140* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
141- fix PARTITION_PROTECTED definition (#118451)
142
143* Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
144- Initial build split out into separate source from the parted package.
145- Don't build on ppc64 right now due to parted build problems (#118183)
Note: See TracBrowser for help on using the repository browser.