source: projects/specs/trunk/p/pylint/pylint-vl.spec @ 6011

Revision 6011, 6.5 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name:           pylint
2Version:        0.25.1
3Release:        1%{?_dist_release}
4Summary:        Analyzes Python code looking for bugs and signs of poor quality
5
6Group:          Development/Debuggers
7License:        GPLv2+
8URL:            http://www.logilab.org/projects/pylint
9Source0:        ftp://ftp.logilab.org/pub/pylint/pylint-%{version}.tar.gz
10BuildArch:      noarch
11BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13BuildRequires:  python-devel python-setuptools python-unittest2
14BuildRequires:  python-logilab-astng >= 0.22.0
15Requires:       python-logilab-astng >= 0.22.0
16
17
18%description
19Pylint is a python tool that checks if a module satisfy a coding standard.
20Pylint can be seen as another PyChecker since nearly all tests you can do
21with PyChecker can also be done with Pylint. But Pylint offers some more
22features, like checking line-code's length, checking if variable names are
23well-formed according to your coding standard, or checking if declared
24interfaces are truly implemented, and much more. The big advantage with
25Pylint is that it is highly configurable, customizable, and you can easily
26write a small plugin to add a personal feature.
27
28
29%package gui
30Summary:        Graphical Interface tool for Pylint
31Group:          Development/Debuggers
32Requires:       %{name} = %{version}-%{release}
33Requires:       tkinter
34
35%description gui
36This package provides a gui tool for pylint written in tkinter.
37
38
39%prep
40%setup -q
41
42%build
43%{__python} setup.py build
44
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
49rm -rf $RPM_BUILD_ROOT%{_python_sitelib}/pylint/test
50mkdir -pm 755 $RPM_BUILD_ROOT%{_mandir}/man1
51install -pm 644 man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
52for FILE in README doc/*.txt; do
53    iconv -f iso-8859-15 -t utf-8 $FILE > $FILE.utf8
54    mv -f $FILE.utf8 $FILE
55done
56
57%check
58%{__python} setup.py test
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63
64%files
65%defattr(-,root,root,-)
66%doc doc/*.txt README ChangeLog examples elisp COPYING
67%{python_sitelib}/pylint*
68%{_bindir}/*
69%{_mandir}/man?/*
70%exclude %{python_sitelib}/pylint/gui.py*
71%exclude %{_bindir}/pylint-gui
72
73%files gui
74%defattr(-,root,root,-)
75%doc COPYING
76%{python_sitelib}/pylint/gui.py*
77%{_bindir}/pylint-gui
78
79
80%changelog
81* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25.1-1
82- initial build for Vine Linux
83
84
85* Wed Mar 14 2012 Brian C. Lane <bcl@redhat.com> 0.25.1-1
86- Upstream 0.25.1
87
88* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-2
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
90
91* Fri Nov 18 2011 Brian C. Lane <bcl@redhat.com> - 0.25.0-1
92- Upstream 0.25.0
93
94* Fri Jul 29 2011 Brian C. Lane <bcl@redhat.com> - 0.24.0-1
95- Upstream 0.24.0
96
97* Mon Mar 28 2011 Brian C. Lane <bcl@redhat.com> - 0.23-0.1
98- Upstream 0.23.0
99- Add unit tests to spec
100
101* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.0-3
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
103
104* Mon Dec 06 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-2
105- Add version to requirement for python-logilab-astng so that updates will
106  work correctly.
107
108* Mon Nov 29 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-1
109- Upstream 0.22.0
110
111* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.21.1-2
112- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
113
114* Thu Jul 08 2010 Brian C. Lane <bcl@redhat.com> - 0.21.1-1
115- Upstream 0.21.1
116- Removed patch for 500272, fixed upstream - http://www.logilab.org/ticket/22962
117
118* Mon Apr 05 2010 Brian C. Lane <bcl@redhat.com> - 0.20.0-2
119- Added patch for bug 500272 (exception with --disable-msg-cat)
120
121* Fri Mar 26 2010 Brian C.Lane <bcl@redhat.com> - 0.20.0-1
122- Upstream 0.20.0
123- Added python-setuptools to BuildRequires
124
125* Sun Aug 30 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.1-1
126- Upstream 0.18.1 (bugfixes and small enhancements)
127
128* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18.0-2
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Wed Jun 17 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.0-1
132- Upstream 0.18.0 (bugfixes and minor feature updates)
133
134* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.0-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Wed Jan 28 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.16.0-1
138- Upstream 0.16.0
139
140* Tue Dec 30 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.15.2-1
141- Upstream 0.15.2
142
143* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.14.0-2
144- Rebuild for Python 2.6
145
146* Thu Jan 17 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.14.0-1
147- Upstream 0.14.0
148- Package the .egg-info files.
149
150* Mon Dec 24 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.2-1
151- Upstream 0.13.2
152- Adjust license to a more precise version
153- Fix docs to be valid utf-8
154
155* Sun Apr 01 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.1-1
156- Upstream 0.13.1
157
158* Sun Dec 17 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.2-1
159- Upstream 0.12.2
160- Add COPYING to -gui
161
162* Tue Sep 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.1-1
163- Upstream 0.12.1
164- Require the renamed python-logilab-astng
165
166* Mon May 01 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.11.0-0
167- Version 0.11.0
168
169* Sun Mar 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.10.0-1
170- Version 0.10.0
171
172* Thu Jan 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.9.0-1
173- Version 0.9.0
174- Add COPYING to docs
175
176* Sun Nov 13 2005 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.8.1-1
177- Version 0.8.1
178- Add dependency on python-astng
179- Drop artificial version requirement on python-logilab-common
180
181* Mon Jun 13 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.7.0-1
182- Version 0.7.0
183- No longer in the logilab subdir
184- Disttagging
185
186* Mon May 09 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-4
187- Install the pylint.1 manfile.
188- Add examples and elisp dirs to docs.
189
190* Thu May 05 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-3
191- Only doc the .txt files.
192- Don't buildrequire python-logilab-common
193- Fix paths.
194
195* Tue Apr 26 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-2
196- Ghost .pyo files.
197- Remove the test dir, as it doesn't do anything.
198- Separate the gui package, which depends on tkinter.
199- Don't own site-packages/logilab, which is owned by
200  python-logilab-common.
201
202* Fri Apr 22 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-1
203- Initial packaging.
Note: See TracBrowser for help on using the repository browser.