source: projects/specs/trunk/p/pygtksourceview/pygtksourceview-vl.spec @ 5701

Revision 5701, 4.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pygtk_version 2.14.1
4%define pygobject_version 2.16.1
5%define gtksourceview_version 2.10.0
6
7Name:           pygtksourceview
8Version:        2.10.1
9Release:        3%{?_dist_release}
10Summary:        Python bindings for gtksourceview
11
12Group:          Development/Libraries
13License:        LGPL
14URL:            http://download.gnome.org/sources/pygtksourceview/
15Source0:        http://download.gnome.org/sources/pygtksourceview/2.6/pygtksourceview-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  gtksourceview2-devel >= %{gtksourceview_version}
19BuildRequires:  pygobject-devel >= %{pygobject_version}
20BuildRequires:  pygobject-doc >= %{pygobject_version}
21BuildRequires:  pygtk2-devel >= %{pygtk_version}
22BuildRequires:  python-devel
23BuildRequires:  gtk-doc >= 1.14
24
25%description
26The %{name} package contains Python bindings for the gtksourceview
27library.
28
29%package devel
30Summary: Development files for using %{name} in Python programs
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: %{name}-doc = %{version}-%{release}
34Requires: gtksourceview2-devel >= %{gtksourceview_version}
35Requires: pkgconfig
36Requires: pygtk2-devel >= %{pygtk_version}
37
38%description devel
39This package contains files required to build Python programs that
40use the %{name} bindings.
41
42%package doc
43Summary: Documentation files for %{name}
44Group: Applications/Documentation
45
46%description doc
47This package contains documentation files for %{name}.
48
49%prep
50%setup -q
51
52%build
53%configure
54## added adhoc patch
55##make PYTHON='LD_PRELOAD=%{_libdir}/python%{pyver}/lib-dynload/timemodule.so %{_bindir}/python'
56make
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make install DESTDIR=$RPM_BUILD_ROOT
61
62rm -f $RPM_BUILD_ROOT%{python_sitearch}/gtksourceview2.la
63 
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(-,root,root,-)
69%doc COPYING AUTHORS README NEWS
70%{python_sitearch}/*
71
72%files devel
73%defattr(-,root,root,-)
74%{_datadir}/pygtk/2.0/defs/gtksourceview2.defs
75%{_libdir}/pkgconfig/pygtksourceview-2.0.pc
76
77%files doc
78%defattr(-,root,root,-)
79%{_datadir}/gtk-doc/html/pygtksourceview2
80
81%changelog
82* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-3
83- rebuild with python-2.7.2
84
85* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.10.1-2
86- rebuilt with rpm-4.8.1 for pkg-config
87
88* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-1
89- new upstream release
90
91* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
92- new upstream release
93- add BuildRequires: gtk-doc >= 1.14
94
95* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-4
96- added BR: pygobject-doc
97
98* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-3
99- rebuilt with python-2.6.4-3
100- dropt adhoc patch to make
101
102* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-2
103- rebuilt with python-2.6.4
104- added adhoc patch to fix python bug (import datetime module error)
105
106* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-1
107- new upstream release
108
109* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
110- new upstream release
111
112* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.0-1
113- new upstream release
114- changed Group to Development/Libraries
115
116* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-2
117- rebuilt with python-2.5.2
118
119* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-1vl5
120- Initial build for Vine Linux
121
122* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 2.2.0-1
123- Update to 2.2.0
124
125* Wed Feb  6 2008 Matthias Clasen <mclasen@redhat.com> - 2.1.1-1
126- Update to 2.1.1
127
128* Tue Jan 22 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-2.fc9
129- Fix a typo.
130
131* Mon Jan 21 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-1.fc9
132- Update to 2.1.0
133
134* Fri Oct 26 2007 Matthew Barnes <mbarnes@redhat.com> - 2.0.0-2.fc9
135- Add subpackage pygtksourceview-doc (bug #342991).
136
137* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
138- Update to 2.0.0
139
140* Tue Sep 11 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.5-1
141- Update to 1.90.5
142
143* Tue Sep  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.4-1
144- Update to 1.90.4
145
146* Wed Aug  1 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.3-1
147- Update to 1.90.3
148
149* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.2-2
150- Rebuild against the gtksourceview2 package
151
152* Fri Jul 06 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.2-1.fc8
153- Update to 1.90.2
154- Bump gtksourceview requirement to 1.90.2.
155
156* Tue Jul 03 2007 Florian La Roche <laroche@redhat.com> 1.90.1-3
157- fix macro typo
158
159* Tue Jun 26 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-2
160- Incorporate package review feedback
161
162* Mon Jun 25 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-1
163- Initial package
Note: See TracBrowser for help on using the repository browser.