source: projects/specs/trunk/p/pygtksourceview/pygtksourceview-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pygtk_version 2.14.1
4%define pygobject_version 2.16.1
5%define gtksourceview_version 2.8.1
6
7Name:           pygtksourceview
8Version:        2.8.0
9Release:        4%{?_dist_release}
10Summary:        Python bindings for gtksourceview
11
12Group:          Development/Libraries
13License:        LGPL
14URL:            http://download.gnome.org/sources/pygtksourceview/
15Source0:        http://download.gnome.org/sources/pygtksourceview/2.6/pygtksourceview-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  gtksourceview2-devel >= %{gtksourceview_version}
19BuildRequires:  pygobject-devel >= %{pygobject_version}
20BuildRequires:  pygobject-doc >= %{pygobject_version}
21BuildRequires:  pygtk2-devel >= %{pygtk_version}
22BuildRequires:  python-devel
23
24%description
25The %{name} package contains Python bindings for the gtksourceview
26library.
27
28%package devel
29Summary: Development files for using %{name} in Python programs
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: %{name}-doc = %{version}-%{release}
33Requires: gtksourceview2-devel >= %{gtksourceview_version}
34Requires: pkgconfig
35Requires: pygtk2-devel >= %{pygtk_version}
36
37%description devel
38This package contains files required to build Python programs that
39use the %{name} bindings.
40
41%package doc
42Summary: Documentation files for %{name}
43Group: Applications/Documentation
44
45%description doc
46This package contains documentation files for %{name}.
47
48%prep
49%setup -q
50
51%build
52%configure
53## added adhoc patch
54##make PYTHON='LD_PRELOAD=%{_libdir}/python%{pyver}/lib-dynload/timemodule.so %{_bindir}/python'
55make
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install DESTDIR=$RPM_BUILD_ROOT
60
61rm -f $RPM_BUILD_ROOT%{python_sitearch}/gtksourceview2.la
62 
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(-,root,root,-)
68%doc COPYING AUTHORS README NEWS
69%{python_sitearch}/*
70
71%files devel
72%defattr(-,root,root,-)
73%{_datadir}/pygtk/2.0/defs/gtksourceview2.defs
74%{_libdir}/pkgconfig/pygtksourceview-2.0.pc
75
76%files doc
77%defattr(-,root,root,-)
78%{_datadir}/gtk-doc/html/pygtksourceview2
79
80%changelog
81* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-4
82- added BR: pygobject-doc
83
84* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-3
85- rebuilt with python-2.6.4-3
86- dropt adhoc patch to make
87
88* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-2
89- rebuilt with python-2.6.4
90- added adhoc patch to fix python bug (import datetime module error)
91
92* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-1
93- new upstream release
94
95* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
96- new upstream release
97
98* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.0-1
99- new upstream release
100- changed Group to Development/Libraries
101
102* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-2
103- rebuilt with python-2.5.2
104
105* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-1vl5
106- Initial build for Vine Linux
107
108* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 2.2.0-1
109- Update to 2.2.0
110
111* Wed Feb  6 2008 Matthias Clasen <mclasen@redhat.com> - 2.1.1-1
112- Update to 2.1.1
113
114* Tue Jan 22 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-2.fc9
115- Fix a typo.
116
117* Mon Jan 21 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-1.fc9
118- Update to 2.1.0
119
120* Fri Oct 26 2007 Matthew Barnes <mbarnes@redhat.com> - 2.0.0-2.fc9
121- Add subpackage pygtksourceview-doc (bug #342991).
122
123* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
124- Update to 2.0.0
125
126* Tue Sep 11 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.5-1
127- Update to 1.90.5
128
129* Tue Sep  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.4-1
130- Update to 1.90.4
131
132* Wed Aug  1 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.3-1
133- Update to 1.90.3
134
135* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.2-2
136- Rebuild against the gtksourceview2 package
137
138* Fri Jul 06 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.2-1.fc8
139- Update to 1.90.2
140- Bump gtksourceview requirement to 1.90.2.
141
142* Tue Jul 03 2007 Florian La Roche <laroche@redhat.com> 1.90.1-3
143- fix macro typo
144
145* Tue Jun 26 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-2
146- Incorporate package review feedback
147
148* Mon Jun 25 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-1
149- Initial package
Note: See TracBrowser for help on using the repository browser.