source: projects/specs/trunk/p/pygtksourceview/pygtksourceview-vl.spec @ 8154

Revision 8154, 4.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pygtk_version 2.14.1
4%define pygobject_version 2.16.1
5%define gtksourceview_version 2.10.0
6
7Name:           pygtksourceview
8Version:        2.10.1
9Release:        4%{?_dist_release}
10Summary:        Python bindings for gtksourceview
11
12Group:          Development/Libraries
13License:        LGPL
14URL:            http://download.gnome.org/sources/pygtksourceview/
15Source0:        http://download.gnome.org/sources/pygtksourceview/2.6/pygtksourceview-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  gtksourceview2-devel >= %{gtksourceview_version}
19BuildRequires:  pygobject-devel >= %{pygobject_version}
20BuildRequires:  pygobject-doc >= %{pygobject_version}
21BuildRequires:  pygtk2-devel >= %{pygtk_version}
22BuildRequires:  python-devel
23BuildRequires:  gtk-doc >= 1.14
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29The %{name} package contains Python bindings for the gtksourceview
30library.
31
32%package devel
33Summary: Development files for using %{name} in Python programs
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: %{name}-doc = %{version}-%{release}
37Requires: gtksourceview2-devel >= %{gtksourceview_version}
38Requires: pkgconfig
39Requires: pygtk2-devel >= %{pygtk_version}
40
41%description devel
42This package contains files required to build Python programs that
43use the %{name} bindings.
44
45%package doc
46Summary: Documentation files for %{name}
47Group: Applications/Documentation
48
49%description doc
50This package contains documentation files for %{name}.
51
52%prep
53%setup -q
54
55%build
56%configure
57## added adhoc patch
58##make PYTHON='LD_PRELOAD=%{_libdir}/python%{pyver}/lib-dynload/timemodule.so %{_bindir}/python'
59make
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT
64
65rm -f $RPM_BUILD_ROOT%{python_sitearch}/gtksourceview2.la
66 
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-,root,root,-)
72%doc COPYING AUTHORS README NEWS
73%{python_sitearch}/*
74
75%files devel
76%defattr(-,root,root,-)
77%{_datadir}/pygtk/2.0/defs/gtksourceview2.defs
78%{_libdir}/pkgconfig/pygtksourceview-2.0.pc
79
80%files doc
81%defattr(-,root,root,-)
82%{_datadir}/gtk-doc/html/pygtksourceview2
83
84%changelog
85* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-4
86- rebuild with VineSeed environment
87
88* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-3
89- rebuild with python-2.7.2
90
91* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.10.1-2
92- rebuilt with rpm-4.8.1 for pkg-config
93
94* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.1-1
95- new upstream release
96
97* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
98- new upstream release
99- add BuildRequires: gtk-doc >= 1.14
100
101* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-4
102- added BR: pygobject-doc
103
104* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-3
105- rebuilt with python-2.6.4-3
106- dropt adhoc patch to make
107
108* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-2
109- rebuilt with python-2.6.4
110- added adhoc patch to fix python bug (import datetime module error)
111
112* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-1
113- new upstream release
114
115* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
116- new upstream release
117
118* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.0-1
119- new upstream release
120- changed Group to Development/Libraries
121
122* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-2
123- rebuilt with python-2.5.2
124
125* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.2.0-1vl5
126- Initial build for Vine Linux
127
128* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 2.2.0-1
129- Update to 2.2.0
130
131* Wed Feb  6 2008 Matthias Clasen <mclasen@redhat.com> - 2.1.1-1
132- Update to 2.1.1
133
134* Tue Jan 22 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-2.fc9
135- Fix a typo.
136
137* Mon Jan 21 2008 Matthew Barnes <mbarnes@redhat.com> - 2.1.0-1.fc9
138- Update to 2.1.0
139
140* Fri Oct 26 2007 Matthew Barnes <mbarnes@redhat.com> - 2.0.0-2.fc9
141- Add subpackage pygtksourceview-doc (bug #342991).
142
143* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
144- Update to 2.0.0
145
146* Tue Sep 11 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.5-1
147- Update to 1.90.5
148
149* Tue Sep  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.4-1
150- Update to 1.90.4
151
152* Wed Aug  1 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.3-1
153- Update to 1.90.3
154
155* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.90.2-2
156- Rebuild against the gtksourceview2 package
157
158* Fri Jul 06 2007 Matthew Barnes <mbarnes@redhat.com> - 1.90.2-1.fc8
159- Update to 1.90.2
160- Bump gtksourceview requirement to 1.90.2.
161
162* Tue Jul 03 2007 Florian La Roche <laroche@redhat.com> 1.90.1-3
163- fix macro typo
164
165* Tue Jun 26 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-2
166- Incorporate package review feedback
167
168* Mon Jun 25 2007 Matthias Clasen <mclasen@redhat.com> 1.90.1-1
169- Initial package
Note: See TracBrowser for help on using the repository browser.