source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 8758

Revision 8758, 7.4 KB checked in by Takemikaduchi, 10 years ago (diff)

update or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pygobject
4Summary: Python bindings for GObject
5Summary(ja): GObject の Python バインディング
6Version: 2.28.6
7Release: 6%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.28/pygobject-%{version}.tar.xz
14Patch0: 00git_cairo_init.patch
15Patch1: 00git_enum_properties.patch
16Patch2: 00git_fix_qdata_warning.patch
17Patch3: 00git_gio_flag_type.patch
18Patch4: 00git_gio_test.patch
19Patch5: 00git_messagebox_type.patch
20Patch6: 00git_python3-maketrans.patch
21Patch7: 00git_python3_build.patch
22Patch8: 00git_test_case_hang.patch
23Patch9: 00git_textiter_crash.patch
24Patch10: 20_deprecated_spam.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: glib2-devel >= 2.26.0
28BuildRequires: python-devel >= 2.6
29BuildRequires: libffi-devel
30BuildRequires: libtool, automake
31BuildRequires: pycairo-devel >= 1.8.10
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: daisuke
36
37%description
38pygobject provides a convenient wrapper for the GObject library
39for use in Python programs.
40
41%package devel
42Summary: Development files for building add-on libraries
43Group: Development/Libraries
44Requires: pygobject = %{version}-%{release}
45#Requires: pygobject-doc = %{version}-%{release}
46Requires: glib2-devel
47Requires: libffi-devel
48Requires: pkgconfig
49
50%description devel
51This package contains files required to build wrappers for
52pygobject-based libraries such as pygtk2.
53
54%package doc
55Summary: Documentation files for pygobject
56Group: Documentation
57
58%description doc
59This package contains documentation files for pygobject.
60
61%prep
62%setup -q
63%patch0 -p1
64%patch1 -p1
65%patch2 -p1
66%patch3 -p1
67%patch4 -p1
68%patch5 -p1
69%patch6 -p1
70%patch7 -p1
71%patch8 -p1
72%patch9 -p1
73%patch10 -p1
74
75%build
76# --disable-docs doesn't work; it builds the docs anyway.
77%configure \
78    --enable-silent-rules \
79    --disable-static \
80    --enable-thread \
81    --disable-introspection \
82    --disable-docs
83export tagname=CC
84make LIBTOOL=/usr/bin/libtool
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export tagname=CC
89make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
90find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
91
92rm -f examples/Makefile*
93
94%clean
95rm -fr $RPM_BUILD_ROOT
96
97%files
98%defattr(644, root, root, 755)
99%doc AUTHORS NEWS README ChangeLog
100%doc examples
101
102%{_libdir}/libpyglib-2.0-python.so.*
103%dir %{python_sitearch}/gtk-2.0
104%{python_sitearch}/gtk-2.0/dsextras.*
105%{python_sitearch}/pygtk.*
106
107%defattr(755, root, root, 755)
108%{python_sitearch}/gtk-2.0/gio
109%{python_sitearch}/glib
110%{python_sitearch}/gobject
111
112%files devel
113%defattr(755, root, root, 755)
114%{_bindir}/pygobject-codegen-2.0
115%defattr(644, root, root, 755)
116%dir %{_datadir}/pygobject
117%dir %{_datadir}/pygobject/2.0
118%dir %{_includedir}/pygtk-2.0
119%{_datadir}/pygobject/2.0/codegen
120%{_datadir}/pygobject/2.0/defs
121%{_datadir}/pygobject/xsl
122%{_includedir}/pygtk-2.0/pyglib.h
123%{_includedir}/pygtk-2.0/pygobject.h
124%{_libdir}/libpyglib-2.0-python.so
125%{_libdir}/pkgconfig/pygobject-2.0.pc
126
127%files doc
128%defattr(644, root, root, 755)
129%{_datadir}/gtk-doc/html/pygobject
130
131%changelog
132* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-6
133- rebuild with libffi-3.0.13
134
135* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-5
136- rebuild with VineSeed environment
137
138* Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.28.6-4
139- added Patch0-10 from Debian sid
140
141* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-3
142- rebuild with python-2.7.2
143
144* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-2
145- remove BuildRequires: gobject-introspection-devel
146- change configure option --disable-introspection instead of --enable-introspection=yes
147
148* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
149- new upstream release
150
151* Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.4-1
152- update to 2.28.4
153
154* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
155- new upstream release
156- add BuildRequires: gobject-introspection-devel, pycairo-devel
157- change configure option --enable-introspection=yes instead of --disable-introspection
158
159* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21.5-1
160- new upstream release
161- added --disable-intropection option (it needs gobject-introspection >= 0.9)
162- moved xsl files to devel package
163- built with rpm-4.8.1
164
165* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
166- new upstream release
167
168* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
169- build for python-2.6
170
171* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
172- added Requires: libffi-devel to devel package <BTS:830>
173
174* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
175- new upstream release
176
177* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
178- new upstream release
179
180* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
181- new upstream release
182
183* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
184- new upstream release
185
186* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
187- rebuilt with python-2.5.2
188
189* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
190- new upstream release
191- spec in UTF-8
192
193* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
194- rebuilt with python-2.4.5 and glib2-2.16.1
195- used %%{?_dist_release} macro
196
197* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
198- new upstream release
199
200* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
201- new upstream release
202- dropped Patch1 (merged into upstream)
203
204* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
205- initial build for Vine Linux
206
207* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
208- Add patch for RH bug #237179 (memory leak).
209
210* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
211- rebuild against python 2.5
212
213* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
214- Update to 2.12.3
215
216* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
217- Add subpackage pygobject2-doc (bug #205231).
218
219* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
220- Use python_sitearch instead of python_sitelib.
221
222* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
223- Update to 2.12.2
224
225* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
226- Require glib2-devel for the -devel package.
227
228* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
229- Define a python_sitelib macro for files under site_packages.
230- Spec file cleanups.
231
232* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
233- Update to 2.12.1
234- Require pkgconfig for the -devel package
235
236* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
237- Update to 2.11.4
238- Use pre-built docs
239
240* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
241- Update to 2.11.3
242
243* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
244- BR libxslt
245
246* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
247- Update to 2.11.2
248
249* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
250- rebuild
251
252* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
253- Update to 2.11.0
254
255* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
256- rebuild
257- Add missing br libtool
258
259* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
260- Cleanup
261
262* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
263- Initial package
Note: See TracBrowser for help on using the repository browser.