source: projects/specs/trunk/p/pygobject/pygobject-vl.spec @ 5701

Revision 5701, 6.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pygobject
4Summary: Python bindings for GObject
5Summary(ja): GObject の Python バインディング
6Version: 2.28.6
7Release: 3%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.28/pygobject-%{version}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.26.0
17BuildRequires: python-devel >= 2.6
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20BuildRequires: pycairo-devel >= 1.8.10
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke
25
26%description
27pygobject provides a convenient wrapper for the GObject library
28for use in Python programs.
29
30%package devel
31Summary: Development files for building add-on libraries
32Group: Development/Libraries
33Requires: pygobject = %{version}-%{release}
34#Requires: pygobject-doc = %{version}-%{release}
35Requires: glib2-devel
36Requires: libffi-devel
37Requires: pkgconfig
38
39%description devel
40This package contains files required to build wrappers for
41pygobject-based libraries such as pygtk2.
42
43%package doc
44Summary: Documentation files for pygobject
45Group: Documentation
46
47%description doc
48This package contains documentation files for pygobject.
49
50%prep
51%setup -q
52
53%build
54# --disable-docs doesn't work; it builds the docs anyway.
55%configure \
56    --enable-silent-rules \
57    --disable-static \
58    --enable-thread \
59    --disable-introspection \
60    --disable-docs
61export tagname=CC
62make LIBTOOL=/usr/bin/libtool
63
64%install
65rm -rf $RPM_BUILD_ROOT
66export tagname=CC
67make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
68find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
69
70rm -f examples/Makefile*
71
72%clean
73rm -fr $RPM_BUILD_ROOT
74
75%files
76%defattr(644, root, root, 755)
77%doc AUTHORS NEWS README ChangeLog
78%doc examples
79
80%{_libdir}/libpyglib-2.0-python.so.*
81%dir %{python_sitearch}/gtk-2.0
82%{python_sitearch}/gtk-2.0/dsextras.*
83%{python_sitearch}/pygtk.*
84
85%defattr(755, root, root, 755)
86%{python_sitearch}/gtk-2.0/gio
87%{python_sitearch}/glib
88%{python_sitearch}/gobject
89
90%files devel
91%defattr(755, root, root, 755)
92%{_bindir}/pygobject-codegen-2.0
93%defattr(644, root, root, 755)
94%dir %{_datadir}/pygobject
95%dir %{_datadir}/pygobject/2.0
96%dir %{_includedir}/pygtk-2.0
97%{_datadir}/pygobject/2.0/codegen
98%{_datadir}/pygobject/2.0/defs
99%{_datadir}/pygobject/xsl
100%{_includedir}/pygtk-2.0/pyglib.h
101%{_includedir}/pygtk-2.0/pygobject.h
102%{_libdir}/libpyglib-2.0-python.so
103%{_libdir}/pkgconfig/pygobject-2.0.pc
104
105%files doc
106%defattr(644, root, root, 755)
107%{_datadir}/gtk-doc/html/pygobject
108
109%changelog
110* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-3
111- rebuild with python-2.7.2
112
113* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-2
114- remove BuildRequires: gobject-introspection-devel
115- change configure option --disable-introspection instead of --enable-introspection=yes
116
117* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
118- new upstream release
119
120* Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.4-1
121- update to 2.28.4
122
123* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
124- new upstream release
125- add BuildRequires: gobject-introspection-devel, pycairo-devel
126- change configure option --enable-introspection=yes instead of --disable-introspection
127
128* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.21.5-1
129- new upstream release
130- added --disable-intropection option (it needs gobject-introspection >= 0.9)
131- moved xsl files to devel package
132- built with rpm-4.8.1
133
134* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
135- new upstream release
136
137* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-3
138- build for python-2.6
139
140* Wed Dec  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-2
141- added Requires: libffi-devel to devel package <BTS:830>
142
143* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-1
144- new upstream release
145
146* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-1
147- new upstream release
148
149* Sat Jan 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
150- new upstream release
151
152* Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.4-1
153- new upstream release
154
155* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.2-2
156- rebuilt with python-2.5.2
157
158* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-1
159- new upstream release
160- spec in UTF-8
161
162* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
163- rebuilt with python-2.4.5 and glib2-2.16.1
164- used %%{?_dist_release} macro
165
166* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
167- new upstream release
168
169* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
170- new upstream release
171- dropped Patch1 (merged into upstream)
172
173* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
174- initial build for Vine Linux
175
176* Thu Apr 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-3.fc7
177- Add patch for RH bug #237179 (memory leak).
178
179* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.12.3-2
180- rebuild against python 2.5
181
182* Sat Nov 18 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.3-1.fc7
183- Update to 2.12.3
184
185* Thu Oct 26 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-3.fc7
186- Add subpackage pygobject2-doc (bug #205231).
187
188* Tue Oct 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-2.fc7
189- Use python_sitearch instead of python_sitelib.
190
191* Sun Oct 15 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.2-1.fc7
192- Update to 2.12.2
193
194* Sun Sep 24 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-3.fc6
195- Require glib2-devel for the -devel package.
196
197* Fri Sep 22 2006 Matthew Barnes <mbarnes@redhat.com> - 2.12.1-2.fc6
198- Define a python_sitelib macro for files under site_packages.
199- Spec file cleanups.
200
201* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.12.1-1.fc6
202- Update to 2.12.1
203- Require pkgconfig for the -devel package
204
205* Sun Aug 27 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.4-1.fc6
206- Update to 2.11.4
207- Use pre-built docs
208
209* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.3-1.fc6
210- Update to 2.11.3
211
212* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-2.fc6
213- BR libxslt
214
215* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.2-1.fc6
216- Update to 2.11.2
217
218* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 2.11.0-2
219- rebuild
220
221* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 2.11.0-1
222- Update to 2.11.0
223
224* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.10.1-3
225- rebuild
226- Add missing br libtool
227
228* Fri May 19 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-2
229- Cleanup
230
231* Fri May 12 2006 John (J5) Palmieri <johnp@redhat.com> - 2.10.1-1
232- Initial package
Note: See TracBrowser for help on using the repository browser.