source: projects/specs/trunk/p/pygame/pygame-vl.spec @ 6558

Revision 6558, 8.1 KB checked in by kudoh, 12 years ago (diff)

pygame-vl.spec

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pygame
4Version:        1.9.1
5Release:        1%{?_dist_release}
6Summary:        Python modules for writing games
7Summary(ja):     ゲームを書くための Python モジュール
8
9Group:          Development/Languages
10License:        LGPLv2+
11URL:            http://www.pygame.org
12
13Source0:        http://pygame.org/ftp/%{name}-%{version}release.tar.gz
14Patch0:         %{name}-1.9.1-config.patch
15# porttime is part of libportmidi.so, there's no libporttime in Fedora
16Patch1:         pygame-1.9.1-porttime.patch
17Patch2:         pygame-1.9.1-no-test-install.patch
18# patch backported from upstream repository, V4L has been remove in linux-2.6.38
19# http://svn.seul.org/viewcvs/viewvc.cgi?view=rev&root=PyGame&revision=3077
20Patch3:         pygame-remove-v4l.patch
21Patch4:         MMX.diff
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires:  python-devel numpy
26BuildRequires:  SDL_image-devel SDL_mixer-devel SDL_ttf-devel
27BuildRequires:  SDL-devel
28BuildRequires:  libpng-devel libjpeg-turbo-devel libX11-devel smpeg-devel
29#BuildRequires:  portmidi-devel
30Requires:       numpy
31
32%description
33Pygame is a set of Python modules designed for writing games. It is
34written on top of the excellent SDL library. This allows you to create
35fully featured games and multimedia programs in the python language.
36Pygame is highly portable and runs on nearly every platform and
37operating system.
38
39%package devel
40Summary:        Files needed for developing programs which use pygame
41Summary(ja):     pygame を使用するプログラム開発に必要なファイル
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44Requires:       SDL_ttf-devel SDL_mixer-devel
45Requires:       python-devel
46
47%description devel
48This package contains headers required to build applications that use
49pygame.
50
51
52%prep
53%setup -qn %{name}-%{version}release
54
55%patch0 -p1
56%patch1 -p1
57%patch2 -p1
58%patch3 -p1
59%patch4 -p1
60
61# rpmlint fixes
62find examples/ -type f -print0 | xargs -0 chmod -x
63find docs/ -type f -print0 | xargs -0 chmod -x
64find src/ -type f -name '*.h' -print0 | xargs -0 chmod -x
65chmod -x README.txt WHATSNEW
66
67iconv -f iso8859-1 -t utf-8 WHATSNEW > WHATSNEW.conv && mv -f WHATSNEW.conv WHATSNEW
68iconv -f iso8859-1 -t utf-8 README.txt > README.txt.conv && mv -f README.txt.conv README.txt
69
70
71# These files must be provided by pygame-nonfree(-devel) packages on a
72# repository that does not have restrictions on providing non-free software
73rm -f src/ffmovie.[ch]
74
75
76%build
77CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
78
79
80%install
81rm -rf $RPM_BUILD_ROOT
82%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
83
84# Fix permissions
85chmod 755 $RPM_BUILD_ROOT%{python_sitearch}/%{name}/*.so
86
87
88%check
89# base_test fails in mock, unable to find soundcard
90PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/base_test.py || :
91PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/image_test.py
92PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/rect_test.py
93 
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98
99%files
100%defattr(-,root,root,-)
101%doc docs/ README.txt WHATSNEW
102#%dir %{python_sitearch}/%{name}
103%{python_sitearch}/%{name}*
104
105%files devel
106%defattr(-,root,root,-)
107%doc examples/
108%dir %{_includedir}/python*/%{name}
109%{_includedir}/python*/%{name}/*.h
110
111
112%changelog
113* Fri Jul 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.1-1
114- initial build for VineSeed
115
116* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-8
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
118
119* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.9.1-7
120- Rebuild for new libpng
121
122* Thu Jun 23 2011 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-6
123- Removed V4L support because V4L has been deprecated from the Linux
124  kernel as of 2.6.38
125
126* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
128
129* Mon Aug 16 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-4
130- fix #607753 - Do not install tests
131
132* Thu Aug 12 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-3
133- fix #585526 - add MIDI support
134
135* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.9.1-2
136- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
137
138* Thu Oct 08 2009 Jon Ciesla <limb@jcomserv.net> - 1.9.1-1
139- New upstream release, BZ 526365.
140- Updated config_unix patch for 1.9.1.
141
142* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
144
145* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-6
146- Dropped f2py deps, unneeded now that numpy is fixed: BZ 496277.
147
148* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-5
149- Add dep for numpy-f2py to fix broken games, BZ 496218.
150
151* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-4
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
153
154* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.8.1-3
155- Rebuild for Python 2.6
156
157* Wed Sep 17 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-2
158- Bump release to trump F9 version.
159
160* Tue Aug 26 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-1
161- Update to new upstream version.
162- rpmlint fixes
163
164* Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-3
165- Rebase config patch for 1.8.0
166- Need to specify BR: SDL-devel
167
168* Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-2
169- Change from requiring python-numeric to numpy
170- rhbz#457074
171
172* Thu May 22 2008 Christopher Stone <chris.stone@gmail.com> 1.8.0-1
173- Upstream sync
174- Remove Obsolets/Provides (been around since FC-4)
175- Remove no longer needed 64bit patch
176- Remove %%{version} macro from Patch0 definition
177- Add png, jpeg, and X11 libraries to BuildRequires
178- Simplify %%files section
179- Fix up some rpmlint warnings
180
181* Thu Feb 21 2008 Christopher Stone <chris.stone@gmail.com> 1.7.1-16
182- Add egginfo file to %%files
183- Update %%license
184- Fix permissions on .so files
185
186* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.7.1-15
187- Autorebuild for GCC 4.3
188
189* Tue May 15 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-14
190- Add one more bit to 64-bit patch
191
192* Sat May 12 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-13
193- Apply 64-bit patch for python 2.5 (bz #239899)
194- Some minor spec file cleanups
195
196* Mon Apr 23 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-12
197- Revert back to version 1.7.1-9
198
199* Mon Dec 11 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-11
200- Remove all Obsolete/Provides
201- Remove Requires on all devel packages
202
203* Sun Dec 10 2006 Christopher Stone <chris.stone@gmail.som> 1.7.1-10
204- Remove macosx examples
205- Move header files into main package
206- Move examples into examples subpackage
207- python(abi) = 0:2.5
208
209* Wed Sep 06 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-9
210- No longer %%ghost pyo files. Bug #205396
211
212* Sat Sep 02 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-8
213- FC6 Rebuild
214
215* Wed Jun 28 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7.fc6.1
216- Rebuild bump
217
218* Wed May 03 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7
219- Fix Obsolete/Provides of python-pygame-doc
220
221* Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-6
222- Bump release for new build on devel
223
224* Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-5
225- Add Obsolete/Provides tags for python-pygame-docs
226- Add Obsolete/Provides tags for python-pygame-devel to devel package
227- Hopefully this fixes Bugzilla bug #189991
228
229* Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-4
230- Add Requires to -devel package
231- Remove ffmovie.h from -devel package since it requires smpeg-devel
232
233* Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-3
234- Obsolete linva python-pygame package
235- Added Provides for python-pygame
236- Fix equal sign in devel requires
237
238* Thu Apr 20 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-2
239- Added a patch to clean up some warnings on 64 bit compiles
240
241* Tue Apr 18 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-1
242- Initial RPM release
Note: See TracBrowser for help on using the repository browser.