source: projects/specs/trunk/p/pygame/pygame-vl.spec @ 8841

Revision 8841, 8.4 KB checked in by kudoh, 10 years ago (diff)

rebuilt with libpng-1.6.12

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pygame
4Version:        1.9.1
5Release:        3%{?_dist_release}
6Summary:        Python modules for writing games
7Summary(ja):     ゲームを書くための Python モジュール
8
9Group:          Development/Languages
10License:        LGPLv2+
11URL:            http://www.pygame.org
12
13Source0:        http://pygame.org/ftp/%{name}-%{version}release.tar.gz
14Patch0:         %{name}-1.9.1-config.patch
15# porttime is part of libportmidi.so, there's no libporttime in Fedora
16Patch1:         pygame-1.9.1-porttime.patch
17Patch2:         pygame-1.9.1-no-test-install.patch
18# patch backported from upstream repository, V4L has been remove in linux-2.6.38
19# http://svn.seul.org/viewcvs/viewvc.cgi?view=rev&root=PyGame&revision=3077
20Patch3:         pygame-remove-v4l.patch
21Patch4:         MMX.diff
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires:  python-devel numpy
26BuildRequires:  SDL_image-devel SDL_mixer-devel SDL_ttf-devel
27BuildRequires:  SDL-devel
28BuildRequires:  libpng-devel libjpeg-turbo-devel libX11-devel smpeg-devel
29#BuildRequires:  portmidi-devel
30Requires:       numpy
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36Pygame is a set of Python modules designed for writing games. It is
37written on top of the excellent SDL library. This allows you to create
38fully featured games and multimedia programs in the python language.
39Pygame is highly portable and runs on nearly every platform and
40operating system.
41
42%package devel
43Summary:        Files needed for developing programs which use pygame
44Summary(ja):     pygame を使用するプログラム開発に必要なファイル
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       SDL_ttf-devel SDL_mixer-devel
48Requires:       python-devel
49
50%description devel
51This package contains headers required to build applications that use
52pygame.
53
54
55%prep
56%setup -qn %{name}-%{version}release
57
58%patch0 -p1
59%patch1 -p1
60%patch2 -p1
61%patch3 -p1
62%patch4 -p1
63
64# rpmlint fixes
65find examples/ -type f -print0 | xargs -0 chmod -x
66find docs/ -type f -print0 | xargs -0 chmod -x
67find src/ -type f -name '*.h' -print0 | xargs -0 chmod -x
68chmod -x README.txt WHATSNEW
69
70iconv -f iso8859-1 -t utf-8 WHATSNEW > WHATSNEW.conv && mv -f WHATSNEW.conv WHATSNEW
71iconv -f iso8859-1 -t utf-8 README.txt > README.txt.conv && mv -f README.txt.conv README.txt
72
73
74# These files must be provided by pygame-nonfree(-devel) packages on a
75# repository that does not have restrictions on providing non-free software
76rm -f src/ffmovie.[ch]
77
78
79%build
80CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
86
87# Fix permissions
88chmod 755 $RPM_BUILD_ROOT%{python_sitearch}/%{name}/*.so
89
90
91%check
92# base_test fails in mock, unable to find soundcard
93PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/base_test.py || :
94PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/image_test.py
95PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/rect_test.py
96 
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101
102%files
103%defattr(-,root,root,-)
104%doc docs/ README.txt WHATSNEW
105#%dir %{python_sitearch}/%{name}
106%{python_sitearch}/%{name}*
107
108%files devel
109%defattr(-,root,root,-)
110%doc examples/
111%dir %{_includedir}/python*/%{name}
112%{_includedir}/python*/%{name}/*.h
113
114
115%changelog
116* Fri Jul 18 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.1-3
117- rebuilt with libpng-1.6.12
118
119* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.9.1-2
120- rebuild with VineSeed environment
121
122* Fri Jul 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.1-1
123- initial build for VineSeed
124
125* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-8
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
127
128* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.9.1-7
129- Rebuild for new libpng
130
131* Thu Jun 23 2011 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-6
132- Removed V4L support because V4L has been deprecated from the Linux
133  kernel as of 2.6.38
134
135* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
137
138* Mon Aug 16 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-4
139- fix #607753 - Do not install tests
140
141* Thu Aug 12 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-3
142- fix #585526 - add MIDI support
143
144* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.9.1-2
145- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
146
147* Thu Oct 08 2009 Jon Ciesla <limb@jcomserv.net> - 1.9.1-1
148- New upstream release, BZ 526365.
149- Updated config_unix patch for 1.9.1.
150
151* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
153
154* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-6
155- Dropped f2py deps, unneeded now that numpy is fixed: BZ 496277.
156
157* Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-5
158- Add dep for numpy-f2py to fix broken games, BZ 496218.
159
160* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-4
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
162
163* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.8.1-3
164- Rebuild for Python 2.6
165
166* Wed Sep 17 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-2
167- Bump release to trump F9 version.
168
169* Tue Aug 26 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-1
170- Update to new upstream version.
171- rpmlint fixes
172
173* Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-3
174- Rebase config patch for 1.8.0
175- Need to specify BR: SDL-devel
176
177* Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-2
178- Change from requiring python-numeric to numpy
179- rhbz#457074
180
181* Thu May 22 2008 Christopher Stone <chris.stone@gmail.com> 1.8.0-1
182- Upstream sync
183- Remove Obsolets/Provides (been around since FC-4)
184- Remove no longer needed 64bit patch
185- Remove %%{version} macro from Patch0 definition
186- Add png, jpeg, and X11 libraries to BuildRequires
187- Simplify %%files section
188- Fix up some rpmlint warnings
189
190* Thu Feb 21 2008 Christopher Stone <chris.stone@gmail.com> 1.7.1-16
191- Add egginfo file to %%files
192- Update %%license
193- Fix permissions on .so files
194
195* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.7.1-15
196- Autorebuild for GCC 4.3
197
198* Tue May 15 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-14
199- Add one more bit to 64-bit patch
200
201* Sat May 12 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-13
202- Apply 64-bit patch for python 2.5 (bz #239899)
203- Some minor spec file cleanups
204
205* Mon Apr 23 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-12
206- Revert back to version 1.7.1-9
207
208* Mon Dec 11 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-11
209- Remove all Obsolete/Provides
210- Remove Requires on all devel packages
211
212* Sun Dec 10 2006 Christopher Stone <chris.stone@gmail.som> 1.7.1-10
213- Remove macosx examples
214- Move header files into main package
215- Move examples into examples subpackage
216- python(abi) = 0:2.5
217
218* Wed Sep 06 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-9
219- No longer %%ghost pyo files. Bug #205396
220
221* Sat Sep 02 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-8
222- FC6 Rebuild
223
224* Wed Jun 28 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7.fc6.1
225- Rebuild bump
226
227* Wed May 03 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7
228- Fix Obsolete/Provides of python-pygame-doc
229
230* Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-6
231- Bump release for new build on devel
232
233* Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-5
234- Add Obsolete/Provides tags for python-pygame-docs
235- Add Obsolete/Provides tags for python-pygame-devel to devel package
236- Hopefully this fixes Bugzilla bug #189991
237
238* Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-4
239- Add Requires to -devel package
240- Remove ffmovie.h from -devel package since it requires smpeg-devel
241
242* Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-3
243- Obsolete linva python-pygame package
244- Added Provides for python-pygame
245- Fix equal sign in devel requires
246
247* Thu Apr 20 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-2
248- Added a patch to clean up some warnings on 64 bit compiles
249
250* Tue Apr 18 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-1
251- Initial RPM release
Note: See TracBrowser for help on using the repository browser.