source: projects/specs/trunk/p/pyexiv2/pyexiv2-vl.spec @ 8034

Revision 8034, 5.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild with libboost-1.54.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name: pyexiv2
4Version: 0.3.2
5Release: 3%{?_dist_release}
6Summary: Python binding to exiv2
7Summary(ja): exiv2 の Python バインディング
8
9Group: Development/Languages
10License: GPLv2+
11URL: http://tilloy.net/dev/pyexiv2/
12Source0: http://launchpad.net/pyexiv2/0.3.x/%{version}/+download/pyexiv2-%{version}.tar.bz2
13Patch0: http://tilloy.net/dev/pyexiv2-0.3.2-exiv2-0.18.2.patch
14
15BuildRequires:  exiv2-devel
16BuildRequires:  libboost-devel
17BuildRequires:  libboost-python
18BuildRequires:  python-devel
19BuildRequires:  pytz
20BuildRequires:  scons
21
22%description
23pyexiv2 is a python binding to exiv2, the C++ library for manipulation
24of EXIF and IPTC image metadata. It is a python module that allows your
25python scripts to read and write metadata (EXIF, IPTC, thumbnail)
26embedded in image files (JPEG, TIFF, ...).
27
28%prep
29%setup -q
30%patch0 -p0 -b .exiv2-0182
31
32%build
33export CXXFLAGS="%{optflags}"
34export LDFLAGS="%{optflags}"
35scons
36
37%install
38#%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
39export CXXFLAGS="%{optflags}"
40export LDFLAGS="%{optflags}"
41scons DESTDIR=$RPM_BUILD_ROOT install
42
43%check
44pushd test
45PYTHONPATH=$RPM_BUILD_ROOT%{python_sitearch}  ./TestsRunner.py
46popd
47
48%files
49%defattr(-,root,root,-)
50%doc README COPYING NEWS doc/
51%{python_sitearch}/*
52
53
54%changelog
55* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.3.2-3
56- rebuild with libboost-1.54.0
57
58* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.3.2-2
59- rebuild with exiv2-0.23
60
61* Tue Jun 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.2-1
62- initial build for VineSeed
63
64* Mon Jan 9 2012 Matěj Cepl <mcepl@redhat.com> 0.3.2-2
65- Applying upstream patch for 0.18.2 compatbility (#753322)
66
67* Fri Dec 23 2011 Peter Robinson <pbrobinson@fedoraproject.org> - 0.3.2-1
68- Update to 0.3.2 and rebuild for new boost, drop upstreamed patch
69
70* Wed Dec 14 2011 Matěj Cepl <mcepl@redhat.com> 0.3.1-2
71- Make the package building with exiv 0.18.2 on EL-6 (#753322)
72
73* Fri Nov 11 2011 'Matěj Cepl <mcepl@redhat.com>' - 0.3.1-1
74- Add pytz to the BuildRequires (so that more tests are run).
75
76* Fri Oct 14 2011 Rex Dieter <rdieter@fedoraproject.org> - 0.3.0-6
77- rebuild (exiv2)
78
79* Sat Jul 30 2011 Matěj Cepl <mcepl@redhat.com> - 0.3.0-5
80- Rebuilt against new libraries.
81
82* Wed Apr 13 2011 Matěj Cepl <mcepl@redhat.com> - 0.3.0-4
83- Rebuilt for new boost.
84
85* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
87
88* Sun Feb 06 2011 Thomas Spura <tomspur@fedoraproject.org> - 0.3.0-2
89- rebuild for new boost
90
91* Sun Jan 02 2011 Rex Dieter <rdieter@fedoraproject.org> -  0.3.0-1
92- pyexiv2-0.3.0
93
94* Mon Oct 25 2010 Matěj Cepl <mcepl@redhat.com> - 0.2.2-2
95- Fixing unit tests.
96
97* Wed Aug 25 2010 Matěj Cepl <mcepl@redhat.com> - 0.2.2-1
98- New upstream package, switch to 0.2.* version
99
100* Sat Aug  7 2010 Peter Lemenkov <lemenkov@gmail.com> - 0.1.3-11
101- Rebuilt for new boost
102- Small cosmetic changes - whitespace cleanups
103
104* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.1.3-10
105- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
106
107* Mon May 31 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.3-9
108- rebuild (exiv2)
109
110* Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.3-8
111- rebuild (boost)
112
113* Fri Jan 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.3-7
114- %%check: use unittests
115
116* Fri Jan 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.1.3-6
117- pyexiv2 FTBFS against exiv2-0.19 (#552281)
118
119* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-5
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
121
122* Mon Jun 08 2009 Matěj Cepl <mcepl@redhat.com> - 0.1.3-4
123-rebuild for new boot library
124
125* Thu Apr 23 2009 Matěj Cepl <mcepl@redhat.com> - 0.1.3-3
126- executable library doesn't make sense
127
128* Sat Apr 18 2009 Matěj Cepl <mcepl@redhat.com> - 0.1.3-2
129- Rebuild after exiv2 was fixed.
130
131* Thu Apr 16 2009 Matěj Cepl <mcepl@redhat.com> - 0.1.3-1
132- New upstream release (closes bug 494419)
133
134* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-9.1.20090109bzr107
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Fri Jan 09 2009 Matej Cepl <mcepl@redhat.com> 0.1.2-8.1.20090109bzr107
138- New snapshot from upstream pyexiv2-0.2 branch in order to be compatible
139  with the current package of exiv2.
140
141* Thu Dec 18 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.1.2-6
142- respin (eviv2)
143
144* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.2-5
145- Rebuild for Python 2.6
146
147* Thu Sep 11 2008 Jesse Keating <jkeating@redhat.com> - 0.1.2-4
148- Rebuild for deps
149
150* Fri Jul 18 2008 Matěj Cepl <mcepl@redhat.com> 0.1.2-3
151- Fix building system.
152- Approved for Fedora
153
154* Fri Jul 18 2008 Matěj Cepl <mcepl@redhat.com> 0.1.2-2
155- Dan's patch to fix compilation flags.
156
157* Thu Jul 17 2008 Matěj Cepl <mcepl@redhat.com> 0.1.2-1
158- initial build
Note: See TracBrowser for help on using the repository browser.