source: projects/specs/trunk/p/pyclutter/pyclutter-vl.spec @ 5701

Revision 5701, 2.2 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pkg_version 1.3.2
4%define pkg_release 1%{?_dist_release}
5
6Summary:        Python bindings for Clutter
7Summary(ja):    Clutter 用 Python バインディング
8Name:           pyclutter
9Version:        %{pkg_version}
10Release:        %{pkg_release}
11Source0:        http://www.clutter-project.org/sources/%{name}/1.3/%{name}-%{version}.tar.bz2
12License:        LGPLv2+
13Group:          Development/Languages
14URL:            http://www.clutter-project.org/
15
16BuildRequires:  glib2-devel     >= 2.16.0
17BuildRequires:  gtk2-devel      >= 2.10.0
18BuildRequires:  clutter-devel   >= 1.0.0
19BuildRequires:  pycairo-devel   >= 1.0.2
20BuildRequires:  pygobject-devel >= 2.12.1
21BuildRequires:  python-devel    >= 2.5.0
22BuildRequires:  pygtk2-devel    >= 2.8.0
23BuildRequires:  pygobject-doc
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30
31%description
32This archive contains the Python modules that allow you to use the
33Clutter toolkit in Python programs.
34
35
36%package devel
37Summary:        PyClutter development environment
38Summary(ja):    PyClutter の開発環境
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41Requires:       pygobject-devel
42Requires:       python-devel
43Requires:       clutter-devel
44
45%description devel
46Header files and libraries for building a extension library for the pyclutter.
47
48
49%prep
50%setup -q
51
52
53%build
54%configure --enable-static=no
55%{__make} %{?_smp_mflags}
56
57
58%install
59%{__rm} -rf ${RPM_BUILD_ROOT}
60%{__make} install DESTDIR=${RPM_BUILD_ROOT}
61
62%{__rm} -rf ${RPM_BUILD_ROOT}%{python_sitearch}/clutter/*.la
63
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68
69%files
70%defattr(-,root,root)
71%doc AUTHORS ChangeLog COPYING NEWS README
72%{python_sitearch}/clutter
73%{_datadir}/pyclutter/1.0/defs
74
75%files devel
76%defattr(-,root,root)
77%{_includedir}/pyclutter-1.0
78%{_libdir}/pkgconfig/pyclutter-1.0.pc
79
80
81%changelog
82* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
83- update to 1.3.2
84
85* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
86- rebuild with rpm-4.8.1 for pkg-config file
87
88* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
89- initial build for Vine Linux
90
Note: See TracBrowser for help on using the repository browser.