source: projects/specs/trunk/p/pybluez/pybluez-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           pybluez
4Version:        0.15
5Release:        3%{?_dist_release}
6Summary:        Python API for the BlueZ bluetooth stack
7Summary(ja):    BlueZ bluetooth スタックの Python API
8
9Group:          Development/Languages
10License:        GPLv2
11URL:            http://code.google.com/p/pybluez/
12Source0:        http://pybluez.googlecode.com/files/PyBluez-0.15.tar.gz
13
14#----------------------------------------------------------------------------
15           
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18#----------------------------------------------------------------------------       
19BuildRequires:      python-devel, bluez-libs-devel
20                   
21#----------------------------------------------------------------------------       
22%description
23PyBluez is an effort to create python wrappers around system Bluetooth
24resources to allow Python developers to easily and quickly create Bluetooth
25applications.
26
27%description -l ja
28PyBluez は Python 開発者が容易かつ迅速にBluetoothのアプリケーションを作成
29できるようにシステム回りの Bluetooth リソースの Pythonラッパーを作成します。
30
31#----------------------------------------------------------------------------       
32%prep
33%setup -q -n PyBluez-%{version}
34
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
38
39
40#----------------------------------------------------------------------------       
41%install
42rm -rf $RPM_BUILD_ROOT
43# This file shouldn't be executable - it's going into %doc
44chmod a-x examples/bluezchat/bluezchat.py
45%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
46
47 
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52#----------------------------------------------------------------------------       
53%files
54%defattr(-,root,root,-)
55%doc README CHANGELOG COPYING examples
56%{python_sitearch}/*
57
58#----------------------------------------------------------------------------
59# Maintainers: babasaki@mindgear.org
60#
61#----------------------------------------------------------------------------
62%changelog
63* Fri Oct 24  2008 Seiichirou Babasaki 0.15-2
64- Import bluez-gnome - Packager: Babasaki
65- added "# Maintainers: " comments.
66- changed UTF-8 encode at pybluez.vs.spec
67- updated specfile
68
69#----------------------------------------------------------------------------
70* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.15-2
71- Rebuild
72
73* Wed Jun 4 2008 Will Woods <wwoods@redhat.com> - 0.15-1
74- New upstream version
75
76* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.1-4
77- Autorebuild for GCC 4.3
78
79* Fri Dec 29 2006 - Will Woods <wwoods@redhat.com> - 0.9.1-3
80- Clean up spec file some more after further comments in bug #218678
81
82* Fri Dec 15 2006 - Will Woods <wwoods@redhat.com> - 0.9.1-2
83- Clean up spec file according to comments in bug #218678
84
85* Wed Dec 6 2006 - Will Woods <wwoods@redhat.com> - 0.9.1-1
86- Initial packaging attempt.
Note: See TracBrowser for help on using the repository browser.