source: projects/specs/trunk/p/pyatspi/pyatspi-vl.spec @ 9803

Revision 9803, 7.1 KB checked in by Takemikaduchi, 8 years ago (diff)

chromium, pciutils, mesa: new upstream release
others: fix spec file

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3
4%global debug_package %{nil}
5
6Name:           pyatspi
7Version:        2.18.0
8Release:        2%{?_dist_release}
9Summary:        Python bindings for at-spi
10
11Group:          Development/Languages
12License:        LGPLv2 and GPLv2
13URL:            http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
14#VCS: git:git://git.gnome.org/pyatspi
15Source0:        http://download.gnome.org/sources/pyatspi/2.18/%{name}-%{version}.tar.xz
16
17BuildRequires:  python
18BuildRequires:  pygobject3-devel >= 2.90.1
19BuildRequires:  libX11-devel
20BuildRequires:  libSM-devel
21
22Requires:       at-spi2-core
23Requires:       pygobject3
24
25BuildArch:      noarch
26
27Vendor:         Project Vine
28Distribution:   Vine Linux
29Packager:       Takemikaduchi
30
31%description
32at-spi allows assistive technologies to access GTK-based
33applications. Essentially it exposes the internals of applications for
34automation, so tools such as screen readers, magnifiers, or even
35scripting interfaces can query and interact with GUI controls.
36
37This version of at-spi is a major break from previous versions.
38It has been completely rewritten to use D-Bus rather than
39ORBIT / CORBA for its transport protocol.
40
41This package includes a python client library for at-spi.
42
43
44%package -n python3-pyatspi
45Summary:        Python3 bindings for at-spi
46Group:          Development/Languages
47BuildRequires:  python3-pygobject
48Requires:       at-spi2-core
49Requires:       python3-pygobject
50BuildArch:      noarch
51Obsoletes:      python3-pyatspi < 2.17.0
52
53%description -n python3-pyatspi
54at-spi allows assistive technologies to access GTK-based
55applications. Essentially it exposes the internals of applications for
56automation, so tools such as screen readers, magnifiers, or even
57scripting interfaces can query and interact with GUI controls.
58
59This version of at-spi is a major break from previous versions.
60It has been completely rewritten to use D-Bus rather than
61ORBIT / CORBA for its transport protocol.
62
63This package includes a python3 client library for at-spi.
64
65
66%prep
67%setup -q
68
69# python3
70rm -rf ../python3
71cp -a . ../python3
72
73%build
74%configure \
75        --with-python=python2
76make
77
78#  python3
79pushd ../python3
80%configure \
81        --with-python=python3
82make
83
84%install
85make install DESTDIR=$RPM_BUILD_ROOT
86
87# python3
88pushd ../python3
89make install DESTDIR=$RPM_BUILD_ROOT
90
91
92%files
93%defattr(644, root, root, 755)
94%doc COPYING COPYING.GPL AUTHORS README
95%{python_sitelib}/pyatspi
96
97%files -n python3-pyatspi
98%defattr(644, root, root, 755)
99%doc COPYING COPYING.GPL AUTHORS README
100%{python3_sitelib}/pyatspi
101
102
103%changelog
104* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
105- fix spec file
106
107* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-1
108- new upstream release
109- create python3-pyatspi subpackage
110
111* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-1
112- new upstream release
113
114* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.0-1
115- new upstream release
116
117* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
118- new upstream release
119
120* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-2
121- rebuild with VineSeed environment
122
123* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
124- new upstream release
125
126* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
127- new upstream release
128
129* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
130- new upstream release
131
132* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.0-1
133- new upstream release
134
135* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-2
136- rebuild with python-2.7.2
137
138* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-1
139- new upstream release
140
141* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
142- new upstream release
143- add BuildRequires: libX11-devel, libSM-devel
144
145* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.91-1
146- initial build for Vine Linux
147
148
149* Wed Aug 31 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.90-1
150- Update to 2.1.90
151
152* Wed Aug 17 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.5-1
153- Update to 2.1.5
154
155* Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
156- Update to 2.1.4
157
158* Thu Jun 16 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.2-1
159- Update to 2.1.2
160
161* Wed May 11 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.1-1
162- Update to 2.1.1
163
164* Tue Apr 26 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.1-1
165- Update to 2.0.1
166
167* Mon Apr  4 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
168- Update to 2.0.0
169
170* Tue Mar 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.92-1
171- Update to 1.91.92
172
173* Mon Mar  7 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-1
174- Update to 1.91.91
175
176* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.90-1
177- Update to 1.91.90
178
179* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.91.6-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
181
182* Wed Feb  2 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6-1
183- Update to 1.91.6
184
185* Tue Jan 11 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.5-1
186- Update to 1.91.5
187
188* Thu Dec  2 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.3-1
189- Update to 1.91.3
190
191* Tue Oct  5 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.0-1
192- Update to 1.91.0
193
194* Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
195- Update to 0.4.0
196
197* Mon Sep 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-2
198- Require python-xlib and and gnome-python2-gconf (#635484)
199
200* Tue Aug 31 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
201- Update to 0.3.91
202
203* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
204- Update to 0.3.90
205
206* Mon Aug  2 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
207- Update to 0.3.6
208
209* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.4-2
210- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
211
212* Tue Jun 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
213- Update to 0.3.4
214
215* Tue Jun  8 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
216- Update to 0.3.3
217
218* Fri May 28 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
219- Update to 0.3.2
220
221* Sat May 15 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.1.1-1
222- Update to 0.3.1.1
223
224* Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.8-1
225- Update to 0.1.8
226
227* Sat Feb 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
228- Update to 0.1.7
229
230* Wed Feb 10 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.1.6-1
231- Update to 0.1.6
232
233* Wed Feb  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.5-2
234- Relocate
235
236* Sat Jan 16 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.5-1
237- Update to 0.1.5
238
239* Thu Jan  7 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.4-3
240- Incorporate review feedback
241
242* Thu Jan  7 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.4-2
243- Fix License field
244- Change CORBA/DBus switching method
245
246* Tue Dec 22 2009 Matthias Clasen <mclasen@redhat.com> - 0.1.4-1
247- Update to 0.1.4
248
249* Sat Dec  5 2009 Matthias Clasen <mclasen@redhat.com> - 0.1.3-1
250- Initial packaging
Note: See TracBrowser for help on using the repository browser.