source: projects/specs/trunk/p/pyatspi/pyatspi-vl.spec @ 10716

Revision 10716, 7.2 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

RevLine 
[4812]1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
[9791]2%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
[4812]3
4%global debug_package %{nil}
5
6Name:           pyatspi
[10716]7Version:        2.20.2
8Release:        1%{?_dist_release}
[4812]9Summary:        Python bindings for at-spi
10
11Group:          Development/Languages
12License:        LGPLv2 and GPLv2
13URL:            http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus
14#VCS: git:git://git.gnome.org/pyatspi
[10716]15Source0:        http://download.gnome.org/sources/pyatspi/2.20/%{name}-%{version}.tar.xz
[4812]16
17BuildRequires:  python
18BuildRequires:  pygobject3-devel >= 2.90.1
[4850]19BuildRequires:  libX11-devel
20BuildRequires:  libSM-devel
[4812]21
22Requires:       at-spi2-core
[7938]23Requires:       pygobject3
[4812]24
25BuildArch:      noarch
26
[9791]27Vendor:         Project Vine
28Distribution:   Vine Linux
29Packager:       Takemikaduchi
[4850]30
[4812]31%description
32at-spi allows assistive technologies to access GTK-based
33applications. Essentially it exposes the internals of applications for
34automation, so tools such as screen readers, magnifiers, or even
35scripting interfaces can query and interact with GUI controls.
36
37This version of at-spi is a major break from previous versions.
38It has been completely rewritten to use D-Bus rather than
39ORBIT / CORBA for its transport protocol.
40
41This package includes a python client library for at-spi.
42
43
[9791]44%package -n python3-pyatspi
45Summary:        Python3 bindings for at-spi
46Group:          Development/Languages
47BuildRequires:  python3-pygobject
48Requires:       at-spi2-core
49Requires:       python3-pygobject
50BuildArch:      noarch
51Obsoletes:      python3-pyatspi < 2.17.0
52
53%description -n python3-pyatspi
54at-spi allows assistive technologies to access GTK-based
55applications. Essentially it exposes the internals of applications for
56automation, so tools such as screen readers, magnifiers, or even
57scripting interfaces can query and interact with GUI controls.
58
59This version of at-spi is a major break from previous versions.
60It has been completely rewritten to use D-Bus rather than
61ORBIT / CORBA for its transport protocol.
62
63This package includes a python3 client library for at-spi.
64
65
[4812]66%prep
67%setup -q
68
[9791]69# python3
70rm -rf ../python3
71cp -a . ../python3
72
[4812]73%build
[9791]74%configure \
75        --with-python=python2
[4812]76make
77
[9791]78#  python3
79pushd ../python3
80%configure \
81        --with-python=python3
82make
[4812]83
84%install
85make install DESTDIR=$RPM_BUILD_ROOT
86
[9791]87# python3
88pushd ../python3
89make install DESTDIR=$RPM_BUILD_ROOT
[4812]90
[9791]91
[4812]92%files
[9791]93%defattr(644, root, root, 755)
[4812]94%doc COPYING COPYING.GPL AUTHORS README
95%{python_sitelib}/pyatspi
96
[9791]97%files -n python3-pyatspi
98%defattr(644, root, root, 755)
99%doc COPYING COPYING.GPL AUTHORS README
100%{python3_sitelib}/pyatspi
[4812]101
[9791]102
[4812]103%changelog
[10716]104* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.2-1
105- new upstream release
[10405]106
[9803]107* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
108- fix spec file
109
[9791]110* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-1
111- new upstream release
112- create python3-pyatspi subpackage
113
[9475]114* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-1
115- new upstream release
116
[9073]117* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.0-1
118- new upstream release
119
[8353]120* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.0-1
121- new upstream release
122
[8154]123* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-2
124- rebuild with VineSeed environment
125
[7938]126* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.0-1
127- new upstream release
128
[7633]129* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
130- new upstream release
131
[6890]132* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
133- new upstream release
134
[6011]135* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.0-1
136- new upstream release
137
[5701]138* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-2
139- rebuild with python-2.7.2
140
[5038]141* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-1
142- new upstream release
143
[4850]144* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
145- new upstream release
146- add BuildRequires: libX11-devel, libSM-devel
147
[4812]148* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.91-1
149- initial build for Vine Linux
150
151
152* Wed Aug 31 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.90-1
153- Update to 2.1.90
154
155* Wed Aug 17 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.5-1
156- Update to 2.1.5
157
158* Mon Jul 25 2011 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
159- Update to 2.1.4
160
161* Thu Jun 16 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.2-1
162- Update to 2.1.2
163
164* Wed May 11 2011 Tomas Bzatek <tbzatek@redhat.com> - 2.1.1-1
165- Update to 2.1.1
166
167* Tue Apr 26 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.1-1
168- Update to 2.0.1
169
170* Mon Apr  4 2011 Matthias Clasen <mclasen@redhat.com> - 2.0.0-1
171- Update to 2.0.0
172
173* Tue Mar 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.92-1
174- Update to 1.91.92
175
176* Mon Mar  7 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.91-1
177- Update to 1.91.91
178
179* Tue Feb 22 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.90-1
180- Update to 1.91.90
181
182* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.91.6-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
184
185* Wed Feb  2 2011 Christopher Aillon <caillon@redhat.com> - 1.91.6-1
186- Update to 1.91.6
187
188* Tue Jan 11 2011 Matthias Clasen <mclasen@redhat.com> - 1.91.5-1
189- Update to 1.91.5
190
191* Thu Dec  2 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.3-1
192- Update to 1.91.3
193
194* Tue Oct  5 2010 Matthias Clasen <mclasen@redhat.com> - 1.91.0-1
195- Update to 1.91.0
196
197* Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
198- Update to 0.4.0
199
200* Mon Sep 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-2
201- Require python-xlib and and gnome-python2-gconf (#635484)
202
203* Tue Aug 31 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
204- Update to 0.3.91
205
206* Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
207- Update to 0.3.90
208
209* Mon Aug  2 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
210- Update to 0.3.6
211
212* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.4-2
213- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
214
215* Tue Jun 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
216- Update to 0.3.4
217
218* Tue Jun  8 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
219- Update to 0.3.3
220
221* Fri May 28 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
222- Update to 0.3.2
223
224* Sat May 15 2010 Matthias Clasen <mclasen@redhat.com> - 0.3.1.1-1
225- Update to 0.3.1.1
226
227* Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.8-1
228- Update to 0.1.8
229
230* Sat Feb 20 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
231- Update to 0.1.7
232
233* Wed Feb 10 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.1.6-1
234- Update to 0.1.6
235
236* Wed Feb  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.5-2
237- Relocate
238
[7633]239* Sat Jan 16 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.5-1
[4812]240- Update to 0.1.5
241
242* Thu Jan  7 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.4-3
243- Incorporate review feedback
244
245* Thu Jan  7 2010 Matthias Clasen <mclasen@redhat.com> - 0.1.4-2
246- Fix License field
247- Change CORBA/DBus switching method
248
249* Tue Dec 22 2009 Matthias Clasen <mclasen@redhat.com> - 0.1.4-1
250- Update to 0.1.4
251
252* Sat Dec  5 2009 Matthias Clasen <mclasen@redhat.com> - 0.1.3-1
253- Initial packaging
Note: See TracBrowser for help on using the repository browser.