source: projects/specs/trunk/p/pwlib/pwlib-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Portable Windows Libary
2Name: pwlib
3Version: 1.10.10
4Release: 2%{?_dist_release}
5URL: http://openh323.sourceforge.net/
6Source0: http://www.ekiga.org/admin/downloads/latest/sources/sources/pwlib-%{version}.tar.gz
7License: MPL
8Group: System Environment/Libraries
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10
11BuildRequires: expat, openssl-devel, pkgconfig
12BuildRequires: openldap-devel, alsa-lib-devel
13BuildRequires: libdv-devel, libraw1394-devel, libavc1394-devel
14BuildRequires: libdc1394-devel
15Requires: libdv, libraw1394, libavc1394
16
17%description
18PWLib is a moderately large class library that has its genesis many
19years ago as a method to produce applications to run on both Microsoft
20Windows and Unix X-Window systems. It also was to have a Macintosh
21port as well but this never eventuated. This version does not contain
22any UI code.
23
24It is supplied mainly to support the open H323 project, but that shouldn't stop
25you from using it in whatever project you have in mind if you so desire.
26
27You should install some add-on plugin packages to use sound/video devices.
28There are following plugins.
29- pwlib-alsa : ALSA sound plugin
30- pwlib-v4l  : V4L/V4L2 video plugin
31- pwlib-avc  : libavc1394 video plugin
32- pwlib-dc   : libdc1394 video plugin
33
34#'
35%package devel
36Summary: Development package for pwlib
37Group: Development/Libraries
38Requires: pwlib = %{version}-%{release}
39Requires: openssl-devel
40
41%description devel
42The pwlib-devel package includes the libraries and header files for pwlib.
43
44%package alsa
45Summary: ALSA sound plugin for pwlib
46Group: System Environment/Libraries
47Requires: pwlib = %{version}-%{release}
48Requires: alsa-lib >= 1.0.2
49Obsoletes: %{name}-oss < 1.10.1
50
51%description alsa
52ALSA sound plugins for pwlib.
53
54%package v4l
55Summary: V4L video plugin for pwlib
56Group: System Environment/Libraries
57Requires: %{name} = %{version}-%{release}
58
59%description v4l
60V4L video plugins for pwlib.
61
62%package avc
63Summary: libavc1394 video plugin for pwlib
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires: libraw1394, libdv, libavc1394
67
68%description avc
69libavc1394 video plugins for pwlib.
70
71%package dc
72Summary: libdc1394 video plugin for pwlib
73Group: System Environment/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: libraw1394, libdv, libdc1394
76
77%description dc
78libdc1394 video plugins for pwlib.
79
80%prep
81%setup -q
82
83%build
84autoconf
85%configure --prefix=%{_prefix} --enable-opal --enable-openh323 \
86    --enable-plugins --disable-oss --enable-v4l2
87make OPTCCFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91mkdir -p $RPM_BUILD_ROOT%{_bindir}
92mkdir -p $RPM_BUILD_ROOT%{_libdir}
93
94make PREFIX=$RPM_BUILD_ROOT%{_prefix} LIBDIR=$RPM_BUILD_ROOT%{_libdir} install
95
96rm -rf $RPM_BUILD_ROOT%{_includedir}/CVS
97rm -rf $RPM_BUILD_ROOT%{_includedir}/ptclib/CVS
98rm -rf $RPM_BUILD_ROOT%{_includedir}/ptlib/CVS
99rm -rf $RPM_BUILD_ROOT%{_includedir}/ptlib/unix/CVS
100rm -rf $RPM_BUILD_ROOT%{_includedir}/ptlib/unix/ptlib/CVS
101rm -rf $RPM_BUILD_ROOT%{_datadir}/pwlib/make/CVS
102
103perl -pi -e 's@PWLIBDIR.*=.*@PWLIBDIR = /usr/share/pwlib@' $RPM_BUILD_ROOT%{_datadir}/pwlib/make/ptbuildopts.mak
104
105# changed permission
106chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpt*.so.*
107chmod 755 $RPM_BUILD_ROOT%{_libdir}/pwlib/devices/*/*.so
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post   -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root)
118%doc History.txt ReadMe.txt mpl-1.0.htm
119%{_libdir}/libpt*.so.*
120%dir %{_libdir}/pwlib
121%dir %{_libdir}/pwlib/devices
122%dir %{_libdir}/pwlib/devices/sound
123%dir %{_libdir}/pwlib/devices/videoinput
124
125%files alsa
126%defattr(-,root,root)
127%{_libdir}/pwlib/devices/sound/alsa_*.so
128
129%files v4l
130%defattr(-,root,root)
131%{_libdir}/pwlib/devices/videoinput/v4l_*.so
132%{_libdir}/pwlib/devices/videoinput/v4l2_*.so
133
134%files avc
135%defattr(-,root,root)
136%{_libdir}/pwlib/devices/videoinput/avc_*.so
137
138%files dc
139%defattr(-,root,root)
140%{_libdir}/pwlib/devices/videoinput/*
141
142%files devel
143%defattr(-,root,root)
144%{_libdir}/libpt*.so
145%{_includedir}/*
146%{_datadir}/pwlib
147%attr(755,root,root) %{_bindir}/*
148
149%changelog
150* Sat Jun 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.10.10-2vl5
151- rebuilt with new libdc1394
152
153* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.10-1vl5
154- applied new versioning policy
155
156* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.10-0vl1
157- new upstream release
158
159* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.7-0vl3
160- rebuild with new openssl
161
162* Sat May 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.7-0vl2
163- rebuilt with new toolchains
164
165* Sat Apr 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.7-0vl1
166- new upstream release
167- fixed typo in spec file
168
169* Fri Feb 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.4-0vl1
170- new upstream release
171- updated Source URL
172
173* Sat Feb  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.3-0vl1
174- new upstream release
175- updated URL
176
177* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
178- new upstream release
179- add BuildRequires: openldap-devel, alsa-lib-devel
180- rebuild with new openldap-2.3.24
181- disable oss support
182
183* Thu Aug  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1vl5
184- rebuild with libraw1394-1.2.0, libavc1394-0.5.3, libdc1394-1.2.0, libdv-0.104
185
186* Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-1vl4
187- rebuild with libraw1394-1.1.0, libavc1394-0.5.0, libdc1394-1.1.0, libdv-0.102
188
189* Thu Apr 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-1vl3
190- rebuild with libdv-0.102
191
192* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-1vl2
193- build with alsa-lib, libdc1394
194- split each plugins to sub-packages.
195
196* Wed Mar  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-1vl1
197- initial build for Vine Linux
198
199* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.6.3-1
200- update to 1.6.3 final
201
202* Fri Feb 20 2004 Alexander Larsson <alexl@redhat.com> 1.6.3-0.pre1.0
203- update to 1.6.3pre1
204
205* Tue Feb 17 2004 Alexander Larsson <alexl@redhat.com> 1.5.0-4
206- add ranges security fix
207
208* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
209- rebuilt
210
211* Fri Jul  4 2003 Alexander Larsson <alexl@redhat.com> 1.5.0-2
212- Add patch to recognize ppc64 ad 64bit
213
214* Tue Jul  1 2003 Alexander Larsson <alexl@redhat.com> 1.5.0-1
215- Update to 1.5.0
216- Update all patches for new makefile
217
218* Mon Jun 30 2003 Alexander Larsson <alexl@redhat.com> 1.4.7-6.EL
219- rebuild for ppc64 crt*.o problems
220
221* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
222- rebuilt
223
224* Wed Jun  4 2003 Alexander Larsson <alexl@redhat.com> 1.4.7-5
225- Add patch to workaround bison problem (bug #92262)
226
227* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
228- rebuilt
229
230* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.4.7-3
231- pwlib-1.4.7-noipv6.patch: Disable ipv6 check, damien claims it's unstable.
232
233* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.4.7-2
234- Oops. deleted a bit much from the specfile
235
236* Wed Jan  8 2003 Alexander Larsson <alexl@redhat.com> 1.4.7-1
237- Update to 1.4.7
238
239* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.3.11-2
240- rebuild
241
242* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
243- Use pkg-config to find OpenSSL if pkg-config admits to knowing anything.
244
245* Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 1.3.11-1
246- Upgrade to 1.3.11
247- Remove pwlib-alpha patch. I don't think it's necessary anymore.
248- fix %doc
249
250* Fri Aug 30 2002 Alexander Larsson <alexl@redhat.com> 1.3.3-5
251- Use %{_libdir} etc instead of hardcoding
252
253* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
254- rebuilt with gcc-3.2 (we hope)
255
256* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.3.3-3
257- rebuilt using gcc-3.2-0.1
258
259* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.3.3-2
260- Use glibc regex (and at the same time get rid of non-fpic code)
261
262* Thu Jul 11 2002 Alexander Larsson <alexl@redhat.com> 1.3.3-1
263- Update to 1.3.3
264
265* Mon Jul  1 2002 Alexander Larsson <alexl@redhat.com> 1.3.1-1
266- Update to 1.3.1
267
268* Fri Mar 22 2002 Alex Larsson <alexl@redhat.com>
269- Added versioned dependency in the devel package
270- Fixed line-to-long error in description
271
272* Fri Mar  8 2002 Alex Larsson <alexl@redhat.com>
273- Add the video patch from damien needed for GM 0.85.1
274
275* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
276- Update to 1.2.12
277
278* Thu Nov 29 2001 Alex Larsson <alexl@redhat.com> 1.2.5-1
279- Updated to 1.2.5
280
281* Mon Oct 01 2001 Alex Larsson <alexl@redhat.com> 1.1.36-4
282- Added defattr
283
284* Wed Sep 28 2001 Alex Larsson <alexl@redhat.com> 1.1.36-3
285- made the devel package require the binary package
286
287* Wed Sep 19 2001 Alex Larsson <alexl@redhat.com> 1.1.36-2
288- Added new patch from damien
289
290* Mon Aug 13 2001 Alexander Larsson <alexl@redhat.com> 1.1.36-1
291- Upgraded to 1.1.36
292
293* Wed Jul  4 2001 Elliot Lee <sopwith@redhat.com>
294- Patch asnparser makefile so 'make -j...' works completely.
295
296* Wed Jul  4 2001 Alexander Larsson <alexl@redhat.com>
297- Borrow some stuff from the Mandrake specfile
298
299* Wed Jul  4 2001 Jonathan Blandford <jrb@redhat.com>
300- Initial build.
Note: See TracBrowser for help on using the repository browser.