source: projects/specs/trunk/p/pwdb/pwdb-vl.spec @ 521

Revision 521, 4.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary:     The password database library.
3Summary(ja): パスワードデータベースライブラリ
4Name: pwdb
5Version: 0.62
6Release: 1%{?_dist_release}
7License: GPL or BSD
8Group: System Environment/Base
9Source: pwdb-%{PACKAGE_VERSION}.tar.gz
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11Conflicts: pam = 0.75-48vl1
12
13%description
14The pwdb package contains libpwdb, the password database library.
15Libpwdb is a library which implements a generic user information
16database.  Libpwdb was specifically designed to work with Linux's PAM
17(Pluggable Authentication Modules).  Libpwdb allows configurable
18access to and management of security tools like /etc/passwd,
19/etc/shadow and network authentication systems including NIS and
20Radius.
21
22%description -l ja
23pwdb パッケージにはパスワードデータベースライブラリである libpwdb が
24収められています.libpwdb は汎用ユーザ情報データベースを実装した
25ライブラリで,特に Linux の PAM (Pluggable Authentication Modules) と
26連係して動作することを念頭に置かれて設計されています.
27libpwdb を使うと /etc/passwd, /etc/shadow はもとより NIS や Radius と
28いったネットワーク認証システムへのアクセスや管理が可能になります.
29
30
31## to build compat32 for x86_64 architecture support
32%package -n compat32-%{name}
33Summary: The password database library.
34Group: System Environment/Base
35%description -n compat32-%{name}
36The pwdb package contains libpwdb, the password database library.
37Libpwdb is a library which implements a generic user information
38database.  Libpwdb was specifically designed to work with Linux's PAM
39(Pluggable Authentication Modules).  Libpwdb allows configurable
40access to and management of security tools like /etc/passwd,
41/etc/shadow and network authentication systems including NIS and
42Radius.
43
44
45%prep
46%setup -q -n pwdb-%{version}
47rm default.defs
48ln -s defs/redhat.defs default.defs
49# checking out of the CVS sometimes preserves the setgid bit on
50# directories...
51chmod -R g-s .
52
53
54%build
55%if %{build_compat32}
56export LDEMULATION="elf_i386"
57make CC="gcc -m32" RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
58%else
59make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
60%endif
61
62%install
63rm -rf $RPM_BUILD_ROOT
64mkdir -p $RPM_BUILD_ROOT/{etc,%{_lib},%{_includedir}/pwdb}
65
66make INCLUDED=$RPM_BUILD_ROOT%{_includedir}/pwdb \
67        LIBDIR=$RPM_BUILD_ROOT/%{_lib} \
68        LDCONFIG=":" \
69        install
70
71install -m 644 conf/pwdb.conf $RPM_BUILD_ROOT/etc/pwdb.conf
72
73
74%post -p /sbin/ldconfig
75
76%postun -p /sbin/ldconfig
77
78
79%if %{build_compat32}
80%post -n compat32-%{name} -p /sbin/ldconfig
81%postun -n compat32-%{name} -p /sbin/ldconfig
82%endif
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%if !%{build_compat32}
88%files
89%defattr(-,root,root)
90%doc Copyright doc/pwdb.txt doc/html
91%config /etc/pwdb.conf
92%{_includedir}/pwdb
93/%{_lib}/libpwdb.a
94/%{_lib}/libpwdb.so
95/%{_lib}/libpwdb.so.%{PACKAGE_VERSION}
96%endif
97
98%if %{build_compat32}
99%files -n compat32-%{name}
100%defattr(-,root,root)
101/%{_lib}/libpwdb.a
102/%{_lib}/libpwdb.so
103/%{_lib}/libpwdb.so.%{PACKAGE_VERSION}
104%endif
105
106
107%changelog
108* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.62-1vl5
109- applied new versioning policy, spec in utf-8
110
111* Sun Mar 12 2006 Shu KONNO <owa@bg.wakwak.com> 0.62-0vl3
112- s/Copylight/License/
113- added compat32-* for x86_64
114
115* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.62-0vl2
116- rebuild
117
118* Thu Mar 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
119- new upstream release
120- splitted from pam-0.75-48vl1
121
122* Fri Aug 02 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.61.2-0vl1
123- source update
124- fix includes
125
126* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
127- 0.61.1-1vl1
128- based on 0.61.1-1 from Rawhide
129- use better macros (%%{_includedir})
130- added Japanese summary and description
131
132* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
133- add missing header files (#16951)
134
135* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
136- automatic rebuild
137
138* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
139- rebuild for next release
140
141* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
142- fix setting the password for passwordless accounts. Patch from Thomas
143  Sailer
144
145* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
146- rebuild to fix dependencies
Note: See TracBrowser for help on using the repository browser.