source: projects/specs/trunk/p/pvm/pvm-vl.spec @ 521

Revision 521, 9.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Libraries for distributed computing.
2Summary(ja): ʬ»¶·×»»¥é¥¤¥Ö¥é¥ê
3Name: pvm
4Version: 3.4.3
5Release: 24vl2
6License: freely distributable
7Group: Development/Libraries
8Source0: http://www.netlib.org/pvm3/pvm3.4.3.tgz
9Source1: http://www.netlib.org/pvm3/xpvm/XPVM.src.1.2.5.tgz
10Source2: xpvm.sh
11Source3: pvmd.init
12Source4: pvm.sh
13Source5: pvm_init.sh
14Source6: pvm_init.csh
15Source7: xpvm_init.sh
16Source8: xpvm_init.csh
17Source9: README.RedHat
18Patch0: xpvm-tcltk.patch
19Patch1: pvm3-vaargfix.patch
20Patch2: pvm-s390.patch
21URL: http://www.epm.ornl.gov/pvm/pvm_home.html
22BuildRoot: %{_tmppath}/pvm-root
23Excludearch: ia64
24Requires: initscripts >= 5.52, bash >= 2
25
26%package gui
27Requires: pvm
28Summary: TCL/TK graphical frontend to monitor and manage a PVM cluster.
29Summary(ja): PVM¥¯¥é¥¹¥¿¤Î¥â¥Ë¥¿¡¦´ÉÍý¤Î¤¿¤á¤ÎTCL/TK ¥°¥é¥Õ¥£¥«¥ë¡¦¥Õ¥í¥ó¥È¥¨¥ó¥É
30Group: Applications/System
31
32%description
33PVM3 (Parallel Virtual Machine) is a library and daemon that allows
34distributed processing environments to be constructed on heterogeneous
35machines and architectures.
36
37%description gui
38Xpvm is a TCL/TK based tool that allows full manageability of the PVM cluster
39as well as the ability to monitor cluster performance.
40
41%prep
42%setup -q -T -c -n pvm
43cp %SOURCE9 .
44chmod 0644 README.RedHat
45
46rm -rf $RPM_BUILD_ROOT
47mkdir -p $RPM_BUILD_ROOT/usr/share/
48cd $RPM_BUILD_ROOT/usr/share
49tar -xzf %{SOURCE0}
50cd pvm3
51tar -xzf %{SOURCE1}
52%patch0 -p0
53%patch1 -p1
54%patch2 -p1
55cp conf/LINUX.def conf/LINUXS390.def
56cp conf/LINUX.m4 conf/LINUXS390.m4
57
58%build
59PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
60        PVM_DPATH=$RPM_BUILD_ROOT/usr/share/pvm3/lib/pvmd \
61        make -C $RPM_BUILD_ROOT/usr/share/pvm3
62PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
63        XPVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3/xpvm \
64        make -C $RPM_BUILD_ROOT/usr/share/pvm3/xpvm
65
66%install
67mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,3}
68install -m 644 $RPM_BUILD_ROOT/usr/share/pvm3/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
69install -m 644 $RPM_BUILD_ROOT/usr/share/pvm3/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
70mkdir -p $RPM_BUILD_ROOT/usr/bin
71install -m 0755  $RPM_SOURCE_DIR/xpvm.sh $RPM_BUILD_ROOT/usr/bin/xpvm
72PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
73        XPVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3/xpvm \
74        make -C $RPM_BUILD_ROOT/usr/share/pvm3/xpvm install
75strip $RPM_BUILD_ROOT/usr/share/pvm3/bin/*/*
76
77mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
78install -m 0755  $RPM_SOURCE_DIR/pvmd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/pvmd
79
80mkdir -p $RPM_BUILD_ROOT/usr/bin
81install -m 0755  $RPM_SOURCE_DIR/pvm.sh $RPM_BUILD_ROOT/usr/bin/pvm
82
83# Move the documentation the directory RPM thinks it's using, so we
84# can classify it as documentation files
85
86mv $RPM_BUILD_ROOT/usr/share/pvm3/doc/* $RPM_BUILD_DIR/pvm/
87rmdir $RPM_BUILD_ROOT/usr/share/pvm3/doc
88
89# Use /var/run/pvm for state files
90
91mkdir -p $RPM_BUILD_ROOT/var/run/pvm3
92
93# build the file list
94find $RPM_BUILD_ROOT -type f -o -type l | \
95        sed -e "s|$RPM_BUILD_ROOT||g" | \
96        grep -v -i win32 | \
97        grep -v "/pvm3/man/man" | \
98        grep -v "usr/man" | \
99        grep -v "xpvm" | \
100        grep -v "example" | \
101        grep -v "conf/" | \
102        grep -v "etc/rc.d/init.d" | \
103        grep -v "\.o$" > files.list
104find $RPM_BUILD_ROOT -type f -o -type l | \
105        sed -e "s|$RPM_BUILD_ROOT||g" | \
106        grep "conf/LINUX" >> files.list
107find $RPM_BUILD_ROOT -type f -o -type l | \
108        grep example | \
109        sed -e "s|$RPM_BUILD_ROOT|%doc |g" >> files.list
110find $RPM_BUILD_ROOT/usr/share/pvm3  -type d | \
111        sed -e "s|$RPM_BUILD_ROOT|%dir |g" | \
112        grep -v "xpvm" >> files.list
113
114# Remove man pages from list
115
116grep -v "%{_mandir}" files.list > files.list2
117mv files.list2 files.list
118
119#install init files
120
121mkdir -p $RPM_BUILD_ROOT/etc/profile.d
122install -m 755  %SOURCE5 $RPM_BUILD_ROOT/etc/profile.d/pvm.sh
123install -m 755  %SOURCE6 $RPM_BUILD_ROOT/etc/profile.d/pvm.csh
124install -m 755  %SOURCE7 $RPM_BUILD_ROOT/etc/profile.d/xpvm.sh
125install -m 755  %SOURCE8 $RPM_BUILD_ROOT/etc/profile.d/xpvm.csh
126
127
128#Fix a broken man page
129rm $RPM_BUILD_ROOT%{_mandir}/man1/PVM.1
130ln -sf pvm_intro.1 $RPM_BUILD_ROOT%{_mandir}/man1/PVM.1
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134rm -f files.list
135
136%pre
137/usr/sbin/groupadd -g 24 -r -f pvm > /dev/null 2>&1 ||:
138/usr/sbin/useradd -u 24 -g 24 -d /usr/share/pvm3 -r -s /bin/bash pvm > /dev/null 2>&1 ||:
139 
140%preun
141if [ $1 -eq 0 ]; then
142        /sbin/chkconfig --del pvmd
143fi
144       
145%post
146/sbin/chkconfig --add pvmd
147
148%postun
149if [ $1 -ge 1 ]; then
150    service pvmd condrestart >/dev/null 2>&1
151fi
152if [ $1 = 0 ] ; then
153    /usr/sbin/userdel pvm > /dev/null 2>&1
154fi
155
156
157%files -f files.list
158%defattr(-,root,root)
159%config /etc/rc.d/init.d/pvmd
160%doc arches  bugreport  example.pvmrc  release-notes README.RedHat
161%{_mandir}/*/*
162/etc/profile.d/pvm*
163%dir %attr(755,pvm,pvm) /var/run/pvm3
164
165%files gui
166%defattr(-,root,root)
167%dir /usr/share/pvm3/xpvm
168/etc/profile.d/xpvm*
169/usr/share/pvm3/bin/*/xpvm
170/usr/bin/xpvm
171/usr/share/pvm3/xpvm/*
172
173%changelog
174* Tue Feb  5 2002 Jun Nishii <jun@vinelinux.org> 3.4.3-24vl2
175- change version dependency of initscripts
176
177* Thu Jan 31 2002 Jun Nishii <jun@vinelinux.org> 3.4.3-24vl1
178- added Japanese summary
179
180* Sat Jan 27 2001 Karsten Hopp <karsten@redhat.de>
181- added s390 patch
182- FIXME: tmpnam is used at several functions, better
183         use mkstemp
184
185* Tue Jan 23 2001 Trond Eivind Glomsr <teg@redhat.com>
186- change gettextizing
187
188* Wed Jan 17 2001 Trond Eivind Glomsr <teg@redhat.com>
189- gettextize
190
191* Fri Oct 20 2000 Trond Eivind Glomsr <teg@redhat.com>
192- LINUX isn't LINUX on Alpha, it's LINUXALPHA (#19389)
193 
194* Fri Aug 18 2000 Trond Eivind Glomsr <teg@redhat.com>
195- add README.RedHat for setup instructions - some
196  enviroment variables need to be set for pvm to work
197
198* Tue Aug 15 2000 Trond Eivind Glomsr <teg@redhat.com>
199- use /var/run/pvm3 for state files (#16217) for a long
200  and healthy life, uninterrupted by tmpwatch
201
202* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
203- condrestart fixes
204
205* Mon Jul 17 2000 Trond Eivind Glomsr <teg@redhat.com>
206- move back to /etc/rc.d/init.d
207
208* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
209- automatic rebuild
210
211* Thu Jul 06 2000 Trond Eivind Glomsr <teg@redhat.com>
212- "Prereq:", not "Requires:" for /etc/init.d
213
214* Thu Jul 06 2000 Trond Eivind Glomsr <teg@redhat.com>
215- require /etc/init.d
216
217* Mon Jun 26 2000 Trond Eivind Glomsr <teg@redhat.com>
218- really move the initscript, not just the paths inside it
219
220* Mon Jun 26 2000 Trond Eivind Glomsr <teg@redhat.com>
221- add conditional restart to initscripts and specfile
222- move initscript to /etc/init.d
223
224* Wed Jun 14 2000 Trond Eivind Glomsr <teg@redhat.com>
225- Added patch to make compile with new tool chain
226- use %%{_tmppath}, %%{_mandir}
227
228* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
229- added handling of arguments to pvm.sh/xpvm.sh
230
231* Fri Apr 28 2000 Trond Eivind Glomsr <teg@redhat.com>
232- added some extra initialization
233- removed gzipping - handled automatically
234
235* Thu Apr 27 2000 Trond Eivind Glomsr <teg@redhat.com>
236- added URL
237- changed source location - use netlib
238- fix location of documentation files
239
240* Mon Apr 17 2000 Trond Eivind Glomsr <teg@redhat.com>
241- fixed a problem with the PVM man page
242- gzip the man pages
243- should now be able to compile with several tcl/tk versions
244  without problems
245
246* Mon Mar 06 2000 Mike Wangsmo <wanger@redhat.com>
247- fixed the useradd failure mode when user already exists
248- finally, the init script seems to behave nicely as user pvm
249
250* Sun Mar 05 2000 Mike Wangsmo <wanger@redhat.com>
251- fixed quirk in init script to allow PVMD_NOHOLD=ON to be honored
252
253* Fri Feb 18 2000 Mike Wangsmo <wanger@redhat.com>
254- added env. variable to make pvmd background when started
255- fixed init script killproc errors
256- moved to 3.4.3 proper
257
258* Tue Feb 15 2000 Mike Wangsmo <wanger@redhat.com>
259- fixed up some group ID stuff
260
261* Mon Feb 14 2000 Mike Wangsmo <wanger@redhat.com>
262- added pvm user to package
263
264* Wed Feb 09 2000 Mike Wangsmo <wanger@redhat.com>
265- added sparc64 identifier to pvmgetarch
266- configured pvmd within the init script to run as user pvm
267
268* Sat Feb 05 2000 Mike Wangsmo <wanger@redhat.com>
269- changed pvm-gui group
270- set chkconfig to be off in all run levels as the default
271
272* Thu Feb 04 2000 Mike Wangsmo <wanger@redhat.com>
273- added sysV init script
274- added a shell wrapper in /usr/bin for the pvm shell
275- moved up to 3.4.2pl4
276
277* Wed Feb 02 2000 Mike Wangsmo <wanger@redhat.com>
278- added some missing files for xpvm to work
279
280* Mon Jan 24 2000 Mike Wangsmo <wanger@redhat.com>
281- dropped all non-linux stuff
282- split the packages up
283- added xpvm
284- "fixed" Sparc
285
286* Mon Nov 29 1999 Tim Powers <timp@redhat.com>
287- updated to 3.4.2
288
289* Sun Sep 5 1999 Tim Powers <timp@redhat.com>
290- excludearch sparc
291
292* Wed Jul 28 1999 Tim Powers <timp@redhat.com>
293- update to 3.4.1
294- comment out the patches in %prep section, will test, if it works then it
295  stays commented
296
297* Wed May 05 1999 Bill Nottingham <notting@redhat.com>
298- update to 3.4.0 final
299
300* Tue Oct 27 1998 Cristian Gafton <gafton@redhat.com>
301- added a patch for the SIGCLD -> SIGCHLD rename
302- fixed the incredibly stupid spec file to have a much shorter %files list
303
304* Tue Oct 12 1998 Michael Maher <mike@redhat.com>
305- updated pacakge for 5.2 powertools.
306
307* Sat Jun 06 1998 Michael Maher <mike@redhat.com>
308- updated source
309- changed spec file for all archs
310
311* Wed Dec 03 1997 Mike Wangsmo <wanger@redhat.com>
312- fixed patches to cleanly build on glibc
313- corrected alpha inuendos
314
315* Wed Dec  3 1997 Otto Hammersmith <otto@redhat.com>
316- snagged Wanger's package.
317- moved buildroot from /var/tmp to /var/tmp/pvm-root
318
Note: See TracBrowser for help on using the repository browser.