source: projects/specs/trunk/p/pugixml/pugixml-vl.spec @ 10769

Revision 10769, 3.2 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           pugixml
2Version:        1.7
3Release:        2%{?_dist_release}
4Summary:        A light-weight C++ XML processing library
5Group:          Development/Libraries
6License:        MIT
7URL:            http://pugixml.org
8
9Source0:        http://github.com/zeux/pugixml/releases/download/v%{version}/pugixml-%{version}.tar.gz
10# Add pugixml-config.cmake
11# https://github.com/zeux/pugixml/pull/7
12#Patch0:         pugixml-export.patch
13
14BuildRequires:  cmake
15
16%description
17pugixml is a light-weight C++ XML processing library.
18It features:
19- DOM-like interface with rich traversal/modification capabilities
20- Extremely fast non-validating XML parser which constructs the DOM tree from
21  an XML file/buffer
22- XPath 1.0 implementation for complex data-driven tree queries
23- Full Unicode support with Unicode interface variants and automatic encoding
24  conversions
25
26
27%package devel
28Summary:        Development files for %{name}
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31
32%description devel
33Development files for package %{name}
34
35
36%package docs
37Summary:        Documentation for %{name}
38Group:          Documentation
39BuildArch:              noarch
40
41%description docs
42Documentation for package %{name}
43
44
45%prep
46%setup -q
47#%patch0 -p1 -b .export
48
49
50%build
51mkdir -p ./build && pushd build
52%cmake -DCMAKE_INSTALL_LIBDIR=%{_lib} ../scripts
53make
54
55
56%install
57make -C build install DESTDIR=%{buildroot}
58mkdir -p %{buildroot}%{_datadir}/%{name}/contrib
59install -p -m 0644 contrib/* %{buildroot}%{_datadir}/%{name}/contrib/
60
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66
67%files
68%doc readme.txt
69%{_libdir}/*.so.*
70
71%files devel
72%{_libdir}/*.so
73%{_libdir}/cmake/%{name}/
74%{_datadir}/%{name}
75%{_includedir}/*.hpp
76
77%files docs
78%doc docs/*
79
80
81%changelog
82* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 1.7-2
83- rebuild with gcc-5.4.0
84
85* Sat Jul 09 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7-1
86- new upstream release
87- deleted Patch0
88
89* Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4-1
90- initial build for Vine Linux
91
92
93* Wed Sep 03 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4-1
94- Update to 1.4
95- Split documentation out into -doc sub-package
96- Add cmake export information
97
98* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-8
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
100
101* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-7
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
103
104* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-6
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
106
107* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
109
110* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
112
113* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
115
116* Thu Jan 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0-2
117- Rebuild for GCC 4.7.0.
118
119* Fri Jul 08 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0-1
120- Initial Release
Note: See TracBrowser for help on using the repository browser.