source: projects/specs/trunk/p/pth/pth-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        The GNU Portable Threads library
2Name:           pth
3Version:        2.0.7
4Release:        7%{?_dist_release}
5License:        LGPLv2+
6Group:          System Environment/Libraries
7URL:            http://www.gnu.org/software/pth/
8Source:         ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz
9Source1:        ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz.sig
10Patch1:         pth-2.0.7-dont-remove-gcc-g.patch
11Patch2:         pth-2.0.7-config-script.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14%description
15Pth is a very portable POSIX/ANSI-C based library for Unix platforms
16which provides non-preemptive priority-based scheduling for multiple
17threads of execution ("multithreading") inside server applications.
18All threads run in the same address space of the server application,
19but each thread has it's own individual program-counter, run-time
20stack, signal mask and errno variable.
21
22%package devel
23Summary:        Development headers and libraries for GNU Pth
24Group:          Development/Libraries
25Requires:       %{name} = %{version}-%{release}
26
27%description devel
28Development headers and libraries for GNU Pth.
29
30
31%prep
32%setup -q
33%patch1 -p1 -b .dont-remove-gcc-g
34%patch2 -p1 -b .config-script
35
36
37%build
38%configure --disable-static ac_cv_func_sigstack='no'
39
40# Work around multiarch conflicts in the pth-config script in order
41# to complete patch2. Make the script choose between /usr/lib and
42# /usr/lib64 at run-time.
43if [ "%_libdir" == "/usr/lib64" ] ; then
44    if grep -e '^pth_libdir="/usr/lib64"' pth-config ; then
45        sed -i -e 's!^pth_libdir="/usr/lib64"!pth_libdir="/usr/lib"!' pth-config
46    else
47        echo "ERROR: Revisit the multiarch pth_libdir fixes for pth-config!"
48        exit 1
49    fi
50fi
51if grep -e "$RPM_OPT_FLAGS" pth-config ; then
52    # Remove our extra CFLAGS from the pth-config script, since they
53    # don't belong in there.
54    sed -i -e "s!$RPM_OPT_FLAGS!!g" pth-config
55else
56    echo "ERROR: Revisit the multiarch CFLAGS fix for pth-config!"
57    exit 1
58fi
59
60# this is necessary; without it make -j fails
61make pth_p.h
62make %{?_smp_mflags}
63
64
65%check
66make test
67l=$($(pwd)/pth-config --libdir)
68%ifarch x86_64 ppc64
69    [ "$l" == "/usr/lib64" ]
70%endif
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make DESTDIR=${RPM_BUILD_ROOT} install
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87
88%files
89%defattr(-,root,root,-)
90%doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS PORTING README
91%doc SUPPORT TESTS THANKS USERS
92%{_libdir}/*.so.*
93
94%files devel
95%defattr(-,root,root,-)
96%doc HACKING
97%{_bindir}/*
98%{_includedir}/*
99%{_libdir}/*.so
100%{_mandir}/*/*
101%{_datadir}/aclocal/*
102
103
104%changelog
105* Wed Sep 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.7-7
106- initial build for VineSeed
107
108* Sat May 31 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-7
109- Drop "|| :" from check section. It failed to build for mdomsch
110  in Rawhide today.
111
112* Fri Feb 08 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-6
113- rebuilt for GCC 4.3 as requested by Fedora Release Engineering
114
115* Sun Oct 21 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-5
116- Patch pth-config.
117  This shall fix the multiarch conflict in pth-devel (#342961).
118  It must not return -I/usr/include and -L/usr/{lib,lib64} either,
119  since these are default search paths already.
120- Replace the config.status CFLAGS sed expr with a patch.
121
122* Tue Aug 21 2007 Michael Schwendt <mschwendt@fedoraproject.org>
123- rebuilt
124
125* Thu Aug  2 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-2
126- Clarify licence (LGPLv2+).
127
128* Sat Nov 25 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-1
129- Update to 2.0.7 (very minor maintenance updates only).
130
131* Mon Aug 28 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-3
132- rebuilt
133
134* Mon May 22 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-2
135- Insert -g into CFLAGS after configure script removes it.
136- Disable configure check for obsolete sigstack(), which segfaults.
137
138* Thu Feb 16 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-1
139- Update to 2.0.6.
140
141* Fri Oct  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.5-1
142- Update to 2.0.5.
143- Don't build static archive.
144
145* Fri May 13 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-3
146- rebuilt
147
148* Thu Apr  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-2
149- rebuilt
150
151* Thu Feb 24 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.4-1
152- Update to 2.0.4.
153- Remove ancient changelog entries which even pre-date Fedora.
154
155* Tue Dec 14 2004 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.3-1
156- Update to 2.0.3, minor and common spec adjustments + LGPL, %%check,
157  use URLs for official GNU companion sites.
158
159* Thu Oct 07 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.2
160- iconv-ing spec to utf8
161
162* Wed Oct 06 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.1
163- Update to 2.0.2 and current Fedora guidelines.
164- added workaround for make -j problem
165
166* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.0.0-0.fdr.1
167- Update to 2.0.0 and current Fedora guidelines.
168- Exclude %%{_libdir}/*.la
169
170* Fri Feb  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1.fedora.1
171- First Fedora release, based on Ryan Weaver's work.
172- Move (most of) docs to main package.
173
Note: See TracBrowser for help on using the repository browser.