source: projects/specs/trunk/p/pth/pth-vl.spec @ 9282

Revision 9282, 5.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-19 Ryoichi INAGAKI <ryo1@…>

  • dirmngr: updated
  • pth: rebuilt


Line 
1Summary:        The GNU Portable Threads library
2Summary(ja):    GNU ポータブルスレッドライブラリ
3Name:           pth
4Version:        2.0.7
5Release:        9%{?_dist_release}
6License:        LGPLv2+
7Group:          System Environment/Libraries
8URL:            http://www.gnu.org/software/pth/
9Source:         ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz
10Source1:        ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz.sig
11Patch1:         pth-2.0.7-dont-remove-gcc-g.patch
12Patch2:         pth-2.0.7-config-script.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15%description
16Pth is a very portable POSIX/ANSI-C based library for Unix platforms
17which provides non-preemptive priority-based scheduling for multiple
18threads of execution ("multithreading") inside server applications.
19All threads run in the same address space of the server application,
20but each thread has it's own individual program-counter, run-time
21stack, signal mask and errno variable.
22
23%package devel
24Summary:        Development headers and libraries for GNU Pth
25Summary(ja):    GNU Pth の開発用ヘッダファイル及びライブラリ
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28
29%description devel
30Development headers and libraries for GNU Pth.
31
32
33%prep
34%setup -q
35%patch1 -p1 -b .dont-remove-gcc-g
36%patch2 -p1 -b .config-script
37
38
39%build
40%configure --disable-static ac_cv_func_sigstack='no'
41
42# Work around multiarch conflicts in the pth-config script in order
43# to complete patch2. Make the script choose between /usr/lib and
44# /usr/lib64 at run-time.
45if [ "%_libdir" == "/usr/lib64" ] ; then
46    if grep -e '^pth_libdir="/usr/lib64"' pth-config ; then
47        sed -i -e 's!^pth_libdir="/usr/lib64"!pth_libdir="/usr/lib"!' pth-config
48    else
49        echo "ERROR: Revisit the multiarch pth_libdir fixes for pth-config!"
50        exit 1
51    fi
52fi
53if grep -e "$RPM_OPT_FLAGS" pth-config ; then
54    # Remove our extra CFLAGS from the pth-config script, since they
55    # don't belong in there.
56    sed -i -e "s!$RPM_OPT_FLAGS!!g" pth-config
57else
58    echo "ERROR: Revisit the multiarch CFLAGS fix for pth-config!"
59    exit 1
60fi
61
62# this is necessary; without it make -j fails
63make pth_p.h
64make %{?_smp_mflags}
65
66
67%check
68make test
69l=$($(pwd)/pth-config --libdir)
70%ifarch x86_64 ppc64
71    [ "$l" == "/usr/lib64" ]
72%endif
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make DESTDIR=${RPM_BUILD_ROOT} install
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
79
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%post -p /sbin/ldconfig
86
87%postun -p /sbin/ldconfig
88
89
90%files
91%defattr(-,root,root,-)
92%doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS PORTING README
93%doc SUPPORT TESTS THANKS USERS
94%{_libdir}/*.so.*
95
96%files devel
97%defattr(-,root,root,-)
98%doc HACKING
99%{_bindir}/*
100%{_includedir}/*
101%{_libdir}/*.so
102%{_mandir}/*/*
103%{_datadir}/aclocal/*
104
105
106%changelog
107* Mon Jan 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.7-9
108- rebuilt on current VineSsed
109
110* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.7-8
111- rebuild with Vine6 environment
112
113* Wed Sep 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.7-7
114- initial build for VineSeed
115
116* Sat May 31 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-7
117- Drop "|| :" from check section. It failed to build for mdomsch
118  in Rawhide today.
119
120* Fri Feb 08 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-6
121- rebuilt for GCC 4.3 as requested by Fedora Release Engineering
122
123* Sun Oct 21 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-5
124- Patch pth-config.
125  This shall fix the multiarch conflict in pth-devel (#342961).
126  It must not return -I/usr/include and -L/usr/{lib,lib64} either,
127  since these are default search paths already.
128- Replace the config.status CFLAGS sed expr with a patch.
129
130* Tue Aug 21 2007 Michael Schwendt <mschwendt@fedoraproject.org>
131- rebuilt
132
133* Thu Aug  2 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-2
134- Clarify licence (LGPLv2+).
135
136* Sat Nov 25 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-1
137- Update to 2.0.7 (very minor maintenance updates only).
138
139* Mon Aug 28 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-3
140- rebuilt
141
142* Mon May 22 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-2
143- Insert -g into CFLAGS after configure script removes it.
144- Disable configure check for obsolete sigstack(), which segfaults.
145
146* Thu Feb 16 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-1
147- Update to 2.0.6.
148
149* Fri Oct  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.5-1
150- Update to 2.0.5.
151- Don't build static archive.
152
153* Fri May 13 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-3
154- rebuilt
155
156* Thu Apr  7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-2
157- rebuilt
158
159* Thu Feb 24 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.4-1
160- Update to 2.0.4.
161- Remove ancient changelog entries which even pre-date Fedora.
162
163* Tue Dec 14 2004 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.3-1
164- Update to 2.0.3, minor and common spec adjustments + LGPL, %%check,
165  use URLs for official GNU companion sites.
166
167* Thu Oct 07 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.2
168- iconv-ing spec to utf8
169
170* Wed Oct 06 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.1
171- Update to 2.0.2 and current Fedora guidelines.
172- added workaround for make -j problem
173
174* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.0.0-0.fdr.1
175- Update to 2.0.0 and current Fedora guidelines.
176- Exclude %%{_libdir}/*.la
177
178* Fri Feb  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1.fedora.1
179- First Fedora release, based on Ryan Weaver's work.
180- Move (most of) docs to main package.
181
Note: See TracBrowser for help on using the repository browser.