source: projects/specs/trunk/p/pstoedit/pstoedit-vl.spec @ 12555

Revision 12555, 9.7 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ImageMagick?-6.9.12.1-1

cmake-3.19.6-1

double-conversion-3.1.5-5

emacs-27.1-1

inkscape-1.0.2-1

potrace-1.16-1

pstoedit-3.75-2

Line 
1Name:            pstoedit
2Summary:         Translator of PostScript and PDF graphics into various vector formats
3Summary(ja):     ポストスクリプトやPDFを多種多様なベクタ形式に変換
4Version:         3.75
5Release:         2%{?_dist_release}
6Group:           graphics
7Vendor:          Project Vine
8Distribution:    Vine Linux
9
10License:         GPLv2
11URL:             http://www.calvina.de/pstoedit/
12Source0:         https://prdownloads.sourceforge.net/pstoedit/%{name}-%{version}.tar.gz
13#Source1:         http://www.helga-glunz.homepage.t-online.de/plugins/plugins_linux_350.tgz
14
15BuildRoot:       %{_tmppath}/%{name}-%{version}-root
16BuildRequires:   libemf-devel libpng-devel gd-devel
17BuildRequires:   ImageMagick-c++-devel zlib-devel
18BuildRequires:   ghostscript
19BuildRequires:   libtool sed
20
21%description
22pstoedit translates PostScript and PDF graphics into other vector
23formats. Currently pstoedit can generate the following formats:
24    * Tgif .obj format (for tgif version >= 3)
25    * .fig format for xfig
26    * pdf - Adobe's Portable Document Format
27    * gnuplot format
28    * Flattened PostScript (with or without Bezier curves)
29    * DXF - CAD exchange format
30    * LWO - LightWave 3D
31    * RIB - RenderMan
32    * RPL - Real3D
33    * Java 1 or Java 2 applet
34    * Idraw format (in fact a special form of EPS that idraw can read)
35    * Tcl/Tk
36    * HPGL
37    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
38    * Windows Meta Files (WMF) (Windows 9x/NT only)
39    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
40    * OS/2 meta files (OS/2 only)
41    * PIC format for troff/groff
42    * MetaPost format for usage with TeX/LaTeX
43    * LaTeX2e picture
44    * Kontour
45    * GNU Metafile (plotutils / libplot)
46    * Sketch ( http://sketch.sourceforge.net )
47    * Mathematica
48    * via ImageMagick to any format supported by ImageMagick
49    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
50
51%description -l ja
52pstoeditはポストスクリプトやPDFを多種多様なベクタ形式に変換します。サ
53ポートしている出力ファイル形式は下記の通りです。
54    *  Tgif .obj format (for tgif version >= 3)
55    * .fig format for xfig
56    * pdf - Adobe's Portable Document Format
57    * gnuplot format
58    * Flattened PostScript (with or without Bezier curves)
59    * DXF - CAD exchange format
60    * LWO - LightWave 3D
61    * RIB - RenderMan
62    * RPL - Real3D
63    * Java 1 or Java 2 applet
64    * Idraw format (in fact a special form of EPS that idraw can read)
65    * Tcl/Tk
66    * HPGL
67    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
68    * Windows Meta Files (WMF) (Windows 9x/NT only)
69    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
70    * OS/2 meta files (OS/2 only)
71    * PIC format for troff/groff
72    * MetaPost format for usage with TeX/LaTeX
73    * LaTeX2e picture
74    * Kontour
75    * GNU Metafile (plotutils / libplot)
76    * Sketch ( http://sketch.sourceforge.net )
77    * Mathematica
78    * via ImageMagick to any format supported by ImageMagick
79    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
80
81
82%package        devel
83Summary:        pstoedit C Library developer.
84Summary(ja):    pstoedit 開発ライブラリ
85Group:          programming
86URL:            http://www.pstoedit.net/pstoedit
87Requires:       pstoedit = %{version}-%{release}
88Requires:       libpng-devel libstdc++-devel zlib-devel
89
90%description devel
91pstoedit library
92
93%description -l ja devel
94pstoedit 開発ライブラリ
95
96
97%debug_package
98
99
100%prep
101%setup -q
102 %{__perl} -p -i -e 's|BINDIR=/usr/local/bin||' autogen.sh
103
104
105%build
106autoreconf -fiv
107#./autogen.sh
108#libtoolize -c -f
109
110# needed because of definitions in imagemagick headers that break with -pedantic
111sed -ie 's/-pedantic//' configure
112
113%configure  \
114    --disable-static \
115    --without-swf \
116    --with-emf \
117    --with-libemf-lib=%{_libdir} \
118    --with-libemf-include=%{_includedir}/libEMF
119
120# don't use _smp_mflags
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%makeinstall
127#ifarch %{ix86}
128#{__install} -m 755 plugins_linux_350.so %{buildroot}%{_libdir}/%{name}
129#endif
130
131%{__mkdir_p} $RPM_BUILD_ROOT%{_mandir}/man1
132%{__install} -m 644 doc/%{name}.1  %{buildroot}%{_mandir}/man1
133
134%{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
135echo "%{_libdir}/%{name}" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/pstoedit.conf
136
137rm -rf %{buildroot}%{_docdir}/%{name}
138
139# %{__mkdir_p} %{buildroot}%{_bindir}
140# %{__install} -c config/pstoedit-config %{buildroot}%{_bindir}
141# %{__mkdir_p} %{buildroot}%{_datadir}
142# %{__install} -c -m 644 config/pstoedit.m4  %{buildroot}%{_datadir}/aclocal
143# %{__mkdir_p} %{buildroot}%{_datadir}/pstoedit/swffonts
144# %{__install} -c -m 644 misc/swffonts/default.fdb %{buildroot}%{_datadir}/pstoedit/swffonts
145# %{__install} -c -m 644 misc/latex2e.fmp %{buildroot}%{_datadir}/pstoedit
146# %{__install} -c -m 644 misc/mpost.fmp %{buildroot}%{_datadir}/pstoedit
147# %{__install} -c -m 644 misc/safer.ps %{buildroot}%{_datadir}/pstoedit
148# %{__install} -c -m 644 misc/svg.fmp %{buildroot}%{_datadir}/pstoedit
149# %{__install} -c -m 644 misc/wemf.fmp %{buildroot}%{_datadir}/pstoedit
150# %{__install} -c -m 644 misc/examplefigmap.fmp %{buildroot}%{_datadir}/pstoedit
151# ./libtool --mode=install %{__install} -c  src/libpstoedit.la  %{buildroot}%{_libdir}
152# ./libtool --mode=install %{__install} -c  src/pstoedit  %{buildroot}%{_bindir}
153# %{__mkdir_p} %{buildroot}%{_libdir}/pstoedit
154# ./libtool --mode=install %{__install} -c  src/libp2edrvstd.la   %{buildroot}%{_libdir}/pstoedit
155# ./libtool --mode=install %{__install} -c  src/libp2edrvmagick++.la  -inst-prefix %{buildroot} %{buildroot}%{_libdir}/pstoedit
156# %{__install} -c -m 644 src/pstoedit.h  %{buildroot}%{_prefix}/include/pstoedit
157# %{__install} -c -m 644 src/pstoedll.h  %{buildroot}%{_prefix}/include/pstoedit
158# %{__install} -c -m 644 src/pstoeditoutputlib.h  %{buildroot}%{_prefix}/include/pstoedit
159# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
160# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
161# %{__install} -c -m 644 src/cppcomp.h  %{buildroot}%{_prefix}/include/pstoedit
162# %{__install} -c -m 644 src/drvbase.h  %{buildroot}%{_prefix}/include/pstoedit
163# %{__install} -c -m 644 src/drvfuncs.h  %{buildroot}%{_prefix}/include/pstoedit
164# %{__install} -c -m 644 src/miscutil.h  %{buildroot}%{_prefix}/include/pstoedit
165# %{__install} -c -m 644 src/base64writer.h  %{buildroot}%{_prefix}/include/pstoedit
166# %{__install} -c -m 644 src/poptions.h  %{buildroot}%{_prefix}/include/pstoedit
167# %{__install} -c -m 644 src/ordlist.h  %{buildroot}%{_prefix}/include/pstoedit
168# %{__install} -c -m 644 src/psimage.h  %{buildroot}%{_prefix}/include/pstoedit
169#
170# %{__install} -m 775 lib/pstoedit/plugins_linux.so %{buildroot}%{_libdir}/pstoedit
171# for i in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/pstoedit/*.la
172#  do cp -p $i $i~
173#  sed s:%{buildroot}::g <$i~ >$i
174#  rm $i~
175# done
176#
177
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182
183%ldconfig_scriptlets
184
185
186%files
187%defattr(-,root,root)
188%license copying
189%doc doc/*.htm doc/*.pdf doc/*.txt
190%{_sysconfdir}/ld.so.conf.d/%{name}.conf
191%{_bindir}/pstoedit
192%{_libdir}/*.so.*
193%dir %{_libdir}/pstoedit
194%{_libdir}/%{name}/*.so
195%{_libdir}/%{name}/*.so.*
196%{_datadir}/%{name}
197%{_mandir}/*/*
198
199%files devel
200%defattr(-,root,root)
201%{_libdir}/*.so
202%{_includedir}/pstoedit/*
203%{_libdir}/pkgconfig/*.pc
204%{_datadir}/aclocal/*
205%exclude %{_libdir}/*.la
206%exclude %{_libdir}/pstoedit/*.la
207
208
209%changelog
210* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.75-2
211- rebuilt with ImageMagick-6.9.12.1.
212
213* Sun May 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.75-1
214- new upstream release.
215
216* Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 3.60-7
217- rebuild under current VineSeed environment
218
219* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 3.60-6
220- rebuild with gcc-5.4.0
221
222* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-5
223- rebuild with ImageMagick-6.9.1.4
224
225* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-4
226- rebuild with ImageMagick-6.8.9.5
227
228* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-3
229- rebuild with ImageMagick-6.8.7.5
230
231* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-2
232- rebuild with ImageMagick-6.8.6.8
233
234* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-1
235- update to 3.60
236- add BuildRequires: ghostscript
237
238* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-3
239- rebuilt with ImageMagick-6.6.4.8
240
241* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-2
242- rebuilt with rpm-4.8.1 for pkg-config
243
244* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-1
245- new upstream release
246- built with new toolchain and ImageMagick-6.6.1.5
247- used ld.so.conf.d instead of ld.so.conf
248
249* Sun Jun 14 2009 Shu KONNO <owa@bg.wakwak.com> 3.45-1
250- applied new versioning policy, and spec in utf-8
251- update pstoedit to 3.45
252- added --disable-static option to %%configure
253- added --without-swf option, because of fail to compile
254
255* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.44-0vl2
256- install plugins_linux.3.42.so only on ix86 archs
257  (what should we do with the intel binary file on other archs, huh?)
258
259* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.44-0vl1
260- rebuilt for VineSeed (4.0)
261- updated to 3.44
262- fixed build dependancy
263
264* Wed Sep 28 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
265- Updated to 3.42
266
267* Tue Jan 11 2005 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
268- Updated to 3.40
269
270* Fri Sep 24 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
271- Added plugins
272- Disable emf support
273
274* Wed Sep 22 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
275- Added buildrequires
276
277* Thu Oct  2 2003  Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
278- initial package
Note: See TracBrowser for help on using the repository browser.