source: projects/specs/trunk/p/pstoedit/pstoedit-vl.spec @ 9687

Revision 9687, 9.2 KB checked in by Takemikaduchi, 9 years ago (diff)

dbus: new upstream release
others: rebuild

Line 
1Name:            pstoedit
2Summary:         Translator of PostScript and PDF graphics into various vector formats
3Summary(ja):     ポストスクリプトやPDFを多種多様なベクタ形式に変換
4Version:         3.60
5Release:         5%{?_dist_release}
6
7Group:           Applications/Graphics
8License:         GPLv2
9URL:             http://www.pstoedit.net/pstoedit
10
11Source0:         http://prdownloads.sourceforge.net/pstoedit/%{name}-%{version}.tar.gz
12#Source1:         http://www.helga-glunz.homepage.t-online.de/plugins/plugins_linux_350.tgz
13
14BuildRoot:       %{_tmppath}/%{name}-%{version}-root
15BuildRequires:   libemf-devel libpng-devel gd-devel
16BuildRequires:   ImageMagick-c++-devel zlib-devel
17BuildRequires:   ghostscript
18BuildRequires:   libtool sed
19
20Vendor:          Project Vine
21Distribution:    Vine Linux
22
23%description
24pstoedit translates PostScript and PDF graphics into other vector
25formats. Currently pstoedit can generate the following formats:
26    * Tgif .obj format (for tgif version >= 3)
27    * .fig format for xfig
28    * pdf - Adobe's Portable Document Format
29    * gnuplot format
30    * Flattened PostScript (with or without Bezier curves)
31    * DXF - CAD exchange format
32    * LWO - LightWave 3D
33    * RIB - RenderMan
34    * RPL - Real3D
35    * Java 1 or Java 2 applet
36    * Idraw format (in fact a special form of EPS that idraw can read)
37    * Tcl/Tk
38    * HPGL
39    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
40    * Windows Meta Files (WMF) (Windows 9x/NT only)
41    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
42    * OS/2 meta files (OS/2 only)
43    * PIC format for troff/groff
44    * MetaPost format for usage with TeX/LaTeX
45    * LaTeX2e picture
46    * Kontour
47    * GNU Metafile (plotutils / libplot)
48    * Sketch ( http://sketch.sourceforge.net )
49    * Mathematica
50    * via ImageMagick to any format supported by ImageMagick
51    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
52
53%description -l ja
54pstoeditはポストスクリプトやPDFを多種多様なベクタ形式に変換します。サ
55ポートしている出力ファイル形式は下記の通りです。
56    *  Tgif .obj format (for tgif version >= 3)
57    * .fig format for xfig
58    * pdf - Adobe's Portable Document Format
59    * gnuplot format
60    * Flattened PostScript (with or without Bezier curves)
61    * DXF - CAD exchange format
62    * LWO - LightWave 3D
63    * RIB - RenderMan
64    * RPL - Real3D
65    * Java 1 or Java 2 applet
66    * Idraw format (in fact a special form of EPS that idraw can read)
67    * Tcl/Tk
68    * HPGL
69    * AI (Adobe Illustrator) (based on ps2ai.ps - not a real pstoedit driver - see notes below and manual)
70    * Windows Meta Files (WMF) (Windows 9x/NT only)
71    * Enhanced Windows Meta Files (EMF) (Windows 9x/NT only)
72    * OS/2 meta files (OS/2 only)
73    * PIC format for troff/groff
74    * MetaPost format for usage with TeX/LaTeX
75    * LaTeX2e picture
76    * Kontour
77    * GNU Metafile (plotutils / libplot)
78    * Sketch ( http://sketch.sourceforge.net )
79    * Mathematica
80    * via ImageMagick to any format supported by ImageMagick
81    * SWF (beta release state - still lot's of features missing (fonts, dash handling, ...)
82
83%package        devel
84Summary:        pstoedit C Library developer.
85Summary(ja):    pstoedit 開発ライブラリ
86Group:          Development/Libraries
87URL:            http://www.pstoedit.net/pstoedit
88Requires:       pstoedit = %{version}-%{release}
89Requires:       libpng-devel libstdc++-devel zlib-devel
90
91%description devel
92pstoedit library
93
94%description -l ja devel
95pstoedit 開発ライブラリ
96
97%prep
98%setup -q
99 %{__perl} -p -i -e 's|BINDIR=/usr/local/bin||' autogen.sh
100
101%build
102./autogen.sh
103libtoolize -c -f
104
105# needed because of definitions in imagemagick headers that break with -pedantic
106sed -ie 's/-pedantic//' configure
107
108%configure  \
109        --disable-static \
110        --without-swf \
111        --with-emf \
112        --with-libemf-lib=%{_libdir} \
113        --with-libemf-include=%{_includedir}/libEMF
114 
115# don't use _smp_mflags
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120
121%makeinstall
122#ifarch %{ix86}
123#{__install} -m 755 plugins_linux_350.so %{buildroot}%{_libdir}/%{name}
124#endif
125
126%{__mkdir_p} $RPM_BUILD_ROOT%{_mandir}/man1
127%{__install} -m 644 doc/%{name}.1  %{buildroot}%{_mandir}/man1
128
129%{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
130echo "%{_libdir}/%{name}" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/pstoedit.conf
131
132# %{__mkdir_p} %{buildroot}%{_bindir}
133# %{__install} -c config/pstoedit-config %{buildroot}%{_bindir}
134# %{__mkdir_p} %{buildroot}%{_datadir}
135# %{__install} -c -m 644 config/pstoedit.m4  %{buildroot}%{_datadir}/aclocal
136# %{__mkdir_p} %{buildroot}%{_datadir}/pstoedit/swffonts
137# %{__install} -c -m 644 misc/swffonts/default.fdb %{buildroot}%{_datadir}/pstoedit/swffonts
138# %{__install} -c -m 644 misc/latex2e.fmp %{buildroot}%{_datadir}/pstoedit
139# %{__install} -c -m 644 misc/mpost.fmp %{buildroot}%{_datadir}/pstoedit
140# %{__install} -c -m 644 misc/safer.ps %{buildroot}%{_datadir}/pstoedit
141# %{__install} -c -m 644 misc/svg.fmp %{buildroot}%{_datadir}/pstoedit
142# %{__install} -c -m 644 misc/wemf.fmp %{buildroot}%{_datadir}/pstoedit
143# %{__install} -c -m 644 misc/examplefigmap.fmp %{buildroot}%{_datadir}/pstoedit
144# ./libtool --mode=install %{__install} -c  src/libpstoedit.la  %{buildroot}%{_libdir}
145# ./libtool --mode=install %{__install} -c  src/pstoedit  %{buildroot}%{_bindir}
146# %{__mkdir_p} %{buildroot}%{_libdir}/pstoedit
147# ./libtool --mode=install %{__install} -c  src/libp2edrvstd.la   %{buildroot}%{_libdir}/pstoedit
148# ./libtool --mode=install %{__install} -c  src/libp2edrvmagick++.la  -inst-prefix %{buildroot} %{buildroot}%{_libdir}/pstoedit
149# %{__install} -c -m 644 src/pstoedit.h  %{buildroot}%{_prefix}/include/pstoedit
150# %{__install} -c -m 644 src/pstoedll.h  %{buildroot}%{_prefix}/include/pstoedit
151# %{__install} -c -m 644 src/pstoeditoutputlib.h  %{buildroot}%{_prefix}/include/pstoedit
152# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
153# %{__install} -c -m 644 src/pstoeditoptions.h  %{buildroot}%{_prefix}/include/pstoedit
154# %{__install} -c -m 644 src/cppcomp.h  %{buildroot}%{_prefix}/include/pstoedit
155# %{__install} -c -m 644 src/drvbase.h  %{buildroot}%{_prefix}/include/pstoedit
156# %{__install} -c -m 644 src/drvfuncs.h  %{buildroot}%{_prefix}/include/pstoedit
157# %{__install} -c -m 644 src/miscutil.h  %{buildroot}%{_prefix}/include/pstoedit
158# %{__install} -c -m 644 src/base64writer.h  %{buildroot}%{_prefix}/include/pstoedit
159# %{__install} -c -m 644 src/poptions.h  %{buildroot}%{_prefix}/include/pstoedit
160# %{__install} -c -m 644 src/ordlist.h  %{buildroot}%{_prefix}/include/pstoedit
161# %{__install} -c -m 644 src/psimage.h  %{buildroot}%{_prefix}/include/pstoedit
162#
163# %{__install} -m 775 lib/pstoedit/plugins_linux.so %{buildroot}%{_libdir}/pstoedit
164# for i in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/pstoedit/*.la
165#  do cp -p $i $i~
166#  sed s:%{buildroot}::g <$i~ >$i
167#  rm $i~
168# done
169#
170
171%clean
172rm -rf $RPM_BUILD_ROOT
173
174%post -p /sbin/ldconfig
175
176%postun -p /sbin/ldconfig
177
178%files
179%defattr(-,root,root)
180%doc copying doc/*.htm
181%{_sysconfdir}/ld.so.conf.d/%{name}.conf
182%{_bindir}/pstoedit
183%{_libdir}/*.so.*
184%dir %{_libdir}/pstoedit
185%{_libdir}/%{name}/*.so
186%{_libdir}/%{name}/*.so.*
187%{_datadir}/%{name}
188%{_mandir}/*/*
189
190%files devel
191%defattr(-,root,root)
192%{_libdir}/*.so
193%{_includedir}/pstoedit/*
194%{_libdir}/pkgconfig/*.pc
195%{_datadir}/aclocal/*
196%exclude %{_libdir}/*.la
197%exclude %{_libdir}/pstoedit/*.la
198
199%changelog
200* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-5
201- rebuild with ImageMagick-6.9.1.4
202
203* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-4
204- rebuild with ImageMagick-6.8.9.5
205
206* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-3
207- rebuild with ImageMagick-6.8.7.5
208
209* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-2
210- rebuild with ImageMagick-6.8.6.8
211
212* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.60-1
213- update to 3.60
214- add BuildRequires: ghostscript
215
216* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-3
217- rebuilt with ImageMagick-6.6.4.8
218
219* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-2
220- rebuilt with rpm-4.8.1 for pkg-config
221
222* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-1
223- new upstream release
224- built with new toolchain and ImageMagick-6.6.1.5
225- used ld.so.conf.d instead of ld.so.conf
226
227* Sun Jun 14 2009 Shu KONNO <owa@bg.wakwak.com> 3.45-1
228- applied new versioning policy, and spec in utf-8
229- update pstoedit to 3.45
230- added --disable-static option to %%configure
231- added --without-swf option, because of fail to compile
232
233* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.44-0vl2
234- install plugins_linux.3.42.so only on ix86 archs
235  (what should we do with the intel binary file on other archs, huh?)
236
237* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.44-0vl1
238- rebuilt for VineSeed (4.0)
239- updated to 3.44
240- fixed build dependancy
241
242* Wed Sep 28 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
243- Updated to 3.42
244
245* Tue Jan 11 2005 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
246- Updated to 3.40
247
248* Fri Sep 24 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
249- Added plugins
250- Disable emf support
251
252* Wed Sep 22 2004 Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
253- Added buildrequires
254
255* Thu Oct  2 2003  Susumu Tanimura  <stanimura-ngs@umin.ac.jp>
256- initial package
Note: See TracBrowser for help on using the repository browser.