source: projects/specs/trunk/p/pspp/pspp-vl.spec @ 12295

Revision 12295, 3.8 KB checked in by ara_t, 5 years ago (diff)

pspp: update to 1.2.0

Line 
1%define pkg_name    pspp
2%define pkg_version 1.2.0
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A program for statistical analysis of sampled data
6Summary(ja): データ統計解析用プログラム
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License: GPLv3+
12Group:   Applications/Edutainment
13URL:     http://www.gnu.org/software/pspp/
14Source0: http://public.p-knowledge.co.jp/gnu-mirror/pspp/pspp-%{version}.tar.gz
15
16# PATCH-FIX-UPSTREAM CVE-2018-20230.patch bnc#1120061 CVE-2018-20230
17Patch0: CVE-2018-20230.patch
18# PATCH-FIX-UPSTREAM CVE-2019-9211.patch boo#1127343 CVE-2019-9211
19Patch1: CVE-2019-9211.patch
20# Fix build with Texinfo 4.13 for openSUSE Leap 42.*
21Patch2: avoid_old_Texinfo_4.13.patch
22
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24
25BuildRequires: m4
26BuildRequires: gettext
27BuildRequires: texinfo
28BuildRequires: desktop-file-utils
29
30BuildRequires: gtk3-devel >= 3.14.5
31BuildRequires: gtksourceview3-devel
32BuildRequires: spread-sheet-widget-devel >= 0.3
33BuildRequires: readline-devel
34BuildRequires: pango-devel
35BuildRequires: cairo-devel
36BuildRequires: gsl-devel >= 1.12
37BuildRequires: libglade2-devel
38BuildRequires: libxml2-devel
39BuildRequires: postgresql-devel
40BuildRequires: zlib-devel
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: ara_t
45
46
47%description
48PSPP is a program for statistical analysis of sampled data.
49It is a free replacement for the proprietary program SPSS.
50
51PSPP supports t-tests, ANOVA, GLM, factor analysis, non-parametric tests,
52and other statistical features. PSPP produces statistical reports
53in plain text, PDF, PostScript, CSV, HTML, SVG, and OpenDocument formats.
54
55PSPP has both text-based and graphical user interfaces.
56The PSPP user interface has been translated into a number of languages.
57
58
59%prep
60%{__rm} -rf ${RPM_BUILD_ROOT}
61%setup -q
62
63%patch0 -p1
64%patch1 -p1
65%patch2 -p1
66
67%build
68autoreconf -f -i
69%configure \
70    --disable-relocatable \
71    --disable-static \
72    --disable-rpath \
73    --enable-debug \
74    --without-libreadline-prefix \
75    --docdir=%{_docdir}/%{name}-%{version}
76
77%{__make} %{?_smp_mflags}
78
79%install
80%{make_install}
81
82%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/pspp/*.la
83%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
84
85# modify desktop file
86%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
87 ${RPM_BUILD_ROOT}%{_datadir}/applications/pspp.desktop
88
89#Config for ld
90%{__mkdir_p} %{buildroot}/etc/ld.so.conf.d
91cat >${RPM_BUILD_ROOT}/etc/ld.so.conf.d/pspp.conf << EOF
92%{_libdir}/pspp
93EOF
94
95# localization
96%find_lang pspp
97
98# %check
99# %%{__make} check || cat ./tests/testsuite.log
100
101%post
102for doc in pspp pspp-dev; do
103    file=%{_infodir}/${doc}.info.gz
104    if [ -e ${file} ]; then
105        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
106    fi
107done
108%{_syssbindir}/ldconfig
109
110%preun
111if [ $1 = 0 ]; then
112    for doc in pspp pspp-dev; do
113        file=%{_infodir}/${doc}.info.gz
114        if [ -e ${file} ]; then
115            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
116        fi
117    done
118fi
119
120%postun -p %{_syssbindir}/ldconfig
121
122
123%files -f pspp.lang
124%defattr(-,root,root,-)
125%doc README COPYING THANKS AUTHORS
126# tests/testsuite.log
127%config(noreplace) /etc/ld.so.conf.d/pspp.conf
128%{_bindir}/pspp
129%{_bindir}/psppire
130%{_bindir}/pspp-dump-sav
131%{_bindir}/pspp-convert
132%dir %{_libdir}/pspp
133%{_libdir}/pspp/*.so
134%{_datadir}/applications/pspp.desktop
135%{_datadir}/appdata/pspp.appdata.xml
136%{_datadir}/icons/
137%dir %{_datadir}/pspp
138%{_datadir}/pspp/
139%{_infodir}/pspp*
140%{_mandir}/man1/
141%{_docdir}/
142
143
144%changelog
145* Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 1.2.0-1
146- update to 1.2.0
147
148* Mon Jun 04 2018 Toshiaki Ara <ara_t@384.jp> 1.0.1-3
149- correct description
150- add Packager: ara_t
151
152* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 1.0.1-2
153- rebuild under gsl-2.4
154
155* Sun Oct 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
156- new package
157
Note: See TracBrowser for help on using the repository browser.