source: projects/specs/trunk/p/pspp/pspp-vl.spec @ 11701

Revision 11701, 2.8 KB checked in by ara_t, 6 years ago (diff)

pspp: correct Description

Line 
1%define pkg_name    pspp
2%define pkg_version 1.0.1
3%define pkg_release 3%{?_dist_release}
4
5Summary:     A program for statistical analysis of sampled data
6Summary(ja): データ統計解析用プログラム
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License: GPLv3 or later
12Group:   Applications/Edutainment
13URL:     http://www.gnu.org/software/pspp/
14Source0: http://public.p-knowledge.co.jp/gnu-mirror/pspp/pspp-%{version}.tar.gz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: texinfo
19BuildRequires: readline-devel
20BuildRequires: gtk3-devel gtksourceview3-devel
21BuildRequires: gsl-devel
22BuildRequires: plotutils-devel
23
24Requires: gtk3 gtksourceview3
25Requires: gsl
26Requires: plotutils
27
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: ara_t
32
33
34%description
35PSPP is a program for statistical analysis of sampled data.
36It is a free replacement for the proprietary program SPSS.
37
38PSPP supports t-tests, ANOVA, GLM, factor analysis, non-parametric tests,
39and other statistical features. PSPP produces statistical reports
40in plain text, PDF, PostScript, CSV, HTML, SVG, and OpenDocument formats.
41
42PSPP has both text-based and graphical user interfaces.
43The PSPP user interface has been translated into a number of languages.
44
45
46%prep
47%{__rm} -rf ${RPM_BUILD_ROOT}
48%setup -q
49
50%build
51%{configure} \
52 --disable-static \
53 --docdir=%{_docdir}/%{name}-%{version}
54
55%{__make} %{?_smp_mflags}
56
57%check
58%{__make} check
59
60%install
61%{make_install}
62%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/pspp/*.la
63%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
64
65%{__cp} AUTHORS COPYING ChangeLog NEWS ONEWS README THANKS TODO \
66        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
67
68# modify desktop file
69%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
70 ${RPM_BUILD_ROOT}%{_datadir}/applications/pspp.desktop
71
72%clean
73%{__rm} -rf ${RPM_BUILD_ROOT}
74
75%post
76for doc in pspp pspp-dev; do
77    file=%{_infodir}/${doc}.info.gz
78    if [ -e ${file} ]; then
79        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
80    fi
81done
82%{_syssbindir}/ldconfig
83
84%preun
85if [ $1 = 0 ]; then
86    for doc in pspp pspp-dev; do
87        file=%{_infodir}/${doc}.info.gz
88        if [ -e ${file} ]; then
89            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
90        fi
91    done
92fi
93
94%postun -p %{_syssbindir}/ldconfig
95
96
97%files
98%defattr(-,root,root)
99%{_bindir}/
100%{_libdir}/pspp/
101%{_datadir}/appdata/
102%{_datadir}/applications/
103%{_datadir}/icons/
104%{_datadir}/locale/
105%{_datadir}/pspp
106%{_infodir}/
107%{_mandir}/man1/
108%{_docdir}/
109
110
111%changelog
112* Mon Jun 04 2018 Toshiaki Ara <ara_t@384.jp> 1.0.1-3
113- correct description
114- add Packager: ara_t
115
116* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 1.0.1-2
117- rebuild under gsl-2.4
118
119* Sun Oct 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
120- new package
121
Note: See TracBrowser for help on using the repository browser.